Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1683326 > unrolled thread
| Started by | "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> |
|---|---|
| First post | 2017-07-07 19:10 +0200 |
| Last post | 2017-07-09 14:30 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH v2 0/3] kernel/kprobes: A few trivial updates to jprobes "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> - 2017-07-07 19:10 +0200
Re: [PATCH v2 0/3] kernel/kprobes: A few trivial updates to jprobes Masami Hiramatsu <mhiramat@kernel.org> - 2017-07-09 14:30 +0200
| From | "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> |
|---|---|
| Date | 2017-07-07 19:10 +0200 |
| Subject | [PATCH v2 0/3] kernel/kprobes: A few trivial updates to jprobes |
| Message-ID | <u0EVs-71k-7@gated-at.bofh.it> |
Here is v2 of the patch:
https://www.mail-archive.com/linux-kernel@vger.kernel.org/msg1434133.html
As suggested, the first two patches first clean up the existing jprobe
registration functions and rename function_offset_within_entry() to
kprobe_on_func_entry(). The last patch has been updated accordingly.
Thanks,
Naveen
Naveen N. Rao (3):
kernel/kprobes: Rename [arch_]function_offset_within_entry() to
[arch_]kprobe_on_func_entry()
kernel/kprobes: Simplify register_jprobes()
kernel/kprobes: Ensure that jprobe probepoints are at function entry
arch/powerpc/kernel/kprobes.c | 2 +-
include/linux/kprobes.h | 4 ++--
kernel/kprobes.c | 42 ++++++++++++++++++++++++------------------
kernel/trace/trace_kprobe.c | 2 +-
4 files changed, 28 insertions(+), 22 deletions(-)
--
2.13.2
[toc] | [next] | [standalone]
| From | Masami Hiramatsu <mhiramat@kernel.org> |
|---|---|
| Date | 2017-07-09 14:30 +0200 |
| Message-ID | <u1jvz-7G7-9@gated-at.bofh.it> |
| In reply to | #1683326 |
On Fri, 7 Jul 2017 22:37:23 +0530 "Naveen N. Rao" <naveen.n.rao@linux.vnet.ibm.com> wrote: > Here is v2 of the patch: > https://www.mail-archive.com/linux-kernel@vger.kernel.org/msg1434133.html > > As suggested, the first two patches first clean up the existing jprobe > registration functions and rename function_offset_within_entry() to > kprobe_on_func_entry(). The last patch has been updated accordingly. This series looks good to me. Acked-by: Masami Hiramatsu <mhiramat@kernel.org> Thanks! > > Thanks, > Naveen > > Naveen N. Rao (3): > kernel/kprobes: Rename [arch_]function_offset_within_entry() to > [arch_]kprobe_on_func_entry() > kernel/kprobes: Simplify register_jprobes() > kernel/kprobes: Ensure that jprobe probepoints are at function entry > > arch/powerpc/kernel/kprobes.c | 2 +- > include/linux/kprobes.h | 4 ++-- > kernel/kprobes.c | 42 ++++++++++++++++++++++++------------------ > kernel/trace/trace_kprobe.c | 2 +- > 4 files changed, 28 insertions(+), 22 deletions(-) > > -- > 2.13.2 > -- Masami Hiramatsu <mhiramat@kernel.org>
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web