Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1621496 > unrolled thread

Re: [PATCH 03/17] thermal: cpu_cooling: Replace cpufreq_device with cpufreq_dev

Started byEduardo Valentin <edubezval@gmail.com>
First post2017-04-11 19:40 +0200
Last post2017-04-12 08:20 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH 03/17] thermal: cpu_cooling: Replace cpufreq_device with  cpufreq_dev Eduardo Valentin <edubezval@gmail.com> - 2017-04-11 19:40 +0200
    Re: [PATCH 03/17] thermal: cpu_cooling: Replace cpufreq_device with  cpufreq_dev Viresh Kumar <viresh.kumar@linaro.org> - 2017-04-12 08:20 +0200

#1621496 — Re: [PATCH 03/17] thermal: cpu_cooling: Replace cpufreq_device with cpufreq_dev

FromEduardo Valentin <edubezval@gmail.com>
Date2017-04-11 19:40 +0200
SubjectRe: [PATCH 03/17] thermal: cpu_cooling: Replace cpufreq_device with cpufreq_dev
Message-ID<tv7VL-1CC-3@gated-at.bofh.it>

[Multipart message — attachments visible in raw view] — view raw

On Thu, Mar 16, 2017 at 10:59:38AM +0530, Viresh Kumar wrote:
> Objects of "struct cpufreq_cooling_device" are named a bit
> inconsistently. Lets use cpufreq_dev everywhere.
> 

Naming is always a matter of taste.. but I frankly cannot see how this
patch improves anything here. cpufreq_dev is still misleading.

Here other options:
 cpufreq_cooling_dev: not misleading but, may a bit too long..
 cpufreq_cdev: better, but still, not a char dev

> Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>

[toc] | [next] | [standalone]


#1621830

FromViresh Kumar <viresh.kumar@linaro.org>
Date2017-04-12 08:20 +0200
Message-ID<tvjNf-10A-3@gated-at.bofh.it>
In reply to#1621496
On 11-04-17, 10:33, Eduardo Valentin wrote:
> On Thu, Mar 16, 2017 at 10:59:38AM +0530, Viresh Kumar wrote:
> > Objects of "struct cpufreq_cooling_device" are named a bit
> > inconsistently. Lets use cpufreq_dev everywhere.
> > 
> 
> Naming is always a matter of taste.. but I frankly cannot see how this
> patch improves anything here. cpufreq_dev is still misleading.

I wasn't trying to get to a better name, but rather be consistent.

> Here other options:
>  cpufreq_cooling_dev: not misleading but, may a bit too long..
>  cpufreq_cdev: better, but still, not a char dev

I will go for the second one.

-- 
viresh

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web