Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1616596 > unrolled thread

Re: [PATCH] cgroup: switch to BUG_ON()

Started byZefan Li <lizefan@huawei.com>
First post2017-04-05 08:00 +0200
Last post2017-04-05 08:00 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH] cgroup: switch to BUG_ON() Zefan Li <lizefan@huawei.com> - 2017-04-05 08:00 +0200

#1616596 — Re: [PATCH] cgroup: switch to BUG_ON()

FromZefan Li <lizefan@huawei.com>
Date2017-04-05 08:00 +0200
SubjectRe: [PATCH] cgroup: switch to BUG_ON()
Message-ID<tsM94-6Yl-17@gated-at.bofh.it>
On 2017/3/27 0:24, Nicholas Mc Guire wrote:
> Use BUG_ON() rather than an explicit if followed by BUG() for 
> improved readability and also consistency.
> 
> Signed-off-by: Nicholas Mc Guire <der.herr@hofr.at>
> ---
> 
> Found by coccinelle: bugon.cocci
> ./kernel/cgroup/cpuset.c:2125:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG.
> ./kernel/cgroup/cpuset.c:2127:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG.
> ./kernel/cgroup/cpuset.c:2143:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG.
> 
> BUG_ON() wraps the explicit if condition and is actually in use for
> all conditional BUG() cases in cpuset.c except in this one function.
> 
> Patch was compile-tested with: x86_64_defconfig (implies CONFIG_CPUSETS=y)
> (checkpatch warnings for this patch seem to be false-positives - the 
>  BUG_ON should be fine)
> 
> Patch is against 4.11-rc3 (localversion-next is next-20170324)
> 

Acked-by: Zefan Li <lizefan@huawei.com>

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web