Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1611272 > unrolled thread

[PATCH] Regulator: core.c: Fix kerneldoc comments

Started byTamara Diaconita <diaconitatamara@gmail.com>
First post2017-03-28 20:40 +0200
Last post2017-03-29 13:10 +0200
Articles 4 — 3 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] Regulator: core.c: Fix kerneldoc comments Tamara Diaconita <diaconitatamara@gmail.com> - 2017-03-28 20:40 +0200
    Re: [Outreachy kernel] [PATCH] Regulator: core.c: Fix kerneldoc  comments Julia Lawall <julia.lawall@lip6.fr> - 2017-03-28 22:00 +0200
    Re: [PATCH] Regulator: core.c: Fix kerneldoc comments Mark Brown <broonie@kernel.org> - 2017-03-29 12:40 +0200
    Applied "regulator: core: Fix kerneldoc comments" to the regulator tree Mark Brown <broonie@kernel.org> - 2017-03-29 13:10 +0200

#1611272 — [PATCH] Regulator: core.c: Fix kerneldoc comments

FromTamara Diaconita <diaconitatamara@gmail.com>
Date2017-03-28 20:40 +0200
Subject[PATCH] Regulator: core.c: Fix kerneldoc comments
Message-ID<tq4ca-3fq-17@gated-at.bofh.it>
Remove the description for the non-existing 'ret' to fix the build warning:
./drivers/regulator/core.c:1467: warning:
Excess function parameter 'ret' description in 'regulator_dev_lookup'.
The description found for the return value is: @ret: 0 on success, -ENODEV
if lookup fails permanently, -EPROBE_DEFER if lookup could succeed in the future.


Signed-off-by: Tamara Diaconita <diaconita.tamara@gmail.com>
---
 drivers/regulator/core.c | 2 --
 1 file changed, 2 deletions(-)

diff --git a/drivers/regulator/core.c b/drivers/regulator/core.c
index 53d4fc7..219b665 100644
--- a/drivers/regulator/core.c
+++ b/drivers/regulator/core.c
@@ -1451,8 +1451,6 @@ static struct regulator_dev *regulator_lookup_by_name(const char *name)
  * regulator_dev_lookup - lookup a regulator device.
  * @dev: device for regulator "consumer".
  * @supply: Supply name or regulator ID.
- * @ret: 0 on success, -ENODEV if lookup fails permanently, -EPROBE_DEFER if
- * lookup could succeed in the future.
  *
  * If successful, returns a struct regulator_dev that corresponds to the name
  * @supply and with the embedded struct device refcount incremented by one.
-- 
2.9.3

[toc] | [next] | [standalone]


#1611328 — Re: [Outreachy kernel] [PATCH] Regulator: core.c: Fix kerneldoc comments

FromJulia Lawall <julia.lawall@lip6.fr>
Date2017-03-28 22:00 +0200
SubjectRe: [Outreachy kernel] [PATCH] Regulator: core.c: Fix kerneldoc comments
Message-ID<tq5rz-43j-9@gated-at.bofh.it>
In reply to#1611272

On Tue, 28 Mar 2017, Tamara Diaconita wrote:

> Remove the description for the non-existing 'ret' to fix the build warning:
> ./drivers/regulator/core.c:1467: warning:
> Excess function parameter 'ret' description in 'regulator_dev_lookup'.
> The description found for the return value is: @ret: 0 on success, -ENODEV
> if lookup fails permanently, -EPROBE_DEFER if lookup could succeed in the future.

Fine for this patch, but if you are finding more of these, I don't think
you need to quote the removed text in the commit log.  One can see it just
below in the patch.  Actually,

"Remove the description for the non-existent parameter ret.  Problem
detected using the kerneldoc build."

seems like it would be sufficient.

julia

>
>
> Signed-off-by: Tamara Diaconita <diaconita.tamara@gmail.com>
> ---
>  drivers/regulator/core.c | 2 --
>  1 file changed, 2 deletions(-)
>
> diff --git a/drivers/regulator/core.c b/drivers/regulator/core.c
> index 53d4fc7..219b665 100644
> --- a/drivers/regulator/core.c
> +++ b/drivers/regulator/core.c
> @@ -1451,8 +1451,6 @@ static struct regulator_dev *regulator_lookup_by_name(const char *name)
>   * regulator_dev_lookup - lookup a regulator device.
>   * @dev: device for regulator "consumer".
>   * @supply: Supply name or regulator ID.
> - * @ret: 0 on success, -ENODEV if lookup fails permanently, -EPROBE_DEFER if
> - * lookup could succeed in the future.
>   *
>   * If successful, returns a struct regulator_dev that corresponds to the name
>   * @supply and with the embedded struct device refcount incremented by one.
> --
> 2.9.3
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/20170328183021.2683-1-diaconita.tamara%40gmail.com.
> For more options, visit https://groups.google.com/d/optout.
>

[toc] | [prev] | [next] | [standalone]


#1611804

FromMark Brown <broonie@kernel.org>
Date2017-03-29 12:40 +0200
Message-ID<tqjbc-5zA-31@gated-at.bofh.it>
In reply to#1611272

[Multipart message — attachments visible in raw view] — view raw

On Tue, Mar 28, 2017 at 09:30:21PM +0300, Tamara Diaconita wrote:
> Remove the description for the non-existing 'ret' to fix the build warning:
> ./drivers/regulator/core.c:1467: warning:
> Excess function parameter 'ret' description in 'regulator_dev_lookup'.
> The description found for the return value is: @ret: 0 on success, -ENODEV
> if lookup fails permanently, -EPROBE_DEFER if lookup could succeed in the future.

Please word wrap your commit messages within paragraphs at something
substantially less than 80 columns.  Doing this makes your messages much
easier to read and reply to and ensures that the changelogs display well
in the git UI.

[toc] | [prev] | [next] | [standalone]


#1611825 — Applied "regulator: core: Fix kerneldoc comments" to the regulator tree

FromMark Brown <broonie@kernel.org>
Date2017-03-29 13:10 +0200
SubjectApplied "regulator: core: Fix kerneldoc comments" to the regulator tree
Message-ID<tqjEe-60u-3@gated-at.bofh.it>
In reply to#1611272
The patch

   regulator: core: Fix kerneldoc comments

has been applied to the regulator tree at

   git://git.kernel.org/pub/scm/linux/kernel/git/broonie/regulator.git 

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.  

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark

From fffd1133388857f5b4b8c588b41b2ade16c7891c Mon Sep 17 00:00:00 2001
From: Tamara Diaconita <diaconitatamara@gmail.com>
Date: Tue, 28 Mar 2017 21:30:21 +0300
Subject: [PATCH] regulator: core: Fix kerneldoc comments

Remove the description for the non-existing 'ret' to fix the build warning:
./drivers/regulator/core.c:1467: warning:
Excess function parameter 'ret' description in 'regulator_dev_lookup'.
The description found for the return value is: @ret: 0 on success, -ENODEV
if lookup fails permanently, -EPROBE_DEFER if lookup could succeed in the future.

Signed-off-by: Tamara Diaconita <diaconita.tamara@gmail.com>
Signed-off-by: Mark Brown <broonie@kernel.org>
---
 drivers/regulator/core.c | 2 --
 1 file changed, 2 deletions(-)

diff --git a/drivers/regulator/core.c b/drivers/regulator/core.c
index 49a0b6a2e237..c20b28a63d15 100644
--- a/drivers/regulator/core.c
+++ b/drivers/regulator/core.c
@@ -1451,8 +1451,6 @@ static struct regulator_dev *regulator_lookup_by_name(const char *name)
  * regulator_dev_lookup - lookup a regulator device.
  * @dev: device for regulator "consumer".
  * @supply: Supply name or regulator ID.
- * @ret: 0 on success, -ENODEV if lookup fails permanently, -EPROBE_DEFER if
- * lookup could succeed in the future.
  *
  * If successful, returns a struct regulator_dev that corresponds to the name
  * @supply and with the embedded struct device refcount incremented by one.
-- 
2.11.0

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web