Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1593304 > unrolled thread

[PATCH] x86/apic: Fix a comment in init_apic_mappings()

Started byDou Liyang <douly.fnst@cn.fujitsu.com>
First post2017-03-06 14:10 +0100
Last post2017-03-13 21:50 +0100
Articles 3 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH] x86/apic: Fix a comment in init_apic_mappings() Dou Liyang <douly.fnst@cn.fujitsu.com> - 2017-03-06 14:10 +0100
    [tip:x86/apic] x86/apic: Fix a comment in init_apic_mappings() tip-bot for Dou Liyang <tipbot@zytor.com> - 2017-03-13 21:50 +0100
    [tip:timers/core] x86/apic: Fix a comment in init_apic_mappings() tip-bot for Dou Liyang <tipbot@zytor.com> - 2017-03-13 21:50 +0100

#1593304 — [PATCH] x86/apic: Fix a comment in init_apic_mappings()

FromDou Liyang <douly.fnst@cn.fujitsu.com>
Date2017-03-06 14:10 +0100
Subject[PATCH] x86/apic: Fix a comment in init_apic_mappings()
Message-ID<ti0yK-9I-21@gated-at.bofh.it>
The commit c0104d38a740 ("x86, apic: Unify identical
register_lapic_address() functions") renames acpi_register_lapic_address
to register_lapic_address.

But acpi_register_lapic_address remains in a comment, and renaming it
to register_lapic_address is not suitable for this comment.

Remove acpi_register_lapic_address and rewrite the comment.

Signed-off-by: Dou Liyang <douly.fnst@cn.fujitsu.com>
---
 arch/x86/kernel/apic/apic.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/x86/kernel/apic/apic.c b/arch/x86/kernel/apic/apic.c
index 4261b32..70b0243 100644
--- a/arch/x86/kernel/apic/apic.c
+++ b/arch/x86/kernel/apic/apic.c
@@ -1798,8 +1798,8 @@ void __init init_apic_mappings(void)
 		apic_phys = mp_lapic_addr;
 
 		/*
-		 * acpi lapic path already maps that address in
-		 * acpi_register_lapic_address()
+		 * ACPI LAPIC path already maps that address during
+		 * early parsing LAPIC address in MADT
 		 */
 		if (!acpi_lapic && !smp_found_config)
 			register_lapic_address(apic_phys);
-- 
2.5.5

[toc] | [next] | [standalone]


#1599804 — [tip:x86/apic] x86/apic: Fix a comment in init_apic_mappings()

Fromtip-bot for Dou Liyang <tipbot@zytor.com>
Date2017-03-13 21:50 +0100
Subject[tip:x86/apic] x86/apic: Fix a comment in init_apic_mappings()
Message-ID<tkF4L-5ZL-59@gated-at.bofh.it>
In reply to#1593304
Commit-ID:  5ba039a55498d78a787edaf8cc915f29a17cecf3
Gitweb:     http://git.kernel.org/tip/5ba039a55498d78a787edaf8cc915f29a17cecf3
Author:     Dou Liyang <douly.fnst@cn.fujitsu.com>
AuthorDate: Mon, 6 Mar 2017 21:08:10 +0800
Committer:  Thomas Gleixner <tglx@linutronix.de>
CommitDate: Mon, 13 Mar 2017 21:42:11 +0100

x86/apic: Fix a comment in init_apic_mappings()

commit c0104d38a740 ("x86, apic: Unify identical register_lapic_address()
functions") renames acpi_register_lapic_address to register_lapic_address.

But acpi_register_lapic_address remains in a comment, and renaming it to
register_lapic_address is not suitable for this comment.

Remove acpi_register_lapic_address and rewrite the comment.

[ tglx: LAPIC address can be registered either by ACPI/MADT or MP info ]

Signed-off-by: Dou Liyang <douly.fnst@cn.fujitsu.com>
Cc: yinghai@kernel.org
Link: http://lkml.kernel.org/r/1488805690-5055-1-git-send-email-douly.fnst@cn.fujitsu.com
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>

---
 arch/x86/kernel/apic/apic.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/x86/kernel/apic/apic.c b/arch/x86/kernel/apic/apic.c
index f3034ba..192e909 100644
--- a/arch/x86/kernel/apic/apic.c
+++ b/arch/x86/kernel/apic/apic.c
@@ -1789,8 +1789,8 @@ void __init init_apic_mappings(void)
 		apic_phys = mp_lapic_addr;
 
 		/*
-		 * acpi lapic path already maps that address in
-		 * acpi_register_lapic_address()
+		 * If the system has ACPI MADT tables or MP info, the LAPIC
+		 * address is already registered.
 		 */
 		if (!acpi_lapic && !smp_found_config)
 			register_lapic_address(apic_phys);

[toc] | [prev] | [next] | [standalone]


#1599806 — [tip:timers/core] x86/apic: Fix a comment in init_apic_mappings()

Fromtip-bot for Dou Liyang <tipbot@zytor.com>
Date2017-03-13 21:50 +0100
Subject[tip:timers/core] x86/apic: Fix a comment in init_apic_mappings()
Message-ID<tkF4L-5ZL-57@gated-at.bofh.it>
In reply to#1593304
Commit-ID:  ad258524b64756834f5fe23620beedb7c3609dc8
Gitweb:     http://git.kernel.org/tip/ad258524b64756834f5fe23620beedb7c3609dc8
Author:     Dou Liyang <douly.fnst@cn.fujitsu.com>
AuthorDate: Mon, 6 Mar 2017 21:08:10 +0800
Committer:  Thomas Gleixner <tglx@linutronix.de>
CommitDate: Mon, 13 Mar 2017 21:40:14 +0100

x86/apic: Fix a comment in init_apic_mappings()

commit c0104d38a740 ("x86, apic: Unify identical register_lapic_address()
functions") renames acpi_register_lapic_address to register_lapic_address.

But acpi_register_lapic_address remains in a comment, and renaming it to
register_lapic_address is not suitable for this comment.

Remove acpi_register_lapic_address and rewrite the comment.

[ tglx: LAPIC address can be registered either by ACPI/MADT or MP info ]

Signed-off-by: Dou Liyang <douly.fnst@cn.fujitsu.com>
Cc: yinghai@kernel.org
Link: http://lkml.kernel.org/r/1488805690-5055-1-git-send-email-douly.fnst@cn.fujitsu.com
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>

---
 arch/x86/kernel/apic/apic.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/x86/kernel/apic/apic.c b/arch/x86/kernel/apic/apic.c
index aee7ded..100c43f 100644
--- a/arch/x86/kernel/apic/apic.c
+++ b/arch/x86/kernel/apic/apic.c
@@ -1789,8 +1789,8 @@ void __init init_apic_mappings(void)
 		apic_phys = mp_lapic_addr;
 
 		/*
-		 * acpi lapic path already maps that address in
-		 * acpi_register_lapic_address()
+		 * If the system has ACPI MADT tables or MP info, the LAPIC
+		 * address is already registered.
 		 */
 		if (!acpi_lapic && !smp_found_config)
 			register_lapic_address(apic_phys);

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web