Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1598475 > unrolled thread

[PATCH net-next v2 10/17] net: dsa: mv88e6xxx: rename new FID helper

Started byVivien Didelot <vivien.didelot@savoirfairelinux.com>
First post2017-03-11 22:20 +0100
Last post2017-03-11 22:20 +0100
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH net-next v2 10/17] net: dsa: mv88e6xxx: rename new FID helper Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-11 22:20 +0100

#1598475 — [PATCH net-next v2 10/17] net: dsa: mv88e6xxx: rename new FID helper

FromVivien Didelot <vivien.didelot@savoirfairelinux.com>
Date2017-03-11 22:20 +0100
Subject[PATCH net-next v2 10/17] net: dsa: mv88e6xxx: rename new FID helper
Message-ID<tjWAG-8vE-29@gated-at.bofh.it>
Rename the _mv88e6xxx_fid_new helper to mv88e6xxx_atu_new to get rid of
the old underscore prefix naming convention and be consistent with the
rest of the chip-wide ATU API.

Signed-off-by: Vivien Didelot <vivien.didelot@savoirfairelinux.com>
Reviewed-by: Andrew Lunn <andrew@lunn.ch>
---
 drivers/net/dsa/mv88e6xxx/chip.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/net/dsa/mv88e6xxx/chip.c b/drivers/net/dsa/mv88e6xxx/chip.c
index a11e5354f14f..df31c2c57e09 100644
--- a/drivers/net/dsa/mv88e6xxx/chip.c
+++ b/drivers/net/dsa/mv88e6xxx/chip.c
@@ -1556,7 +1556,7 @@ static int _mv88e6xxx_stu_loadpurge(struct mv88e6xxx_chip *chip,
 	return _mv88e6xxx_vtu_cmd(chip, GLOBAL_VTU_OP_STU_LOAD_PURGE);
 }
 
-static int _mv88e6xxx_fid_new(struct mv88e6xxx_chip *chip, u16 *fid)
+static int mv88e6xxx_atu_new(struct mv88e6xxx_chip *chip, u16 *fid)
 {
 	DECLARE_BITMAP(fid_bitmap, MV88E6XXX_N_FID);
 	struct mv88e6xxx_vtu_entry vlan;
@@ -1610,7 +1610,7 @@ static int _mv88e6xxx_vtu_new(struct mv88e6xxx_chip *chip, u16 vid,
 	};
 	int i, err;
 
-	err = _mv88e6xxx_fid_new(chip, &vlan.fid);
+	err = mv88e6xxx_atu_new(chip, &vlan.fid);
 	if (err)
 		return err;
 
-- 
2.12.0

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web