Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1595398 > unrolled thread
| Started by | Bartosz Golaszewski <bgolaszewski@baylibre.com> |
|---|---|
| First post | 2017-03-08 18:20 +0100 |
| Last post | 2017-03-09 11:50 +0100 |
| Articles | 4 — 3 participants |
Back to article view | Back to linux.kernel
[PATCH v2] irq: generic-chip: provide irq_free_generic_chip() Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2017-03-08 18:20 +0100
Re: [PATCH v2] irq: generic-chip: provide irq_free_generic_chip() Marc Zyngier <marc.zyngier@arm.com> - 2017-03-09 09:10 +0100
Re: [PATCH v2] irq: generic-chip: provide irq_free_generic_chip() Thomas Gleixner <tglx@linutronix.de> - 2017-03-09 11:20 +0100
Re: [PATCH v2] irq: generic-chip: provide irq_free_generic_chip() Bartosz Golaszewski <bgolaszewski@baylibre.com> - 2017-03-09 11:50 +0100
| From | Bartosz Golaszewski <bgolaszewski@baylibre.com> |
|---|---|
| Date | 2017-03-08 18:20 +0100 |
| Subject | [PATCH v2] irq: generic-chip: provide irq_free_generic_chip() |
| Message-ID | <tiNpM-1c7-19@gated-at.bofh.it> |
Some users of irq_alloc_generic_chip() are modules which can be
removed (e.g. gpio-ml-ioh) but have no means of freeing the allocated
generic chip. Provide a function for that.
Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
---
v1 -> v2:
- added the kernel doc
include/linux/irq.h | 1 +
kernel/irq/generic-chip.c | 12 ++++++++++++
2 files changed, 13 insertions(+)
diff --git a/include/linux/irq.h b/include/linux/irq.h
index f887351..04e5120 100644
--- a/include/linux/irq.h
+++ b/include/linux/irq.h
@@ -950,6 +950,7 @@ void irq_setup_generic_chip(struct irq_chip_generic *gc, u32 msk,
int irq_setup_alt_chip(struct irq_data *d, unsigned int type);
void irq_remove_generic_chip(struct irq_chip_generic *gc, u32 msk,
unsigned int clr, unsigned int set);
+void irq_free_generic_chip(struct irq_chip_generic *gc);
struct irq_chip_generic *irq_get_domain_generic_chip(struct irq_domain *d, unsigned int hw_irq);
diff --git a/kernel/irq/generic-chip.c b/kernel/irq/generic-chip.c
index ee32870..242836e 100644
--- a/kernel/irq/generic-chip.c
+++ b/kernel/irq/generic-chip.c
@@ -545,6 +545,18 @@ void irq_remove_generic_chip(struct irq_chip_generic *gc, u32 msk,
}
EXPORT_SYMBOL_GPL(irq_remove_generic_chip);
+/**
+ * irq_free_generic_chip - Free the memory allocated for a chip
+ * @gc: Generic irq chip
+ *
+ * Free the data previously allocated by irq_allocate_generic_chip().
+ */
+void irq_free_generic_chip(struct irq_chip_generic *gc)
+{
+ kfree(gc);
+}
+EXPORT_SYMBOL_GPL(irq_free_generic_chip);
+
static struct irq_data *irq_gc_get_irq_data(struct irq_chip_generic *gc)
{
unsigned int virq;
--
2.9.3
[toc] | [next] | [standalone]
| From | Marc Zyngier <marc.zyngier@arm.com> |
|---|---|
| Date | 2017-03-09 09:10 +0100 |
| Message-ID | <tj1j5-2og-55@gated-at.bofh.it> |
| In reply to | #1595398 |
On Wed, Mar 08 2017 at 5:04:05 pm GMT, Bartosz Golaszewski <bgolaszewski@baylibre.com> wrote: > Some users of irq_alloc_generic_chip() are modules which can be > removed (e.g. gpio-ml-ioh) but have no means of freeing the allocated > generic chip. Provide a function for that. > > Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Acked-by: Marc Zyngier <marc.zyngier@arm.com> M. -- Jazz is not dead, it just smell funny.
[toc] | [prev] | [next] | [standalone]
| From | Thomas Gleixner <tglx@linutronix.de> |
|---|---|
| Date | 2017-03-09 11:20 +0100 |
| Message-ID | <tj3kS-3Nk-15@gated-at.bofh.it> |
| In reply to | #1595398 |
On Wed, 8 Mar 2017, Bartosz Golaszewski wrote:
> Some users of irq_alloc_generic_chip() are modules which can be
> removed (e.g. gpio-ml-ioh) but have no means of freeing the allocated
> generic chip. Provide a function for that.
They have means, i.e. kfree(gc). If you want a wrapper for that then please
make it a simple static inline w/o the bloat of an exported symbol.
But, what you really want is a proper counterpart to
irq_alloc_generic_chip() which undoes everything what
irq_alloc_generic_chip() does.
You have to call irq_remove_generic_chip() before calling kfree() or the
wrapper anyway. And looking at the 3 users of irq_remove_generic_chip():
Two of them (drivers/gpio/gpio-tb10x.c drivers/mfd/jz4740-adc.c) do
irq_remove_generic_chip(gc)
kfree(gc)
The third one (arch/arm/mach-omap2/prm_common.c) leaks the generic chip
memory....
So the proper solution is to rename irq_remove_generic_chip() to
irq_destroy_generic_chip() and do the kfree() at the end of that function.
Hmm?
tglx
[toc] | [prev] | [next] | [standalone]
| From | Bartosz Golaszewski <bgolaszewski@baylibre.com> |
|---|---|
| Date | 2017-03-09 11:50 +0100 |
| Message-ID | <tj3NU-3XL-23@gated-at.bofh.it> |
| In reply to | #1595886 |
2017-03-09 11:17 GMT+01:00 Thomas Gleixner <tglx@linutronix.de>: > On Wed, 8 Mar 2017, Bartosz Golaszewski wrote: > >> Some users of irq_alloc_generic_chip() are modules which can be >> removed (e.g. gpio-ml-ioh) but have no means of freeing the allocated >> generic chip. Provide a function for that. > > They have means, i.e. kfree(gc). If you want a wrapper for that then please > make it a simple static inline w/o the bloat of an exported symbol. > Yes, I want a wrapper, since there are no guarantees as to what irq_alloc_generic_chip() does internally. > But, what you really want is a proper counterpart to > irq_alloc_generic_chip() which undoes everything what > irq_alloc_generic_chip() does. > > You have to call irq_remove_generic_chip() before calling kfree() or the > wrapper anyway. And looking at the 3 users of irq_remove_generic_chip(): > > Two of them (drivers/gpio/gpio-tb10x.c drivers/mfd/jz4740-adc.c) do > > irq_remove_generic_chip(gc) > kfree(gc) > > The third one (arch/arm/mach-omap2/prm_common.c) leaks the generic chip > memory.... > > So the proper solution is to rename irq_remove_generic_chip() to > irq_destroy_generic_chip() and do the kfree() at the end of that function. > > Hmm? > Sounds good! Thanks, Bartosz
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web