Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1585606 > unrolled thread
| Started by | Borislav Petkov <bp@alien8.de> |
|---|---|
| First post | 2017-02-21 19:40 +0100 |
| Last post | 2017-03-01 11:50 +0100 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH] x86/boot: Correct setup_header.start_sys name Borislav Petkov <bp@alien8.de> - 2017-02-21 19:40 +0100
[tip:x86/urgent] x86/boot: Correct setup_header.start_sys name tip-bot for Borislav Petkov <tipbot@zytor.com> - 2017-03-01 11:50 +0100
| From | Borislav Petkov <bp@alien8.de> |
|---|---|
| Date | 2017-02-21 19:40 +0100 |
| Subject | [PATCH] x86/boot: Correct setup_header.start_sys name |
| Message-ID | <tdnvY-6me-5@gated-at.bofh.it> |
From: Borislav Petkov <bp@suse.de>
It is called start_sys_seg elsewhere so rename it to that. It is an
obsolete field so we could just as well directly call it __u16 __pad...
No functionality change.
Signed-off-by: Borislav Petkov <bp@suse.de>
---
arch/x86/include/uapi/asm/bootparam.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/include/uapi/asm/bootparam.h b/arch/x86/include/uapi/asm/bootparam.h
index 5138dacf8bb8..07244ea16765 100644
--- a/arch/x86/include/uapi/asm/bootparam.h
+++ b/arch/x86/include/uapi/asm/bootparam.h
@@ -58,7 +58,7 @@ struct setup_header {
__u32 header;
__u16 version;
__u32 realmode_swtch;
- __u16 start_sys;
+ __u16 start_sys_seg;
__u16 kernel_version;
__u8 type_of_loader;
__u8 loadflags;
--
2.11.0
[toc] | [next] | [standalone]
| From | tip-bot for Borislav Petkov <tipbot@zytor.com> |
|---|---|
| Date | 2017-03-01 11:50 +0100 |
| Subject | [tip:x86/urgent] x86/boot: Correct setup_header.start_sys name |
| Message-ID | <tg9Zw-1Pu-35@gated-at.bofh.it> |
| In reply to | #1585606 |
Commit-ID: 8392f16d38bb5222c03073a3906b7fd272386faf
Gitweb: http://git.kernel.org/tip/8392f16d38bb5222c03073a3906b7fd272386faf
Author: Borislav Petkov <bp@suse.de>
AuthorDate: Tue, 21 Feb 2017 19:36:39 +0100
Committer: Thomas Gleixner <tglx@linutronix.de>
CommitDate: Wed, 1 Mar 2017 11:27:26 +0100
x86/boot: Correct setup_header.start_sys name
It is called start_sys_seg elsewhere so rename it to that. It is an
obsolete field so we could just as well directly call it __u16 __pad...
No functional change.
Signed-off-by: Borislav Petkov <bp@suse.de>
Link: http://lkml.kernel.org/r/20170221183639.16554-1-bp@alien8.de
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
---
arch/x86/include/uapi/asm/bootparam.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/include/uapi/asm/bootparam.h b/arch/x86/include/uapi/asm/bootparam.h
index 5138dac..07244ea 100644
--- a/arch/x86/include/uapi/asm/bootparam.h
+++ b/arch/x86/include/uapi/asm/bootparam.h
@@ -58,7 +58,7 @@ struct setup_header {
__u32 header;
__u16 version;
__u32 realmode_swtch;
- __u16 start_sys;
+ __u16 start_sys_seg;
__u16 kernel_version;
__u8 type_of_loader;
__u8 loadflags;
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web