Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1580007 > unrolled thread
| Started by | Daniel Bristot de Oliveira <bristot@redhat.com> |
|---|---|
| First post | 2017-02-13 20:10 +0100 |
| Last post | 2017-02-16 17:50 +0100 |
| Articles | 2 on this page of 22 — 8 participants |
Back to article view | Back to linux.kernel
[PATCH V2 0/2] sched/deadline: Fixes for constrained deadline tasks Daniel Bristot de Oliveira <bristot@redhat.com> - 2017-02-13 20:10 +0100
[PATCH V2 2/2] sched/deadline: Throttle a constrained deadline task activated after the deadline Daniel Bristot de Oliveira <bristot@redhat.com> - 2017-02-13 20:10 +0100
Re: [PATCH V2 2/2] sched/deadline: Throttle a constrained deadline task activated after the deadline Tommaso Cucinotta <tommaso.cucinotta@santannapisa.it> - 2017-02-14 18:00 +0100
Re: [PATCH V2 2/2] sched/deadline: Throttle a constrained deadline task activated after the deadline Daniel Bristot de Oliveira <bristot@redhat.com> - 2017-02-14 18:40 +0100
Re: [PATCH V2 2/2] sched/deadline: Throttle a constrained deadline task activated after the deadline Steven Rostedt <rostedt@goodmis.org> - 2017-02-14 20:40 +0100
[PATCH V2 1/2] sched/deadline: Replenishment timer should fire in the next period Daniel Bristot de Oliveira <bristot@redhat.com> - 2017-02-13 20:10 +0100
[PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow "Steven Rostedt (VMware)" <rostedt@goodmis.org> - 2017-02-14 20:30 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow luca abeni <luca.abeni@santannapisa.it> - 2017-02-14 23:50 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Steven Rostedt <rostedt@goodmis.org> - 2017-02-15 01:20 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Luca Abeni <luca.abeni@santannapisa.it> - 2017-02-15 08:50 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Juri Lelli <juri.lelli@arm.com> - 2017-02-15 11:30 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Peter Zijlstra <peterz@infradead.org> - 2017-02-15 12:40 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Luca Abeni <luca.abeni@santannapisa.it> - 2017-02-15 13:40 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Juri Lelli <juri.lelli@arm.com> - 2017-02-15 14:00 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Luca Abeni <luca.abeni@santannapisa.it> - 2017-02-15 14:20 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Juri Lelli <juri.lelli@arm.com> - 2017-02-15 15:20 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Daniel Bristot de Oliveira <bristot@redhat.com> - 2017-02-15 14:40 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Daniel Bristot de Oliveira <bristot@redhat.com> - 2017-02-15 14:50 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Steven Rostedt <rostedt@goodmis.org> - 2017-02-15 15:10 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Juri Lelli <juri.lelli@arm.com> - 2017-02-15 15:20 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Tommaso Cucinotta <tommaso.cucinotta@santannapisa.it> - 2017-02-16 17:40 +0100
Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow Steven Rostedt <rostedt@goodmis.org> - 2017-02-16 17:50 +0100
Page 2 of 2 — ← Prev page 1 [2]
| From | Tommaso Cucinotta <tommaso.cucinotta@santannapisa.it> |
|---|---|
| Date | 2017-02-16 17:40 +0100 |
| Subject | Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow |
| Message-ID | <tbxg5-uI-9@gated-at.bofh.it> |
| In reply to | #1581318 |
On 15/02/2017 14:33, Daniel Bristot de Oliveira wrote:
> [1] For the sake of completeness:
> - dl_se->deadline = Absolute deadline
> - dl_se->dl_deadline = Relative deadline
Daniel's note [1] reminds me that, would it be worth a rename of these, for the sake of clarity, e.g.:
-) abs_deadline vs rel_deadline
-) runtime_left vs runtime_tot
or similar :-) ?
T.
[toc] | [prev] | [next] | [standalone]
| From | Steven Rostedt <rostedt@goodmis.org> |
|---|---|
| Date | 2017-02-16 17:50 +0100 |
| Subject | Re: [PATCH 3/2] sched/deadline: Use deadline instead of period when calculating overflow |
| Message-ID | <tbxpM-zM-13@gated-at.bofh.it> |
| In reply to | #1582693 |
On Thu, 16 Feb 2017 17:36:07 +0100 Tommaso Cucinotta <tommaso.cucinotta@santannapisa.it> wrote: > On 15/02/2017 14:33, Daniel Bristot de Oliveira wrote: > > [1] For the sake of completeness: > > - dl_se->deadline = Absolute deadline > > - dl_se->dl_deadline = Relative deadline > Daniel's note [1] reminds me that, would it be worth a rename of these, for the sake of clarity, e.g.: > -) abs_deadline vs rel_deadline > -) runtime_left vs runtime_tot > or similar :-) ? +1 as I seem to get confused by it too. -- Steve
[toc] | [prev] | [standalone]
Page 2 of 2 — ← Prev page 1 [2]
Back to top | Article view | linux.kernel
csiph-web