Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1672438 > unrolled thread
| Started by | "Kirill A. Shutemov" <kirill@shutemov.name> |
|---|---|
| First post | 2017-06-22 11:00 +0200 |
| Last post | 2017-06-22 11:10 +0200 |
| Articles | 4 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCHv7 00/14] x86: 5-level paging enabling for v4.13, Part 4 "Kirill A. Shutemov" <kirill@shutemov.name> - 2017-06-22 11:00 +0200
Re: [PATCHv7 00/14] x86: 5-level paging enabling for v4.13, Part 4 "Kirill A. Shutemov" <kirill@shutemov.name> - 2017-06-22 11:10 +0200
Re: [PATCHv7 00/14] x86: 5-level paging enabling for v4.13, Part 4 Ingo Molnar <mingo@kernel.org> - 2017-06-22 11:30 +0200
Re: [PATCHv7 00/14] x86: 5-level paging enabling for v4.13, Part 4 Ingo Molnar <mingo@kernel.org> - 2017-06-22 11:10 +0200
| From | "Kirill A. Shutemov" <kirill@shutemov.name> |
|---|---|
| Date | 2017-06-22 11:00 +0200 |
| Subject | Re: [PATCHv7 00/14] x86: 5-level paging enabling for v4.13, Part 4 |
| Message-ID | <tV682-2hR-25@gated-at.bofh.it> |
On Tue, Jun 06, 2017 at 02:31:19PM +0300, Kirill A. Shutemov wrote: > Please review and consider applying. Hi Ingo, I've noticed you haven't applied last two patches of the patchset. Is there any problem with them? Or what is you plan here? -- Kirill A. Shutemov
[toc] | [next] | [standalone]
| From | "Kirill A. Shutemov" <kirill@shutemov.name> |
|---|---|
| Date | 2017-06-22 11:10 +0200 |
| Message-ID | <tV6hH-2Cj-1@gated-at.bofh.it> |
| In reply to | #1672438 |
On Thu, Jun 22, 2017 at 11:04:22AM +0200, Ingo Molnar wrote: > > * Kirill A. Shutemov <kirill@shutemov.name> wrote: > > > On Tue, Jun 06, 2017 at 02:31:19PM +0300, Kirill A. Shutemov wrote: > > > Please review and consider applying. > > > > Hi Ingo, > > > > I've noticed you haven't applied last two patches of the patchset. > > > > Is there any problem with them? Or what is you plan here? > > As they change/extend the Linux ABI I still need to think about them some more. Okay, I see. Let me know if any action is required from my side. -- Kirill A. Shutemov
[toc] | [prev] | [next] | [standalone]
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Date | 2017-06-22 11:30 +0200 |
| Message-ID | <tV6B3-2JO-9@gated-at.bofh.it> |
| In reply to | #1672439 |
* Kirill A. Shutemov <kirill@shutemov.name> wrote: > On Thu, Jun 22, 2017 at 11:04:22AM +0200, Ingo Molnar wrote: > > > > * Kirill A. Shutemov <kirill@shutemov.name> wrote: > > > > > On Tue, Jun 06, 2017 at 02:31:19PM +0300, Kirill A. Shutemov wrote: > > > > Please review and consider applying. > > > > > > Hi Ingo, > > > > > > I've noticed you haven't applied last two patches of the patchset. > > > > > > Is there any problem with them? Or what is you plan here? > > > > As they change/extend the Linux ABI I still need to think about them some more. > > Okay, I see. > > Let me know if any action is required from my side. Yeah, so I had a look, and the ABI principle of using the mmap() address hint to trigger 57-bit address space allocations still looks mostly good to me, but please split up this patch: Subject: [PATCHv7 14/14] x86/mm: Allow to have userspace mappings above 47-bits arch/x86/include/asm/elf.h | 4 ++-- arch/x86/include/asm/mpx.h | 9 +++++++++ arch/x86/include/asm/processor.h | 12 +++++++++--- arch/x86/kernel/sys_x86_64.c | 30 ++++++++++++++++++++++++++---- arch/x86/mm/hugetlbpage.c | 27 +++++++++++++++++++++++---- arch/x86/mm/mmap.c | 6 +++--- arch/x86/mm/mpx.c | 33 ++++++++++++++++++++++++++++++++- 7 files changed, 104 insertions(+), 17 deletions(-) One patch should add the MPX quirk, another should add all the TASK_SIZE variations, without actually changing the logic, etc. - while the final patch adds the larger task size. Please try to split it into as many patches as possible - I'd say 4-5 look ideal. All of this changes existing code paths and if things break we'd like some small patch to be bisected to. The finer grained structure also makes review easier. Also, please rename the tasksize_*() functions to task_size_ (in yet another patch) - it's absolutely silly that we have 'TASK_SIZE' in uppercase but 'tasksize' in lowercase ... Thanks, Ingo
[toc] | [prev] | [next] | [standalone]
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Date | 2017-06-22 11:10 +0200 |
| Message-ID | <tV6hH-2Cj-3@gated-at.bofh.it> |
| In reply to | #1672438 |
* Kirill A. Shutemov <kirill@shutemov.name> wrote: > On Tue, Jun 06, 2017 at 02:31:19PM +0300, Kirill A. Shutemov wrote: > > Please review and consider applying. > > Hi Ingo, > > I've noticed you haven't applied last two patches of the patchset. > > Is there any problem with them? Or what is you plan here? As they change/extend the Linux ABI I still need to think about them some more. Thanks, Ingo
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web