Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1667267 > unrolled thread

[PATCH 0/7] RPi touchscreen as a panel driver again

Started byEric Anholt <eric@anholt.net>
First post2017-06-15 22:50 +0200
Last post2017-06-15 22:50 +0200
Articles 2 — 1 participant

Back to article view | Back to linux.kernel


Contents

  [PATCH 0/7] RPi touchscreen as a panel driver again Eric Anholt <eric@anholt.net> - 2017-06-15 22:50 +0200
    [PATCH 3/7] drm/vc4: Fix misleading name of the continuous flag. Eric Anholt <eric@anholt.net> - 2017-06-15 22:50 +0200

#1667267 — [PATCH 0/7] RPi touchscreen as a panel driver again

FromEric Anholt <eric@anholt.net>
Date2017-06-15 22:50 +0200
Subject[PATCH 0/7] RPi touchscreen as a panel driver again
Message-ID<tSJSh-7i5-3@gated-at.bofh.it>
After splitting the panel driver out into a panel and bridge due to
panel review, the feedback from bridge maintainers was that it didn't
make sense as a bridge.  I completely agree with them.  This series
returns the driver to being a panel, but this time probing as an i2c
client rather than a DSI device (due to review from bridge
submission).

Eric Anholt (7):
  drm/bridge: Support hotplugging panel-bridge.
  drm/vc4: Fix DSI T_INIT timing.
  drm/vc4: Fix misleading name of the continuous flag.
  drm/vc4: Use drm_mode_vrefresh() in DSI fixup, in case vrefresh is 0.
  dt-bindings: Document the Raspberry Pi Touchscreen nodes.
  drm/panel: Add support for the Raspberry Pi 7" Touchscreen.
  ARM: dts: bcm2835: Enable the Raspberry Pi touchscreen panel.

 .../panel/raspberrypi,7inch-touchscreen.txt        |  49 ++
 arch/arm/boot/dts/bcm2835-rpi-b-plus.dts           |   5 +
 arch/arm/boot/dts/bcm2835-rpi-b-rev2.dts           |   5 +
 arch/arm/boot/dts/bcm2835-rpi-b.dts                |   5 +
 arch/arm/boot/dts/bcm2836-rpi-2-b.dts              |   5 +
 arch/arm/boot/dts/bcm283x.dtsi                     |  30 +-
 arch/arm64/boot/dts/broadcom/bcm2837-rpi-3-b.dts   |   5 +
 drivers/gpu/drm/bridge/panel.c                     |   3 +
 drivers/gpu/drm/panel/Kconfig                      |   8 +
 drivers/gpu/drm/panel/Makefile                     |   1 +
 .../gpu/drm/panel/panel-raspberrypi-touchscreen.c  | 507 +++++++++++++++++++++
 drivers/gpu/drm/vc4/vc4_dsi.c                      |  24 +-
 12 files changed, 640 insertions(+), 7 deletions(-)
 create mode 100644 Documentation/devicetree/bindings/display/panel/raspberrypi,7inch-touchscreen.txt
 create mode 100644 drivers/gpu/drm/panel/panel-raspberrypi-touchscreen.c

-- 
2.11.0

[toc] | [next] | [standalone]


#1667269 — [PATCH 3/7] drm/vc4: Fix misleading name of the continuous flag.

FromEric Anholt <eric@anholt.net>
Date2017-06-15 22:50 +0200
Subject[PATCH 3/7] drm/vc4: Fix misleading name of the continuous flag.
Message-ID<tSJSi-7i5-39@gated-at.bofh.it>
In reply to#1667267
The logic was all right in the end, the name was just backwards.

Signed-off-by: Eric Anholt <eric@anholt.net>
---
 drivers/gpu/drm/vc4/vc4_dsi.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/vc4/vc4_dsi.c b/drivers/gpu/drm/vc4/vc4_dsi.c
index 15f6d5005ab9..629d372633e6 100644
--- a/drivers/gpu/drm/vc4/vc4_dsi.c
+++ b/drivers/gpu/drm/vc4/vc4_dsi.c
@@ -736,18 +736,18 @@ static void vc4_dsi_latch_ulps(struct vc4_dsi *dsi, bool latch)
 /* Enters or exits Ultra Low Power State. */
 static void vc4_dsi_ulps(struct vc4_dsi *dsi, bool ulps)
 {
-	bool continuous = dsi->mode_flags & MIPI_DSI_CLOCK_NON_CONTINUOUS;
-	u32 phyc_ulps = ((continuous ? DSI_PORT_BIT(PHYC_CLANE_ULPS) : 0) |
+	bool non_continuous = dsi->mode_flags & MIPI_DSI_CLOCK_NON_CONTINUOUS;
+	u32 phyc_ulps = ((non_continuous ? DSI_PORT_BIT(PHYC_CLANE_ULPS) : 0) |
 			 DSI_PHYC_DLANE0_ULPS |
 			 (dsi->lanes > 1 ? DSI_PHYC_DLANE1_ULPS : 0) |
 			 (dsi->lanes > 2 ? DSI_PHYC_DLANE2_ULPS : 0) |
 			 (dsi->lanes > 3 ? DSI_PHYC_DLANE3_ULPS : 0));
-	u32 stat_ulps = ((continuous ? DSI1_STAT_PHY_CLOCK_ULPS : 0) |
+	u32 stat_ulps = ((non_continuous ? DSI1_STAT_PHY_CLOCK_ULPS : 0) |
 			 DSI1_STAT_PHY_D0_ULPS |
 			 (dsi->lanes > 1 ? DSI1_STAT_PHY_D1_ULPS : 0) |
 			 (dsi->lanes > 2 ? DSI1_STAT_PHY_D2_ULPS : 0) |
 			 (dsi->lanes > 3 ? DSI1_STAT_PHY_D3_ULPS : 0));
-	u32 stat_stop = ((continuous ? DSI1_STAT_PHY_CLOCK_STOP : 0) |
+	u32 stat_stop = ((non_continuous ? DSI1_STAT_PHY_CLOCK_STOP : 0) |
 			 DSI1_STAT_PHY_D0_STOP |
 			 (dsi->lanes > 1 ? DSI1_STAT_PHY_D1_STOP : 0) |
 			 (dsi->lanes > 2 ? DSI1_STAT_PHY_D2_STOP : 0) |
-- 
2.11.0

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web