Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1640574 > unrolled thread
| Started by | Markus Heiser <markus.heiser@darmarit.de> |
|---|---|
| First post | 2017-05-12 18:40 +0200 |
| Last post | 2017-05-13 12:10 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH 01/36] docs-rst: convert kernel-hacking to ReST Markus Heiser <markus.heiser@darmarit.de> - 2017-05-12 18:40 +0200
Re: [PATCH 01/36] docs-rst: convert kernel-hacking to ReST Mauro Carvalho Chehab <mchehab@s-opensource.com> - 2017-05-13 12:10 +0200
| From | Markus Heiser <markus.heiser@darmarit.de> |
|---|---|
| Date | 2017-05-12 18:40 +0200 |
| Subject | Re: [PATCH 01/36] docs-rst: convert kernel-hacking to ReST |
| Message-ID | <tGlLI-7eN-1@gated-at.bofh.it> |
Am 12.05.2017 um 15:59 schrieb Mauro Carvalho Chehab <mchehab@s-opensource.com>: > Use pandoc to convert documentation to ReST by calling > Documentation/sphinx/tmplcvt script. > > - Manually adjusted to use ..note and ..warning > - Minor fixes for it to be parsed without errors > - Use **bold** for emphasis. > > Signed-off-by: Mauro Carvalho Chehab <mchehab@s-opensource.com> > --- > Documentation/DocBook/Makefile | 2 +- > Documentation/DocBook/kernel-hacking.tmpl | 1312 ----------------------------- > Documentation/conf.py | 2 + > Documentation/index.rst | 1 + > Documentation/kernel-hacking/conf.py | 10 + > Documentation/kernel-hacking/index.rst | 794 +++++++++++++++++ > 6 files changed, 808 insertions(+), 1313 deletions(-) > delete mode 100644 Documentation/DocBook/kernel-hacking.tmpl > create mode 100644 Documentation/kernel-hacking/conf.py > create mode 100644 Documentation/kernel-hacking/index.rst > > .... > +:c:func:`cpu_to_be32()`/:c:func:`be32_to_cpu()`/:c:func:`cpu_to_le32()`/:c:func:`le32_to_cpu()` ``include/asm/byteorder.h`` > +--------------------------------------------------------------------------------------------------------------------------- > + Hi Mauro, just my bikeshedding: what do you think, do we really need to refer functions in titles? As far as I know, there is no use-case where we can get any benefit from. So I recommend to write titles more simple, e.g.: cpu_to_be32()/be32_to_cpu()/cpu_to_le32()/le32_to_cpu() include/asm/byteorder.h .. which is long enough ;) -- Markus --
[toc] | [next] | [standalone]
| From | Mauro Carvalho Chehab <mchehab@s-opensource.com> |
|---|---|
| Date | 2017-05-13 12:10 +0200 |
| Message-ID | <tGC9Q-2dQ-31@gated-at.bofh.it> |
| In reply to | #1640574 |
Em Fri, 12 May 2017 18:35:29 +0200 Markus Heiser <markus.heiser@darmarit.de> escreveu: > Am 12.05.2017 um 15:59 schrieb Mauro Carvalho Chehab <mchehab@s-opensource.com>: > > > Use pandoc to convert documentation to ReST by calling > > Documentation/sphinx/tmplcvt script. > > > > - Manually adjusted to use ..note and ..warning > > - Minor fixes for it to be parsed without errors > > - Use **bold** for emphasis. > > > > Signed-off-by: Mauro Carvalho Chehab <mchehab@s-opensource.com> > > --- > > Documentation/DocBook/Makefile | 2 +- > > Documentation/DocBook/kernel-hacking.tmpl | 1312 ----------------------------- > > Documentation/conf.py | 2 + > > Documentation/index.rst | 1 + > > Documentation/kernel-hacking/conf.py | 10 + > > Documentation/kernel-hacking/index.rst | 794 +++++++++++++++++ > > 6 files changed, 808 insertions(+), 1313 deletions(-) > > delete mode 100644 Documentation/DocBook/kernel-hacking.tmpl > > create mode 100644 Documentation/kernel-hacking/conf.py > > create mode 100644 Documentation/kernel-hacking/index.rst > > > > > .... > > > +:c:func:`cpu_to_be32()`/:c:func:`be32_to_cpu()`/:c:func:`cpu_to_le32()`/:c:func:`le32_to_cpu()` ``include/asm/byteorder.h`` > > +--------------------------------------------------------------------------------------------------------------------------- > > + > > Hi Mauro, just my bikeshedding: > > what do you think, do we really need to refer functions in titles? > As far as I know, there is no use-case where we can get any benefit > from. So I recommend to write titles more simple, e.g.: > > cpu_to_be32()/be32_to_cpu()/cpu_to_le32()/le32_to_cpu() include/asm/byteorder.h > > .. which is long enough ;) There are some functions there that are only mentioned at the title, like: local_bh_disable(). IMHO, it is a good idea to add a cross-reference to those, as it helps the reader to get further information if needed. So, except if this would cause Sphinx to crash, I prefer to keep the references. What I did, instead, on patch 02/36 is to move all header references to be outside the title: +:c:func:`cpu_to_be32()`/:c:func:`be32_to_cpu()`/:c:func:`cpu_to_le32()`/:c:func:`le32_to_cpu()` +----------------------------------------------------------------------------------------------- + +Defined in ``include/asm/byteorder.h`` With reduces the displayed title to something reasonable. Thanks, Mauro
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web