Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1640073 > unrolled thread

handle_bad_irq and locking

Started byGregory Fong <gregory.0xf0@gmail.com>
First post2017-05-12 01:30 +0200
Last post2017-05-15 10:50 +0200
Articles 3 — 2 participants

Back to article view | Back to linux.kernel


Contents

  handle_bad_irq and locking Gregory Fong <gregory.0xf0@gmail.com> - 2017-05-12 01:30 +0200
    Re: handle_bad_irq and locking Thomas Gleixner <tglx@linutronix.de> - 2017-05-12 10:50 +0200
      Re: handle_bad_irq and locking Gregory Fong <gregory.0xf0@gmail.com> - 2017-05-15 10:50 +0200

#1640073 — handle_bad_irq and locking

FromGregory Fong <gregory.0xf0@gmail.com>
Date2017-05-12 01:30 +0200
Subjecthandle_bad_irq and locking
Message-ID<tG5GV-4qK-3@gated-at.bofh.it>
Hi Thomas,

I noticed that when you changed arm irq handling to use the generic
implementation back in 2006 that you changed do_bad_IRQ() to the
following:

+#define do_bad_IRQ(irq,desc,regs)                      \
+do {                                                   \
+       spin_lock(&desc->lock);                         \
+       handle_bad_irq(irq, desc, regs);                \
+       spin_unlock(&desc->lock);                       \
+} while(0)

and it's mostly stayed the same since then.  As such, there are a few
examples of this being open-coded in the kernel in various irqchip
handlers such as that of drivers/irqchip/irq-brcmstb-l2.c, and even
more cases where the lock isn't being grabbed before calling
handle_bad_irq().

Since handle_bad_irq() is sort of a flow handler like
handle_edge_irq() etc., do you think it would make sense to do the
same as those and have it do the locking on its own?  A quick look
through existing users of handle_bad_irq() at [1] suggests that either
the locking isn't necessary or it's almost always done wrong.

Apologies if this has been asked before, but it's remarkably difficult
to search for.

[1] http://elixir.free-electrons.com/linux/latest/ident/handle_bad_irq

Thanks and regards,
Gregory

[toc] | [next] | [standalone]


#1640322

FromThomas Gleixner <tglx@linutronix.de>
Date2017-05-12 10:50 +0200
Message-ID<tGeqS-1Rw-19@gated-at.bofh.it>
In reply to#1640073
On Thu, 11 May 2017, Gregory Fong wrote:
> Hi Thomas,
> 
> I noticed that when you changed arm irq handling to use the generic
> implementation back in 2006 that you changed do_bad_IRQ() to the
> following:
> 
> +#define do_bad_IRQ(irq,desc,regs)                      \
> +do {                                                   \
> +       spin_lock(&desc->lock);                         \
> +       handle_bad_irq(irq, desc, regs);                \
> +       spin_unlock(&desc->lock);                       \
> +} while(0)
> 
> and it's mostly stayed the same since then.  As such, there are a few
> examples of this being open-coded in the kernel in various irqchip
> handlers such as that of drivers/irqchip/irq-brcmstb-l2.c, and even
> more cases where the lock isn't being grabbed before calling
> handle_bad_irq().
> 
> Since handle_bad_irq() is sort of a flow handler like
> handle_edge_irq() etc., do you think it would make sense to do the
> same as those and have it do the locking on its own?  A quick look
> through existing users of handle_bad_irq() at [1] suggests that either
> the locking isn't necessary or it's almost always done wrong.

Right. So the proper solution to this is to create a generic function

       handle_bad_irq_desc()

have proper locking in it and move all users (including do_bad_IRQ()) over
to it.

Thanks,

	tglx

[toc] | [prev] | [next] | [standalone]


#1641399

FromGregory Fong <gregory.0xf0@gmail.com>
Date2017-05-15 10:50 +0200
Message-ID<tHjRw-5Kw-21@gated-at.bofh.it>
In reply to#1640322
On Fri, May 12, 2017 at 1:40 AM, Thomas Gleixner <tglx@linutronix.de> wrote:
> On Thu, 11 May 2017, Gregory Fong wrote:
>> Hi Thomas,
>>
>> I noticed that when you changed arm irq handling to use the generic
>> implementation back in 2006 that you changed do_bad_IRQ() to the
>> following:
>>
>> +#define do_bad_IRQ(irq,desc,regs)                      \
>> +do {                                                   \
>> +       spin_lock(&desc->lock);                         \
>> +       handle_bad_irq(irq, desc, regs);                \
>> +       spin_unlock(&desc->lock);                       \
>> +} while(0)
>>
>> and it's mostly stayed the same since then.  As such, there are a few
>> examples of this being open-coded in the kernel in various irqchip
>> handlers such as that of drivers/irqchip/irq-brcmstb-l2.c, and even
>> more cases where the lock isn't being grabbed before calling
>> handle_bad_irq().
>>
>> Since handle_bad_irq() is sort of a flow handler like
>> handle_edge_irq() etc., do you think it would make sense to do the
>> same as those and have it do the locking on its own?  A quick look
>> through existing users of handle_bad_irq() at [1] suggests that either
>> the locking isn't necessary or it's almost always done wrong.
>
> Right. So the proper solution to this is to create a generic function
>
>        handle_bad_irq_desc()
>
> have proper locking in it and move all users (including do_bad_IRQ()) over
> to it.

I'm guessing the different name would be to avoid breaking existing
users.  Wouldn't it be better to just add locking in handle_bad_irq(),
simultaneously removing the lock/unlock around in its invocations in
the few places where that was actually done?  There aren't any
existing builtin IRQ flow handlers that end in "_desc".

Otherwise I'll move forward with implementing handle_bad_irq_desc()
and updating existing users.

Thanks,
Gregory

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web