Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1633302 > unrolled thread
| Started by | "Alex A. Mihaylov" <minimumlaw@rambler.ru> |
|---|---|
| First post | 2017-04-29 16:40 +0200 |
| Last post | 2017-04-30 22:50 +0200 |
| Articles | 4 — 3 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
[PATCH 2/2] Add driver for MAX17211/MAX17215 fuel gauge "Alex A. Mihaylov" <minimumlaw@rambler.ru> - 2017-04-29 16:40 +0200
Re: [PATCH 2/2] Add driver for MAX17211/MAX17215 fuel gauge Sebastian Reichel <sre@kernel.org> - 2017-04-29 18:50 +0200
Re: [PATCH 2/2] Add driver for MAX17211/MAX17215 fuel gauge Михайлов Алексей Анатольевич <minimumlaw@rambler.ru> - 2017-04-30 19:40 +0200
Re: [PATCH 2/2] Add driver for MAX17211/MAX17215 fuel gauge Sebastian Reichel <sre@kernel.org> - 2017-04-30 22:50 +0200
| From | "Alex A. Mihaylov" <minimumlaw@rambler.ru> |
|---|---|
| Date | 2017-04-29 16:40 +0200 |
| Subject | [PATCH 2/2] Add driver for MAX17211/MAX17215 fuel gauge |
| Message-ID | <tBBHr-7p2-9@gated-at.bofh.it> |
Maxim Semiconductor MAX17211/MAX17215 single/multi-cell fuel gauge
monitor with M5 Fuel Gauge algorithm
This driver provide userspace access to MAX17211/MAX17215 data with
power_supply class drivers.
---
drivers/power/supply/Kconfig | 8 +
drivers/power/supply/Makefile | 1 +
drivers/power/supply/max1721x_battery.c | 303 ++++++++++++++++++++++++++++++++
3 files changed, 312 insertions(+)
create mode 100644 drivers/power/supply/max1721x_battery.c
diff --git a/drivers/power/supply/Kconfig b/drivers/power/supply/Kconfig
index 76806a0..25fe441 100644
--- a/drivers/power/supply/Kconfig
+++ b/drivers/power/supply/Kconfig
@@ -117,6 +117,14 @@ config BATTERY_DS2782
Say Y here to enable support for the DS2782/DS2786 standalone battery
gas-gauge.
+config BATTERY_MAX1721X
+ tristate "MAX17211/MAX17215 standalone gas-gauge"
+ depends on W1
+ select W1_SLAVE_MAX1721X
+ help
+ Say Y here to enable support for the MAX17211/MAX17215 standalone
+ battery gas-gauge.
+
config BATTERY_PMU
tristate "Apple PMU battery"
depends on PPC32 && ADB_PMU
diff --git a/drivers/power/supply/Makefile b/drivers/power/supply/Makefile
index 36c599d..1e5546d 100644
--- a/drivers/power/supply/Makefile
+++ b/drivers/power/supply/Makefile
@@ -22,6 +22,7 @@ obj-$(CONFIG_BATTERY_DS2760) += ds2760_battery.o
obj-$(CONFIG_BATTERY_DS2780) += ds2780_battery.o
obj-$(CONFIG_BATTERY_DS2781) += ds2781_battery.o
obj-$(CONFIG_BATTERY_DS2782) += ds2782_battery.o
+obj-$(CONFIG_BATTERY_MAX1721X) += max1721x_battery.o
obj-$(CONFIG_BATTERY_GAUGE_LTC2941) += ltc2941-battery-gauge.o
obj-$(CONFIG_BATTERY_GOLDFISH) += goldfish_battery.o
obj-$(CONFIG_BATTERY_PMU) += pmu_battery.o
diff --git a/drivers/power/supply/max1721x_battery.c b/drivers/power/supply/max1721x_battery.c
new file mode 100644
index 0000000..ff77d3f
--- /dev/null
+++ b/drivers/power/supply/max1721x_battery.c
@@ -0,0 +1,303 @@
+/*
+ * 1-wire client/driver for the Maxim MAX17211/MAX17215 Fuel Gauge IC
+ *
+ * Author: Alex A. Mihaylov <minimumlaw@rambler.ru>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 as
+ * published by the Free Software Foundation.
+ *
+ */
+
+#include <linux/module.h>
+#include <linux/slab.h>
+#include <linux/param.h>
+#include <linux/pm.h>
+#include <linux/platform_device.h>
+#include <linux/power_supply.h>
+#include <linux/idr.h>
+
+#include "../../w1/w1.h"
+#include "../../w1/slaves/w1_max1721x.h"
+
+#define DEF_DEV_NAME_MAX17211 "MAX17211"
+#define DEF_DEV_NAME_MAX17215 "MAX17215"
+#define DEF_DEV_NAME_UNKNOWN "UNKNOWN"
+#define DEF_MFG_NAME "MAXIM"
+
+struct max17211_device_info {
+ struct device *dev;
+ struct power_supply *bat;
+ struct power_supply_desc bat_desc;
+ struct device *w1_dev;
+ /* battery design format */
+ uint16_t rsense; /* in tenths uOhm */
+ char DeviceName[2 * MAX1721X_REG_DEV_NUMB + 1];
+ char ManufacturerName[2 * MAX1721X_REG_MFG_NUMB + 1];
+ char SerialNumber[13]; /* see get_sn_str() later for comment */
+};
+
+static inline struct max17211_device_info *
+to_device_info(struct power_supply *psy)
+{
+ return power_supply_get_drvdata(psy);
+}
+
+static int max1721x_battery_get_property(struct power_supply *psy,
+ enum power_supply_property psp,
+ union power_supply_propval *val)
+{
+ struct max17211_device_info *info = to_device_info(psy);
+ uint16_t reg;
+ int ret = 0;
+
+ switch (psp) {
+ case POWER_SUPPLY_PROP_PRESENT:
+ /*
+ * POWER_SUPPLY_PROP_PRESENT will always readable via
+ * sysfs interface. Value return 0 if battery not
+ * present or unaccesable via W1.
+ */
+ val->intval =
+ w1_max1721x_reg_get(info->w1_dev, MAX172XX_REG_STATUS,
+ ®) ? 0 : !(reg & MAX172XX_BAT_PRESENT);
+ break;
+ case POWER_SUPPLY_PROP_CAPACITY:
+ ret = w1_max1721x_reg_get(info->w1_dev,
+ MAX172XX_REG_REPSOC, ®);
+ val->intval = max172xx_percent_to_ps(reg);
+ break;
+ case POWER_SUPPLY_PROP_VOLTAGE_NOW:
+ ret = w1_max1721x_reg_get(info->w1_dev,
+ MAX172XX_REG_BATT, ®);
+ val->intval = max172xx_voltage_to_ps(reg);
+ break;
+ case POWER_SUPPLY_PROP_CHARGE_FULL_DESIGN:
+ ret = w1_max1721x_reg_get(info->w1_dev,
+ MAX172XX_REG_DESIGNCAP, ®);
+ val->intval = max172xx_capacity_to_ps(reg);
+ break;
+ case POWER_SUPPLY_PROP_CHARGE_AVG:
+ ret = w1_max1721x_reg_get(info->w1_dev,
+ MAX172XX_REG_REPCAP, ®);
+ val->intval = max172xx_capacity_to_ps(reg);
+ break;
+ case POWER_SUPPLY_PROP_TIME_TO_EMPTY_AVG:
+ ret = w1_max1721x_reg_get(info->w1_dev,
+ MAX172XX_REG_TTE, ®);
+ val->intval = max172xx_time_to_ps(reg);
+ break;
+ case POWER_SUPPLY_PROP_TIME_TO_FULL_AVG:
+ ret = w1_max1721x_reg_get(info->w1_dev,
+ MAX172XX_REG_TTF, ®);
+ val->intval = max172xx_time_to_ps(reg);
+ break;
+ case POWER_SUPPLY_PROP_TEMP:
+ ret = w1_max1721x_reg_get(info->w1_dev,
+ MAX172XX_REG_TEMP, ®);
+ val->intval = max172xx_temperature_to_ps(reg);
+ break;
+ case POWER_SUPPLY_PROP_CURRENT_NOW:
+ ret = w1_max1721x_reg_get(info->w1_dev,
+ MAX172XX_REG_CURRENT, ®);
+ val->intval = max172xx_current_to_voltage(reg) / info->rsense;
+ break;
+ case POWER_SUPPLY_PROP_CURRENT_AVG:
+ ret = w1_max1721x_reg_get(info->w1_dev,
+ MAX172XX_REG_AVGCURRENT, ®);
+ val->intval = max172xx_current_to_voltage(reg) / info->rsense;
+ break;
+ /*
+ * Strings already received and inited by probe.
+ * We do dummy read for check battery still available.
+ */
+ case POWER_SUPPLY_PROP_MODEL_NAME:
+ ret = w1_max1721x_reg_get(info->w1_dev,
+ MAX1721X_REG_DEV_STR, ®);
+ val->strval = info->DeviceName;
+ break;
+ case POWER_SUPPLY_PROP_MANUFACTURER:
+ ret = w1_max1721x_reg_get(info->w1_dev,
+ MAX1721X_REG_MFG_STR, ®);
+ val->strval = info->ManufacturerName;
+ break;
+ case POWER_SUPPLY_PROP_SERIAL_NUMBER:
+ ret = w1_max1721x_reg_get(info->w1_dev,
+ MAX1721X_REG_SER_HEX, ®);
+ val->strval = info->SerialNumber;
+ break;
+ default:
+ ret = -EINVAL;
+ }
+
+ return ret;
+}
+
+static enum power_supply_property max1721x_battery_props[] = {
+ /* int */
+ POWER_SUPPLY_PROP_PRESENT,
+ POWER_SUPPLY_PROP_CAPACITY,
+ POWER_SUPPLY_PROP_VOLTAGE_NOW,
+ POWER_SUPPLY_PROP_CHARGE_FULL_DESIGN,
+ POWER_SUPPLY_PROP_CHARGE_AVG,
+ POWER_SUPPLY_PROP_TIME_TO_EMPTY_AVG,
+ POWER_SUPPLY_PROP_TIME_TO_FULL_AVG,
+ POWER_SUPPLY_PROP_TEMP,
+ POWER_SUPPLY_PROP_CURRENT_NOW,
+ POWER_SUPPLY_PROP_CURRENT_AVG,
+ /* strings */
+ POWER_SUPPLY_PROP_MODEL_NAME,
+ POWER_SUPPLY_PROP_MANUFACTURER,
+ POWER_SUPPLY_PROP_SERIAL_NUMBER,
+};
+
+static int get_string(struct device *dev, uint16_t reg, uint8_t nr, char *str)
+{
+ uint16_t val;
+
+ if (!str || !(reg == MAX1721X_REG_MFG_STR ||
+ reg == MAX1721X_REG_DEV_STR))
+ return -EFAULT;
+
+ while (nr--) {
+ if (w1_max1721x_reg_get(dev, reg++, &val))
+ return -EFAULT;
+ *str++ = val>>8 & 0x00FF;
+ *str++ = val & 0x00FF;
+ }
+ return 0;
+}
+
+/* Maxim say: Serial number is a hex string up to 12 hex characters */
+static int get_sn_string(struct device *dev, char *str)
+{
+ uint16_t val[3];
+
+ if (!str)
+ return -EFAULT;
+
+ if (w1_max1721x_reg_get(dev, MAX1721X_REG_SER_HEX, &val[0]))
+ return -EFAULT;
+ if (w1_max1721x_reg_get(dev, MAX1721X_REG_SER_HEX + 1, &val[1]))
+ return -EFAULT;
+ if (w1_max1721x_reg_get(dev, MAX1721X_REG_SER_HEX + 2, &val[2]))
+ return -EFAULT;
+
+ snprintf(str, 13, "%04X%04X%04X", val[0], val[1], val[2]);
+ return 0;
+}
+
+static int max1721x_battery_probe(struct platform_device *pdev)
+{
+ struct power_supply_config psy_cfg = {};
+ struct max17211_device_info *info;
+
+ info = devm_kzalloc(&pdev->dev, sizeof(*info), GFP_KERNEL);
+ if (!info)
+ return -ENOMEM;
+
+ platform_set_drvdata(pdev, info);
+
+ info->dev = &pdev->dev;
+ info->w1_dev = pdev->dev.parent;
+ info->bat_desc.name = dev_name(&pdev->dev);
+ info->bat_desc.type = POWER_SUPPLY_TYPE_BATTERY;
+ info->bat_desc.properties = max1721x_battery_props;
+ info->bat_desc.num_properties = ARRAY_SIZE(max1721x_battery_props);
+ info->bat_desc.get_property = max1721x_battery_get_property;
+ /*
+ * FixMe:
+ * Device without no_thermal = true not register (err -22)
+ * Len of platform device name "max17211-battery.X.auto"
+ * more than 20 chars limit in THERMAL_NAME_LENGTH from
+ * include/uapi/linux/thermal.h
+ */
+ info->bat_desc.no_thermal = true;
+ psy_cfg.drv_data = info;
+
+ if (w1_max1721x_reg_get(info->w1_dev,
+ MAX1721X_REG_NRSENSE, &info->rsense))
+ return -ENODEV;
+
+ if (!info->rsense) {
+ dev_warn(info->dev, "RSenese not calibrated, set 10 mOhms!\n");
+ info->rsense = 1000; /* in regs in 10^-5 */
+ }
+ dev_dbg(info->dev, "RSense: %d mOhms.\n", info->rsense / 100);
+
+ if (get_string(info->w1_dev, MAX1721X_REG_MFG_STR,
+ MAX1721X_REG_MFG_NUMB, info->ManufacturerName)) {
+ dev_err(info->dev, "Can't read manufacturer. Hardware error.\n");
+ return -ENODEV;
+ }
+
+ if (!info->ManufacturerName[0])
+ strncpy(info->ManufacturerName, DEF_MFG_NAME,
+ 2 * MAX1721X_REG_MFG_NUMB);
+
+ if (get_string(info->w1_dev, MAX1721X_REG_DEV_STR,
+ MAX1721X_REG_DEV_NUMB, info->DeviceName)) {
+ dev_err(info->dev, "Can't read device. Hardware error.\n");
+ return -ENODEV;
+ }
+ if (!info->DeviceName[0]) {
+ uint16_t dev_name;
+
+ if (w1_max1721x_reg_get(info->w1_dev,
+ MAX172XX_REG_DEVNAME, &dev_name)) {
+ dev_err(info->w1_dev, "Can't read device name reg.\n");
+ return -ENODEV;
+ }
+
+ switch (dev_name & MAX172XX_DEV_MASK) {
+ case MAX172X1_DEV:
+ strncpy(info->DeviceName, DEF_DEV_NAME_MAX17211,
+ 2 * MAX1721X_REG_DEV_NUMB);
+ break;
+ case MAX172X5_DEV:
+ strncpy(info->DeviceName, DEF_DEV_NAME_MAX17215,
+ 2 * MAX1721X_REG_DEV_NUMB);
+ break;
+ default:
+ strncpy(info->DeviceName, DEF_DEV_NAME_UNKNOWN,
+ 2 * MAX1721X_REG_DEV_NUMB);
+ }
+ }
+
+ if (get_sn_string(info->w1_dev, info->SerialNumber)) {
+ dev_err(info->dev, "Can't read serial. Hardware error.\n");
+ return -ENODEV;
+ }
+
+ info->bat = power_supply_register(&pdev->dev, &info->bat_desc,
+ &psy_cfg);
+ if (IS_ERR(info->bat)) {
+ dev_err(info->dev, "failed to register battery\n");
+ return PTR_ERR(info->bat);
+ }
+
+ return 0;
+}
+
+static int max1721x_battery_remove(struct platform_device *pdev)
+{
+ struct max17211_device_info *info = platform_get_drvdata(pdev);
+
+ power_supply_unregister(info->bat);
+
+ return 0;
+}
+
+static struct platform_driver max1721x_battery_driver = {
+ .driver = {
+ .name = "max1721x-battery",
+ },
+ .probe = max1721x_battery_probe,
+ .remove = max1721x_battery_remove,
+};
+module_platform_driver(max1721x_battery_driver);
+
+MODULE_LICENSE("GPL");
+MODULE_AUTHOR("Alex A. Mihaylov <minimumlaw@rambler.ru>");
+MODULE_DESCRIPTION("Maxim MAX17211/MAX17215 Fuel Gauage IC driver");
+MODULE_ALIAS("platform:max1721x-battery");
--
2.8.4 (Apple Git-73)
[toc] | [next] | [standalone]
| From | Sebastian Reichel <sre@kernel.org> |
|---|---|
| Date | 2017-04-29 18:50 +0200 |
| Message-ID | <tBDJf-c0-11@gated-at.bofh.it> |
| In reply to | #1633302 |
[Multipart message — attachments visible in raw view] — view raw
Hi,
Please make sure you Cc the relevant people / mailing lists. You
can use ./scripts/get_maintainer.pl to find out who should receive
the patches.
On Sat, Apr 29, 2017 at 05:34:29PM +0300, Alex A. Mihaylov wrote:
> Maxim Semiconductor MAX17211/MAX17215 single/multi-cell fuel gauge
> monitor with M5 Fuel Gauge algorithm
>
> This driver provide userspace access to MAX17211/MAX17215 data with
> power_supply class drivers.
> ---
> drivers/power/supply/Kconfig | 8 +
> drivers/power/supply/Makefile | 1 +
Please move the entries in both files before CONFIG_BATTERY_MAX17040.
> [...]
>
> + * FixMe:
> + * Device without no_thermal = true not register (err -22)
> + * Len of platform device name "max17211-battery.X.auto"
> + * more than 20 chars limit in THERMAL_NAME_LENGTH from
> + * include/uapi/linux/thermal.h
> + */
IIRC we already had problems with small THERMAL_NAME_LENGTH before.
I suggest to add another patch, that increases THERMAL_NAME_LENGTH
(don't forget to Cc/To the thermal subsystem people).
> + info->bat_desc.no_thermal = true;
> + psy_cfg.drv_data = info;
> +
> + if (w1_max1721x_reg_get(info->w1_dev,
> + MAX1721X_REG_NRSENSE, &info->rsense))
> + return -ENODEV;
> +
> + if (!info->rsense) {
> + dev_warn(info->dev, "RSenese not calibrated, set 10 mOhms!\n");
> + info->rsense = 1000; /* in regs in 10^-5 */
> + }
> + dev_dbg(info->dev, "RSense: %d mOhms.\n", info->rsense / 100);
> +
> + if (get_string(info->w1_dev, MAX1721X_REG_MFG_STR,
> + MAX1721X_REG_MFG_NUMB, info->ManufacturerName)) {
> + dev_err(info->dev, "Can't read manufacturer. Hardware error.\n");
> + return -ENODEV;
> + }
> +
> + if (!info->ManufacturerName[0])
> + strncpy(info->ManufacturerName, DEF_MFG_NAME,
> + 2 * MAX1721X_REG_MFG_NUMB);
> +
> + if (get_string(info->w1_dev, MAX1721X_REG_DEV_STR,
> + MAX1721X_REG_DEV_NUMB, info->DeviceName)) {
> + dev_err(info->dev, "Can't read device. Hardware error.\n");
> + return -ENODEV;
> + }
> + if (!info->DeviceName[0]) {
> + uint16_t dev_name;
> +
> + if (w1_max1721x_reg_get(info->w1_dev,
> + MAX172XX_REG_DEVNAME, &dev_name)) {
> + dev_err(info->w1_dev, "Can't read device name reg.\n");
> + return -ENODEV;
> + }
> +
> + switch (dev_name & MAX172XX_DEV_MASK) {
> + case MAX172X1_DEV:
> + strncpy(info->DeviceName, DEF_DEV_NAME_MAX17211,
> + 2 * MAX1721X_REG_DEV_NUMB);
> + break;
> + case MAX172X5_DEV:
> + strncpy(info->DeviceName, DEF_DEV_NAME_MAX17215,
> + 2 * MAX1721X_REG_DEV_NUMB);
> + break;
> + default:
> + strncpy(info->DeviceName, DEF_DEV_NAME_UNKNOWN,
> + 2 * MAX1721X_REG_DEV_NUMB);
> + }
> + }
> +
> + if (get_sn_string(info->w1_dev, info->SerialNumber)) {
> + dev_err(info->dev, "Can't read serial. Hardware error.\n");
> + return -ENODEV;
> + }
> +
> + info->bat = power_supply_register(&pdev->dev, &info->bat_desc,
> + &psy_cfg);
> + if (IS_ERR(info->bat)) {
> + dev_err(info->dev, "failed to register battery\n");
> + return PTR_ERR(info->bat);
> + }
Please use devm_power_supply_register() and drop the remove
function.
> + return 0;
> +}
> +
> +static int max1721x_battery_remove(struct platform_device *pdev)
> +{
> + struct max17211_device_info *info = platform_get_drvdata(pdev);
> +
> + power_supply_unregister(info->bat);
> +
> + return 0;
> +}
> +
> +static struct platform_driver max1721x_battery_driver = {
> + .driver = {
> + .name = "max1721x-battery",
> + },
> + .probe = max1721x_battery_probe,
> + .remove = max1721x_battery_remove,
> +};
> +module_platform_driver(max1721x_battery_driver);
> +
> +MODULE_LICENSE("GPL");
> +MODULE_AUTHOR("Alex A. Mihaylov <minimumlaw@rambler.ru>");
> +MODULE_DESCRIPTION("Maxim MAX17211/MAX17215 Fuel Gauage IC driver");
> +MODULE_ALIAS("platform:max1721x-battery");
-- Sebastian
[toc] | [prev] | [next] | [standalone]
| From | Михайлов Алексей Анатольевич <minimumlaw@rambler.ru> |
|---|---|
| Date | 2017-04-30 19:40 +0200 |
| Message-ID | <tC0Zb-65x-5@gated-at.bofh.it> |
| In reply to | #1633310 |
Hi!
>> [...]
>>
>> + * FixMe:
>> + * Device without no_thermal = true not register (err -22)
>> + * Len of platform device name "max17211-battery.X.auto"
>> + * more than 20 chars limit in THERMAL_NAME_LENGTH from
>> + * include/uapi/linux/thermal.h
>> + */
> IIRC we already had problems with small THERMAL_NAME_LENGTH before.
> I suggest to add another patch, that increases THERMAL_NAME_LENGTH
> (don't forget to Cc/To the thermal subsystem people).
May be rename "max17211-battery" to "max17211" and remove no_thermal =
true? This case thermal zone will work again. In current (mainline)
kernel all drivers "xxxxxx-battery" (like ds2780-battery or
ds2760-battery) compiled, but not working (not registered). They can
start working again without thermal zone by adding no_thermal = true or
by remove "-battery" from platform device name. Alternative limit on
THERMAL_NAME_LENGTH may be extended.
>> + info->bat = power_supply_register(&pdev->dev, &info->bat_desc,
>> + &psy_cfg);
>> + if (IS_ERR(info->bat)) {
>> + dev_err(info->dev, "failed to register battery\n");
>> + return PTR_ERR(info->bat);
>> + }
> Please use devm_power_supply_register() and drop the remove
> function.
Khm... probe/remove paired functions. I can use
devm_power_supply_register in my code. But all other fuel gauge drivers
use classic probe/remove pair. Which decision will be more correct?
[toc] | [prev] | [next] | [standalone]
| From | Sebastian Reichel <sre@kernel.org> |
|---|---|
| Date | 2017-04-30 22:50 +0200 |
| Message-ID | <tC3X3-7VU-1@gated-at.bofh.it> |
| In reply to | #1633468 |
[Multipart message — attachments visible in raw view] — view raw
Hi,
On Sun, Apr 30, 2017 at 08:32:10PM +0300, Михайлов Алексей Анатольевич wrote:
> > IIRC we already had problems with small THERMAL_NAME_LENGTH before.
> > I suggest to add another patch, that increases THERMAL_NAME_LENGTH
> > (don't forget to Cc/To the thermal subsystem people).
> May be rename "max17211-battery" to "max17211" and remove no_thermal = true?
> This case thermal zone will work again. In current (mainline) kernel all
> drivers "xxxxxx-battery" (like ds2780-battery or ds2760-battery) compiled,
> but not working (not registered). They can start working again without
> thermal zone by adding no_thermal = true or by remove "-battery" from
> platform device name. Alternative limit on THERMAL_NAME_LENGTH may be
> extended.
I think increasing THERMAL_NAME_LENGTH is the right way.
> > > + info->bat = power_supply_register(&pdev->dev, &info->bat_desc,
> > > + &psy_cfg);
> > > + if (IS_ERR(info->bat)) {
> > > + dev_err(info->dev, "failed to register battery\n");
> > > + return PTR_ERR(info->bat);
> > > + }
> > Please use devm_power_supply_register() and drop the remove
> > function.
> Khm... probe/remove paired functions. I can use devm_power_supply_register
> in my code. But all other fuel gauge drivers use classic probe/remove pair.
> Which decision will be more correct?
Most drivers are older than devm_power_supply_register. We already
have a few fuel gauge drivers, which use it, though:
$ git grep devm_power_supply_register | grep "battery"
88pm860x_battery.c: info->battery = devm_power_supply_register(&pdev->dev,
da9150-fg.c: fg->battery = devm_power_supply_register(dev, &fg_desc, NULL);
max17042_battery.c: chip->battery = devm_power_supply_register(&client->dev, max17042_desc,
max8997_charger.c: charger->battery = devm_power_supply_register(&pdev->dev,
max8998_charger.c: max8998->battery = devm_power_supply_register(max8998->dev,
sbs-battery.c: chip->power_supply = devm_power_supply_register(&client->dev, sbs_desc,
-- Sebastian
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web