Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1633156 > unrolled thread
| Started by | Rob Herring <robh@kernel.org> |
|---|---|
| First post | 2017-04-28 23:00 +0200 |
| Last post | 2017-05-02 09:50 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH v3 1/2] ASoC: stm32: add bindings for SAI Rob Herring <robh@kernel.org> - 2017-04-28 23:00 +0200
Re: [PATCH v3 1/2] ASoC: stm32: add bindings for SAI Olivier MOYSAN <olivier.moysan@st.com> - 2017-05-02 09:50 +0200
| From | Rob Herring <robh@kernel.org> |
|---|---|
| Date | 2017-04-28 23:00 +0200 |
| Subject | Re: [PATCH v3 1/2] ASoC: stm32: add bindings for SAI |
| Message-ID | <tBl9E-4mT-3@gated-at.bofh.it> |
On Mon, Apr 10, 2017 at 05:19:55PM +0200, olivier moysan wrote:
> This patch adds documentation of device tree bindings for the
> STM32 SAI ASoC driver.
>
> Signed-off-by: olivier moysan <olivier.moysan@st.com>
> ---
> .../devicetree/bindings/sound/st,stm32-sai.txt | 89 ++++++++++++++++++++++
> 1 file changed, 89 insertions(+)
> create mode 100644 Documentation/devicetree/bindings/sound/st,stm32-sai.txt
>
> diff --git a/Documentation/devicetree/bindings/sound/st,stm32-sai.txt b/Documentation/devicetree/bindings/sound/st,stm32-sai.txt
> new file mode 100644
> index 0000000..c59a3d7
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/sound/st,stm32-sai.txt
> @@ -0,0 +1,89 @@
> +STMicroelectronics STM32 Serial Audio Interface (SAI).
[...]
> + sai1b: audio-controller@40015824 {
> + #sound-dai-cells = <0>;
> + compatible = "st,stm32-sai-sub-b";
> + reg = <0x40015824 0x1C>;
> + clocks = <&rcc 1 CLK_SAI2>;
> + clock-names = "sai_ck";
> + dmas = <&dma2 5 0 0x400 0x0>;
> + dma-names = "tx";
> + pinctrl-names = "default";
> + pinctrl-0 = <&pinctrl_sai1b>;
> +
> + ports {
> + #address-cells = <1>;
> + #size-cells = <0>;
> +
> + sai1b_port: port@0 {
> + reg = <0>;
> + cpu_endpoint: endpoint {
> + remote-endpoint = <&codec_endpoint>;
> + audio-graph-card,format = "i2s";
> + audio-graph-card,bitclock-master = <&codec_endpoint>;
> + audio-graph-card,frame-master = <&codec_endpoint>;
These property names are wrong.
> + };
> + };
> + };
> + };
> +};
> +
> +audio-codec {
> + codec_port: port {
> + codec_endpoint: endpoint {
> + remote-endpoint = <&cpu_endpoint>;
> + };
> + };
> +};
> --
> 1.9.1
>
[toc] | [next] | [standalone]
| From | Olivier MOYSAN <olivier.moysan@st.com> |
|---|---|
| Date | 2017-05-02 09:50 +0200 |
| Message-ID | <tCAJk-3zE-15@gated-at.bofh.it> |
| In reply to | #1633156 |
Hello Rob,
On 04/28/2017 10:53 PM, Rob Herring wrote:
> On Mon, Apr 10, 2017 at 05:19:55PM +0200, olivier moysan wrote:
>> This patch adds documentation of device tree bindings for the
>> STM32 SAI ASoC driver.
>>
>> Signed-off-by: olivier moysan <olivier.moysan@st.com>
>> ---
>> .../devicetree/bindings/sound/st,stm32-sai.txt | 89 ++++++++++++++++++++++
>> 1 file changed, 89 insertions(+)
>> create mode 100644 Documentation/devicetree/bindings/sound/st,stm32-sai.txt
>>
>> diff --git a/Documentation/devicetree/bindings/sound/st,stm32-sai.txt b/Documentation/devicetree/bindings/sound/st,stm32-sai.txt
>> new file mode 100644
>> index 0000000..c59a3d7
>> --- /dev/null
>> +++ b/Documentation/devicetree/bindings/sound/st,stm32-sai.txt
>> @@ -0,0 +1,89 @@
>> +STMicroelectronics STM32 Serial Audio Interface (SAI).
>
> [...]
>
>> + sai1b: audio-controller@40015824 {
>> + #sound-dai-cells = <0>;
>> + compatible = "st,stm32-sai-sub-b";
>> + reg = <0x40015824 0x1C>;
>> + clocks = <&rcc 1 CLK_SAI2>;
>> + clock-names = "sai_ck";
>> + dmas = <&dma2 5 0 0x400 0x0>;
>> + dma-names = "tx";
>> + pinctrl-names = "default";
>> + pinctrl-0 = <&pinctrl_sai1b>;
>> +
>> + ports {
>> + #address-cells = <1>;
>> + #size-cells = <0>;
>> +
>> + sai1b_port: port@0 {
>> + reg = <0>;
>> + cpu_endpoint: endpoint {
>> + remote-endpoint = <&codec_endpoint>;
>> + audio-graph-card,format = "i2s";
>> + audio-graph-card,bitclock-master = <&codec_endpoint>;
>> + audio-graph-card,frame-master = <&codec_endpoint>;
>
> These property names are wrong.
>
I have taken into account this comment (and previous ones).
They will be included in next update of this patch set.
>> + };
>> + };
>> + };
>> + };
>> +};
>> +
>> +audio-codec {
>> + codec_port: port {
>> + codec_endpoint: endpoint {
>> + remote-endpoint = <&cpu_endpoint>;
>> + };
>> + };
>> +};
>> --
>> 1.9.1
>>
Best regards
Olivier
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web