Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1563670 > unrolled thread
| Started by | Geliang Tang <geliangtang@gmail.com> |
|---|---|
| First post | 2017-01-20 15:40 +0100 |
| Last post | 2017-01-20 18:50 +0100 |
| Articles | 3 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH] ext4: use i_blocksize() Geliang Tang <geliangtang@gmail.com> - 2017-01-20 15:40 +0100
[PATCH] truncate: use i_blocksize() Geliang Tang <geliangtang@gmail.com> - 2017-01-20 15:40 +0100
Re: [PATCH] truncate: use i_blocksize() Ross Zwisler <ross.zwisler@linux.intel.com> - 2017-01-20 18:50 +0100
| From | Geliang Tang <geliangtang@gmail.com> |
|---|---|
| Date | 2017-01-20 15:40 +0100 |
| Subject | [PATCH] ext4: use i_blocksize() |
| Message-ID | <t1Iwa-8q4-19@gated-at.bofh.it> |
Since i_blocksize() helper has been defined in fs.h, use it instead of open-coding. Signed-off-by: Geliang Tang <geliangtang@gmail.com> --- fs/ext4/move_extent.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/fs/ext4/move_extent.c b/fs/ext4/move_extent.c index 578f8c3..60222ed 100644 --- a/fs/ext4/move_extent.c +++ b/fs/ext4/move_extent.c @@ -382,7 +382,7 @@ move_extent_per_page(struct file *o_filp, struct inode *donor_inode, /* Perform all necessary steps similar write_begin()/write_end() * but keeping in mind that i_size will not change */ if (!page_has_buffers(pagep[0])) - create_empty_buffers(pagep[0], 1 << orig_inode->i_blkbits, 0); + create_empty_buffers(pagep[0], i_blocksize(orig_inode), 0); bh = page_buffers(pagep[0]); for (i = 0; i < data_offset_in_page; i++) bh = bh->b_this_page; -- 2.9.3
[toc] | [next] | [standalone]
| From | Geliang Tang <geliangtang@gmail.com> |
|---|---|
| Date | 2017-01-20 15:40 +0100 |
| Subject | [PATCH] truncate: use i_blocksize() |
| Message-ID | <t1Iwb-8q4-47@gated-at.bofh.it> |
| In reply to | #1563670 |
Since i_blocksize() helper has been defined in fs.h, use it instead
of open-coding.
Signed-off-by: Geliang Tang <geliangtang@gmail.com>
---
mm/truncate.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/mm/truncate.c b/mm/truncate.c
index dd7b24e..4c49a9b 100644
--- a/mm/truncate.c
+++ b/mm/truncate.c
@@ -785,7 +785,7 @@ EXPORT_SYMBOL(truncate_setsize);
*/
void pagecache_isize_extended(struct inode *inode, loff_t from, loff_t to)
{
- int bsize = 1 << inode->i_blkbits;
+ int bsize = i_blocksize(inode);
loff_t rounded_from;
struct page *page;
pgoff_t index;
--
2.9.3
[toc] | [prev] | [next] | [standalone]
| From | Ross Zwisler <ross.zwisler@linux.intel.com> |
|---|---|
| Date | 2017-01-20 18:50 +0100 |
| Subject | Re: [PATCH] truncate: use i_blocksize() |
| Message-ID | <t1Lu1-1Nd-1@gated-at.bofh.it> |
| In reply to | #1563671 |
On Fri, Jan 20, 2017 at 10:29:54PM +0800, Geliang Tang wrote: > Since i_blocksize() helper has been defined in fs.h, use it instead > of open-coding. > > Signed-off-by: Geliang Tang <geliangtang@gmail.com> Sure this seems correct. Reviewed-by: Ross Zwisler <ross.zwisler@linux.intel.com>
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web