Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1562127 > unrolled thread

Re: [PATCH v2 1/2] dt-bindings: usb: add DT binding for s3c2410 USB device controller

Started byRob Herring <robh@kernel.org>
First post2017-01-18 21:10 +0100
Last post2017-01-24 19:30 +0100
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v2 1/2] dt-bindings: usb: add DT binding for s3c2410 USB  device controller Rob Herring <robh@kernel.org> - 2017-01-18 21:10 +0100
    Re: [PATCH v2 1/2] dt-bindings: usb: add DT binding for s3c2410 USB  device controller Sergio Prado <sergio.prado@e-labworks.com> - 2017-01-24 19:30 +0100

#1562127 — Re: [PATCH v2 1/2] dt-bindings: usb: add DT binding for s3c2410 USB device controller

FromRob Herring <robh@kernel.org>
Date2017-01-18 21:10 +0100
SubjectRe: [PATCH v2 1/2] dt-bindings: usb: add DT binding for s3c2410 USB device controller
Message-ID<t14Iq-91-3@gated-at.bofh.it>
On Wed, Jan 11, 2017 at 08:02:29PM -0200, Sergio Prado wrote:
> Adds the device tree bindings description for Samsung S3C2410 and
> compatible USB device controller.
> 
> Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>
> ---
>  .../devicetree/bindings/usb/s3c2410-usb.txt        | 28 ++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
> 
> diff --git a/Documentation/devicetree/bindings/usb/s3c2410-usb.txt b/Documentation/devicetree/bindings/usb/s3c2410-usb.txt
> index e45b38ce2986..28353eea31fd 100644
> --- a/Documentation/devicetree/bindings/usb/s3c2410-usb.txt
> +++ b/Documentation/devicetree/bindings/usb/s3c2410-usb.txt
> @@ -20,3 +20,31 @@ usb0: ohci@49000000 {
>  	clocks = <&clocks UCLK>, <&clocks HCLK_USBH>;
>  	clock-names = "usb-bus-host", "usb-host";
>  };
> +
> +Samsung S3C2410 and compatible USB device controller
> +
> +Required properties:
> + - compatible: Should be one of the following
> +	       "samsung,s3c2410-udc"
> +	       "samsung,s3c2440-udc"
> + - reg: address and length of the controller memory mapped region
> + - interrupts: interrupt number for the USB device controller
> + - clocks: Should reference the bus and host clocks
> + - clock-names: Should contain two strings
> +		"uclk" for the USB bus clock
> +		"usb-device" for the USB device clock

Perhaps just "bus" and "device".

> +
> +Optional properties:
> + - samsung,vbus-gpio: specifies a gpio that allows to detect whether
> +   vbus is present - USB is connected (active high, input).
> + - samsung,pullup-gpio: If present, specifies a gpio to control the
> +   USB D+ pullup (active high, output).

"-gpios", not "-gpio" is preferred.

These should be common property names if we're going to have them. The 
problem with just "vbus-gpios" is does that mean an enable control or 
status as you have. I guess in the former case, that should always be 
modeled as a regulator.

Also, these should all be part of a connector node as these controls are 
more related to the USB connector than the controller. And I don't mean 
extcon here because those bindings are a mess.

Rob

[toc] | [next] | [standalone]


#1566044

FromSergio Prado <sergio.prado@e-labworks.com>
Date2017-01-24 19:30 +0100
Message-ID<t3e0V-7Jk-3@gated-at.bofh.it>
In reply to#1562127
On Wed, Jan 18, 2017 at 02:08:45PM -0600, Rob Herring wrote:
> On Wed, Jan 11, 2017 at 08:02:29PM -0200, Sergio Prado wrote:
> > + - clocks: Should reference the bus and host clocks
> > + - clock-names: Should contain two strings
> > +		"uclk" for the USB bus clock
> > +		"usb-device" for the USB device clock
> 
> Perhaps just "bus" and "device".

OK, I'll rename.

> > +
> > +Optional properties:
> > + - samsung,vbus-gpio: specifies a gpio that allows to detect whether
> > +   vbus is present - USB is connected (active high, input).
> > + - samsung,pullup-gpio: If present, specifies a gpio to control the
> > +   USB D+ pullup (active high, output).
> 
> "-gpios", not "-gpio" is preferred.
> 
> These should be common property names if we're going to have them. The 
> problem with just "vbus-gpios" is does that mean an enable control or 
> status as you have. I guess in the former case, that should always be 
> modeled as a regulator.
> 
> Also, these should all be part of a connector node as these controls are 
> more related to the USB connector than the controller. And I don't mean 
> extcon here because those bindings are a mess.

There are other bindings that are doing the same thing I did, like the
property "atmel,vbus-gpio" in atmel-usb.txt and "samsung,vbus-gpio" in
exynos-usb.txt. Also, I did not find any example of a connector node doing
this. Can you point me out to an example, or should I just rename to
"-gpios" in this case?

> 
> Rob

-- 
Sergio Prado
Embedded Labworks
Office: +55 11 2628-3461
Mobile: +55 11 97123-3420

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web