Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1561034 > unrolled thread

Re: [PATCH v2 3/6] ALSA: hda - rename dell_led_set_func to dell_micmute_led_set_func

Started byJacek Anaszewski <jacek.anaszewski@gmail.com>
First post2017-01-17 22:30 +0100
Last post2017-01-17 22:30 +0100
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v2 3/6] ALSA: hda - rename dell_led_set_func to  dell_micmute_led_set_func Jacek Anaszewski <jacek.anaszewski@gmail.com> - 2017-01-17 22:30 +0100

#1561034 — Re: [PATCH v2 3/6] ALSA: hda - rename dell_led_set_func to dell_micmute_led_set_func

FromJacek Anaszewski <jacek.anaszewski@gmail.com>
Date2017-01-17 22:30 +0100
SubjectRe: [PATCH v2 3/6] ALSA: hda - rename dell_led_set_func to dell_micmute_led_set_func
Message-ID<t0Juh-3NG-7@gated-at.bofh.it>
Hi Jaroslav, Takashi,

I need an ack from sound sybsystem maintainer.
Are you OK with this patch going through LED tree?

Best regards,
Jacek Anaszewski

On 01/16/2017 02:22 PM, Michał Kępień wrote:
> With dell_app_wmi_led_set() replaced by dell_micmute_led_set(), rename
> the function pointer to the latter for consistency.
> 
> Signed-off-by: Michał Kępień <kernel@kempniu.pl>
> ---
>  sound/pci/hda/dell_wmi_helper.c | 20 ++++++++++----------
>  1 file changed, 10 insertions(+), 10 deletions(-)
> 
> diff --git a/sound/pci/hda/dell_wmi_helper.c b/sound/pci/hda/dell_wmi_helper.c
> index e128c8096772..516237ad6ef5 100644
> --- a/sound/pci/hda/dell_wmi_helper.c
> +++ b/sound/pci/hda/dell_wmi_helper.c
> @@ -6,7 +6,7 @@
>  #include <linux/dell-led.h>
>  
>  static int dell_led_value;
> -static int (*dell_led_set_func)(int);
> +static int (*dell_micmute_led_set_func)(int);
>  static void (*dell_old_cap_hook)(struct hda_codec *,
>  			         struct snd_kcontrol *,
>  				 struct snd_ctl_elem_value *);
> @@ -18,7 +18,7 @@ static void update_dell_wmi_micmute_led(struct hda_codec *codec,
>  	if (dell_old_cap_hook)
>  		dell_old_cap_hook(codec, kcontrol, ucontrol);
>  
> -	if (!ucontrol || !dell_led_set_func)
> +	if (!ucontrol || !dell_micmute_led_set_func)
>  		return;
>  	if (strcmp("Capture Switch", ucontrol->id.name) == 0 && ucontrol->id.index == 0) {
>  		/* TODO: How do I verify if it's a mono or stereo here? */
> @@ -26,8 +26,8 @@ static void update_dell_wmi_micmute_led(struct hda_codec *codec,
>  		if (val == dell_led_value)
>  			return;
>  		dell_led_value = val;
> -		if (dell_led_set_func)
> -			dell_led_set_func(dell_led_value);
> +		if (dell_micmute_led_set_func)
> +			dell_micmute_led_set_func(dell_led_value);
>  	}
>  }
>  
> @@ -39,15 +39,15 @@ static void alc_fixup_dell_wmi(struct hda_codec *codec,
>  	bool removefunc = false;
>  
>  	if (action == HDA_FIXUP_ACT_PROBE) {
> -		if (!dell_led_set_func)
> -			dell_led_set_func = symbol_request(dell_micmute_led_set);
> -		if (!dell_led_set_func) {
> +		if (!dell_micmute_led_set_func)
> +			dell_micmute_led_set_func = symbol_request(dell_micmute_led_set);
> +		if (!dell_micmute_led_set_func) {
>  			codec_warn(codec, "Failed to find dell wmi symbol dell_micmute_led_set\n");
>  			return;
>  		}
>  
>  		removefunc = true;
> -		if (dell_led_set_func(false) >= 0) {
> +		if (dell_micmute_led_set_func(false) >= 0) {
>  			dell_led_value = 0;
>  			if (spec->gen.num_adc_nids > 1 && !spec->gen.dyn_adc_switch)
>  				codec_dbg(codec, "Skipping micmute LED control due to several ADCs");
> @@ -60,9 +60,9 @@ static void alc_fixup_dell_wmi(struct hda_codec *codec,
>  
>  	}
>  
> -	if (dell_led_set_func && (action == HDA_FIXUP_ACT_FREE || removefunc)) {
> +	if (dell_micmute_led_set_func && (action == HDA_FIXUP_ACT_FREE || removefunc)) {
>  		symbol_put(dell_micmute_led_set);
> -		dell_led_set_func = NULL;
> +		dell_micmute_led_set_func = NULL;
>  		dell_old_cap_hook = NULL;
>  	}
>  }
> 

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web