Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1506702 > unrolled thread

[PATCH v3] x86/entry64: remove unused audit related macros

Started byAlexander Kuleshov <kuleshovmail@gmail.com>
First post2016-10-23 16:00 +0200
Last post2016-10-25 12:40 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH v3] x86/entry64: remove unused audit related macros Alexander Kuleshov <kuleshovmail@gmail.com> - 2016-10-23 16:00 +0200
    [tip:x86/asm] x86/entry64: Remove unused audit related macros tip-bot for Alexander Kuleshov <tipbot@zytor.com> - 2016-10-25 12:40 +0200

#1506702 — [PATCH v3] x86/entry64: remove unused audit related macros

FromAlexander Kuleshov <kuleshovmail@gmail.com>
Date2016-10-23 16:00 +0200
Subject[PATCH v3] x86/entry64: remove unused audit related macros
Message-ID<svrtD-1D9-9@gated-at.bofh.it>
These macros were added in:

  86a1c34 ("x86_64 syscall audit fast-path")

commit. They were used in two-phase sycalls entry tracing,
but this functionality was moved to the
arch/x86/entry/common.c:syscall_trace_enter() in:

  1f484aa ("x86/entry: Move C entry and exit code to arch/x86/entry/common.c")

commit.

syscall_trace_enter() now uses same defines from <linux/audit.h>,
so these defines are no longer used anywhere in entry_64.S outside
of it and we may remove them.

Signed-off-by: Alexander Kuleshov <kuleshovmail@gmail.com>
Reviewed-by: Borislav Petkov <bp@suse.de>
---
ChangeLog:

v1 -> v2:

- Added more details in the commit message.

v2 -> v2:

- Make commit message more readable  

 arch/x86/entry/entry_64.S | 6 ------
 1 file changed, 6 deletions(-)

diff --git a/arch/x86/entry/entry_64.S b/arch/x86/entry/entry_64.S
index ef766a3..4362f1c 100644
--- a/arch/x86/entry/entry_64.S
+++ b/arch/x86/entry/entry_64.S
@@ -38,12 +38,6 @@
 #include <asm/export.h>
 #include <linux/err.h>
 
-/* Avoid __ASSEMBLER__'ifying <linux/audit.h> just for this.  */
-#include <linux/elf-em.h>
-#define AUDIT_ARCH_X86_64			(EM_X86_64|__AUDIT_ARCH_64BIT|__AUDIT_ARCH_LE)
-#define __AUDIT_ARCH_64BIT			0x80000000
-#define __AUDIT_ARCH_LE				0x40000000
-
 .code64
 .section .entry.text, "ax"
 
-- 
2.8.0.rc3.1353.gea9bdc0

[toc] | [next] | [standalone]


#1508171 — [tip:x86/asm] x86/entry64: Remove unused audit related macros

Fromtip-bot for Alexander Kuleshov <tipbot@zytor.com>
Date2016-10-25 12:40 +0200
Subject[tip:x86/asm] x86/entry64: Remove unused audit related macros
Message-ID<sw7jc-4nV-13@gated-at.bofh.it>
In reply to#1506702
Commit-ID:  5e25d5bdf6d407224ad185a3fb8b870ad7d6c627
Gitweb:     http://git.kernel.org/tip/5e25d5bdf6d407224ad185a3fb8b870ad7d6c627
Author:     Alexander Kuleshov <kuleshovmail@gmail.com>
AuthorDate: Sun, 23 Oct 2016 19:56:46 +0600
Committer:  Ingo Molnar <mingo@kernel.org>
CommitDate: Tue, 25 Oct 2016 11:43:31 +0200

x86/entry64: Remove unused audit related macros

These macros were added in the following commit:

  86a1c34a929f ("x86_64 syscall audit fast-path")

They were used in two-phase sycalls entry tracing, but this functionality
was then moved to the arch/x86/entry/common.c:syscall_trace_enter() function,
in the following commit:

  1f484aa69046 ("x86/entry: Move C entry and exit code to arch/x86/entry/common.c")

syscall_trace_enter() now uses the defines from <linux/audit.h>,
so these defines entry_64.S are no longer used anywhere.

Signed-off-by: Alexander Kuleshov <kuleshovmail@gmail.com>
Reviewed-by: Borislav Petkov <bp@suse.de>
Cc: Andy Lutomirski <luto@kernel.org>
Cc: Borislav Petkov <bp@alien8.de>
Cc: Brian Gerst <brgerst@gmail.com>
Cc: Denys Vlasenko <dvlasenk@redhat.com>
Cc: H. Peter Anvin <hpa@zytor.com>
Cc: Josh Poimboeuf <jpoimboe@redhat.com>
Cc: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Paolo Bonzini <pbonzini@redhat.com>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Thomas Gleixner <tglx@linutronix.de>
Link: http://lkml.kernel.org/r/20161023135646.4453-1-kuleshovmail@gmail.com
Signed-off-by: Ingo Molnar <mingo@kernel.org>
---
 arch/x86/entry/entry_64.S | 6 ------
 1 file changed, 6 deletions(-)

diff --git a/arch/x86/entry/entry_64.S b/arch/x86/entry/entry_64.S
index 65fad8a..5b21970 100644
--- a/arch/x86/entry/entry_64.S
+++ b/arch/x86/entry/entry_64.S
@@ -38,12 +38,6 @@
 #include <asm/export.h>
 #include <linux/err.h>
 
-/* Avoid __ASSEMBLER__'ifying <linux/audit.h> just for this.  */
-#include <linux/elf-em.h>
-#define AUDIT_ARCH_X86_64			(EM_X86_64|__AUDIT_ARCH_64BIT|__AUDIT_ARCH_LE)
-#define __AUDIT_ARCH_64BIT			0x80000000
-#define __AUDIT_ARCH_LE				0x40000000
-
 .code64
 .section .entry.text, "ax"
 

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web