Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1495694 > unrolled thread

RE: Re: [PATCH v2 2/5] ramoops: introduce generic init/free functions for prz

Started by岩松信洋 / IWAMATSU,NOBUHIRO <nobuhiro.iwamatsu.kw@hitachi.com>
First post2016-10-05 06:50 +0200
Last post2016-10-05 06:50 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  RE: Re: [PATCH v2 2/5] ramoops: introduce generic init/free  functions for prz 岩松信洋 / IWAMATSU,NOBUHIRO          <nobuhiro.iwamatsu.kw@hitachi.com> - 2016-10-05 06:50 +0200

#1495694 — RE: Re: [PATCH v2 2/5] ramoops: introduce generic init/free functions for prz

From岩松信洋 / IWAMATSU,NOBUHIRO <nobuhiro.iwamatsu.kw@hitachi.com>
Date2016-10-05 06:50 +0200
SubjectRE: Re: [PATCH v2 2/5] ramoops: introduce generic init/free functions for prz
Message-ID<soMjv-4ib-1@gated-at.bofh.it>
Hi,


Thanks for youre review.

> -----Original Message-----
> From: keescook@google.com [mailto:keescook@google.com] On Behalf Of Kees
> Cook
> Sent: Friday, September 09, 2016 6:23 AM
> To: 岩松信洋 / IWAMATSU,NOBUHIRO
> Cc: Anton Vorontsov; Colin Cross; Tony Luck; LKML; Hiraku Toyooka; Mark
> Salyzyn; 阿口誠司 / AGUCHI,SEIJI
> Subject: [!]Re: [PATCH v2 2/5] ramoops: introduce generic init/free
> functions for prz
> 
> On Sun, Jul 24, 2016 at 8:56 PM, Nobuhiro Iwamatsu
> <nobuhiro.iwamatsu.kw@hitachi.com> wrote:
> > From: Hiraku Toyooka <hiraku.toyooka.gu@hitachi.com>
> >
> > We modifies initialization and freeing code for prz for generic usage.
> 
> Sorry for the delay in getting to this review, I've been catching up on
> pstore finally. :)
> 
> > This change
> >
> >  * add generic function __ramoops_init_prz() to reduce redundancy
> >    between ramoops_init_prz() and ramoops_init_przs().
> 
> Can you split this into a separate patch?

OK, I will do.
> 
> >  * rename 'przs' member in struct ramoops_context to 'dprzs' so that
> >    it stands for 'dump przs'.
> >  * rename ramoops_init_prz() to ramoops_init_dprzs().
> 
> And also these two into a separate patch, since it's just a renaming.
> And could you add comments for all the przs, it's getting harder to read
> these since they're just single-letter names. :)
> 
> >  * change parameter of ramoops_free_przs() from struct ramoops_context
> *
> >    into struct persistent_ram_zone * in order to make it available for
> >    all prz array.
> 
> I *think* this should be with the first change, so splitting this email's
> patch into two patches would make review easier (i.e. first do renamings,
> then make functional changes).

OK, I will do too.

> 
> > Signed-off-by: Hiraku Toyooka <hiraku.toyooka.gu@hitachi.com>
> > Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.kw@hitachi.com>
> > Cc: Mark Salyzyn <salyzyn@android.com>
> > Cc: Seiji Aguchi <seiji.aguchi.tr@hitachi.com>

<snip>

> 
> Thanks!
> 
> -Kees
> 
> --
> Kees Cook
> Nexus Security

Best regards,
  Nobuhiro

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web