Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1481308 > unrolled thread
| Started by | Bhumika Goyal <bhumirks@gmail.com> |
|---|---|
| First post | 2016-09-12 16:00 +0200 |
| Last post | 2016-09-12 19:00 +0200 |
| Articles | 3 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH] Staging: rtl8188eu: Remove ternary operator Bhumika Goyal <bhumirks@gmail.com> - 2016-09-12 16:00 +0200
Re: [Outreachy kernel] [PATCH] Staging: rtl8188eu: Remove ternary operator Jes Sorensen <jes.sorensen@gmail.com> - 2016-09-12 16:50 +0200
Re: [Outreachy kernel] [PATCH] Staging: rtl8188eu: Remove ternary operator Bhumika Goyal <bhumirks@gmail.com> - 2016-09-12 19:00 +0200
| From | Bhumika Goyal <bhumirks@gmail.com> |
|---|---|
| Date | 2016-09-12 16:00 +0200 |
| Subject | [PATCH] Staging: rtl8188eu: Remove ternary operator |
| Message-ID | <sgzW9-41n-19@gated-at.bofh.it> |
Relational and logical operators evaluate to either true or false.
Explicit conversion is not needed so remove the ternary operator.
Done using coccinelle:
@r@
expression A,B;
symbol true,false;
binary operator b = {==,!=,&&,||,>=,<=,>,<};
@@
- (A b B) ? true : false
+ A b B
Signed-off-by: Bhumika Goyal <bhumirks@gmail.com>
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 8 ++++----
drivers/staging/rtl8188eu/hal/phy.c | 2 +-
drivers/staging/rtl8188eu/hal/rtl8188e_dm.c | 3 ++-
3 files changed, 7 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
index 9544e55..b43f57be 100644
--- a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
+++ b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
@@ -705,7 +705,7 @@ static int issue_probereq_ex(struct adapter *padapter,
unsigned long start = jiffies;
do {
- ret = issue_probereq(padapter, pssid, da, wait_ms > 0 ? true : false);
+ ret = issue_probereq(padapter, pssid, da, wait_ms > 0);
i++;
@@ -1293,7 +1293,7 @@ int issue_nulldata(struct adapter *padapter, unsigned char *da, unsigned int pow
da = pnetwork->MacAddress;
do {
- ret = _issue_nulldata(padapter, da, power_mode, wait_ms > 0 ? true : false);
+ ret = _issue_nulldata(padapter, da, power_mode, wait_ms > 0);
i++;
@@ -1420,7 +1420,7 @@ int issue_qos_nulldata(struct adapter *padapter, unsigned char *da, u16 tid, int
da = pnetwork->MacAddress;
do {
- ret = _issue_qos_nulldata(padapter, da, tid, wait_ms > 0 ? true : false);
+ ret = _issue_qos_nulldata(padapter, da, tid, wait_ms > 0);
i++;
@@ -1527,7 +1527,7 @@ static int issue_deauth_ex(struct adapter *padapter, u8 *da,
unsigned long start = jiffies;
do {
- ret = _issue_deauth(padapter, da, reason, wait_ms > 0 ? true : false);
+ ret = _issue_deauth(padapter, da, reason, wait_ms > 0);
i++;
diff --git a/drivers/staging/rtl8188eu/hal/phy.c b/drivers/staging/rtl8188eu/hal/phy.c
index 776e5b8..41e0cbc 100644
--- a/drivers/staging/rtl8188eu/hal/phy.c
+++ b/drivers/staging/rtl8188eu/hal/phy.c
@@ -1292,7 +1292,7 @@ void rtl88eu_phy_iq_calibrate(struct adapter *adapt, bool recovery)
rOFDM0_RxIQExtAnta};
bool is2t;
- is2t = (dm_odm->RFType == ODM_2T2R) ? true : false;
+ is2t = dm_odm->RFType == ODM_2T2R;
if (!(dm_odm->SupportAbility & ODM_RF_CALIBRATION))
return;
diff --git a/drivers/staging/rtl8188eu/hal/rtl8188e_dm.c b/drivers/staging/rtl8188eu/hal/rtl8188e_dm.c
index 11e7246..962102d 100644
--- a/drivers/staging/rtl8188eu/hal/rtl8188e_dm.c
+++ b/drivers/staging/rtl8188eu/hal/rtl8188e_dm.c
@@ -60,7 +60,8 @@ static void Init_ODM_ComInfo_88E(struct adapter *Adapter)
ODM_CmnInfoInit(dm_odm, ODM_CMNINFO_CUT_VER, cut_ver);
- ODM_CmnInfoInit(dm_odm, ODM_CMNINFO_MP_TEST_CHIP, hal_data->VersionID.ChipType == NORMAL_CHIP ? true : false);
+ ODM_CmnInfoInit(dm_odm, ODM_CMNINFO_MP_TEST_CHIP,
+ hal_data->VersionID.ChipType == NORMAL_CHIP);
ODM_CmnInfoInit(dm_odm, ODM_CMNINFO_PATCH_ID, hal_data->CustomerID);
ODM_CmnInfoInit(dm_odm, ODM_CMNINFO_BWIFI_TEST, Adapter->registrypriv.wifi_spec);
--
1.9.1
[toc] | [next] | [standalone]
| From | Jes Sorensen <jes.sorensen@gmail.com> |
|---|---|
| Date | 2016-09-12 16:50 +0200 |
| Subject | Re: [Outreachy kernel] [PATCH] Staging: rtl8188eu: Remove ternary operator |
| Message-ID | <sgAIy-4zI-11@gated-at.bofh.it> |
| In reply to | #1481308 |
On 09/12/16 09:58, Bhumika Goyal wrote:
> Relational and logical operators evaluate to either true or false.
> Explicit conversion is not needed so remove the ternary operator.
> Done using coccinelle:
>
> @r@
> expression A,B;
> symbol true,false;
> binary operator b = {==,!=,&&,||,>=,<=,>,<};
> @@
> - (A b B) ? true : false
> + A b B
>
> Signed-off-by: Bhumika Goyal <bhumirks@gmail.com>
> ---
> drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 8 ++++----
> drivers/staging/rtl8188eu/hal/phy.c | 2 +-
> drivers/staging/rtl8188eu/hal/rtl8188e_dm.c | 3 ++-
> 3 files changed, 7 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
> index 9544e55..b43f57be 100644
> --- a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
> +++ b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
> @@ -705,7 +705,7 @@ static int issue_probereq_ex(struct adapter *padapter,
> unsigned long start = jiffies;
>
> do {
> - ret = issue_probereq(padapter, pssid, da, wait_ms > 0 ? true : false);
> + ret = issue_probereq(padapter, pssid, da, wait_ms > 0);
>
> i++;
>
> @@ -1293,7 +1293,7 @@ int issue_nulldata(struct adapter *padapter, unsigned char *da, unsigned int pow
> da = pnetwork->MacAddress;
>
> do {
> - ret = _issue_nulldata(padapter, da, power_mode, wait_ms > 0 ? true : false);
> + ret = _issue_nulldata(padapter, da, power_mode, wait_ms > 0);
>
> i++;
>
> @@ -1420,7 +1420,7 @@ int issue_qos_nulldata(struct adapter *padapter, unsigned char *da, u16 tid, int
> da = pnetwork->MacAddress;
>
> do {
> - ret = _issue_qos_nulldata(padapter, da, tid, wait_ms > 0 ? true : false);
> + ret = _issue_qos_nulldata(padapter, da, tid, wait_ms > 0);
>
> i++;
>
> @@ -1527,7 +1527,7 @@ static int issue_deauth_ex(struct adapter *padapter, u8 *da,
> unsigned long start = jiffies;
>
> do {
> - ret = _issue_deauth(padapter, da, reason, wait_ms > 0 ? true : false);
> + ret = _issue_deauth(padapter, da, reason, wait_ms > 0);
>
> i++;
While this part of the patch is technically correct, I would argue it
doesn't improve the code. It would make the code more readable to pass
in the wait_ms value and then have the decision made based on that in
the called function.
Cheers,
Jes
[toc] | [prev] | [next] | [standalone]
| From | Bhumika Goyal <bhumirks@gmail.com> |
|---|---|
| Date | 2016-09-12 19:00 +0200 |
| Subject | Re: [Outreachy kernel] [PATCH] Staging: rtl8188eu: Remove ternary operator |
| Message-ID | <sgCKl-5RJ-1@gated-at.bofh.it> |
| In reply to | #1481365 |
On Mon, Sep 12, 2016 at 8:14 PM, Jes Sorensen <jes.sorensen@gmail.com> wrote:
> On 09/12/16 09:58, Bhumika Goyal wrote:
>> Relational and logical operators evaluate to either true or false.
>> Explicit conversion is not needed so remove the ternary operator.
>> Done using coccinelle:
>>
>> @r@
>> expression A,B;
>> symbol true,false;
>> binary operator b = {==,!=,&&,||,>=,<=,>,<};
>> @@
>> - (A b B) ? true : false
>> + A b B
>>
>> Signed-off-by: Bhumika Goyal <bhumirks@gmail.com>
>> ---
>> drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 8 ++++----
>> drivers/staging/rtl8188eu/hal/phy.c | 2 +-
>> drivers/staging/rtl8188eu/hal/rtl8188e_dm.c | 3 ++-
>> 3 files changed, 7 insertions(+), 6 deletions(-)
>>
>> diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
>> index 9544e55..b43f57be 100644
>> --- a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
>> +++ b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
>> @@ -705,7 +705,7 @@ static int issue_probereq_ex(struct adapter *padapter,
>> unsigned long start = jiffies;
>>
>> do {
>> - ret = issue_probereq(padapter, pssid, da, wait_ms > 0 ? true : false);
>> + ret = issue_probereq(padapter, pssid, da, wait_ms > 0);
>>
>> i++;
>>
>> @@ -1293,7 +1293,7 @@ int issue_nulldata(struct adapter *padapter, unsigned char *da, unsigned int pow
>> da = pnetwork->MacAddress;
>>
>> do {
>> - ret = _issue_nulldata(padapter, da, power_mode, wait_ms > 0 ? true : false);
>> + ret = _issue_nulldata(padapter, da, power_mode, wait_ms > 0);
>>
>> i++;
>>
>> @@ -1420,7 +1420,7 @@ int issue_qos_nulldata(struct adapter *padapter, unsigned char *da, u16 tid, int
>> da = pnetwork->MacAddress;
>>
>> do {
>> - ret = _issue_qos_nulldata(padapter, da, tid, wait_ms > 0 ? true : false);
>> + ret = _issue_qos_nulldata(padapter, da, tid, wait_ms > 0);
>>
>> i++;
>>
>> @@ -1527,7 +1527,7 @@ static int issue_deauth_ex(struct adapter *padapter, u8 *da,
>> unsigned long start = jiffies;
>>
>> do {
>> - ret = _issue_deauth(padapter, da, reason, wait_ms > 0 ? true : false);
>> + ret = _issue_deauth(padapter, da, reason, wait_ms > 0);
>>
>> i++;
>
> While this part of the patch is technically correct, I would argue it
> doesn't improve the code. It would make the code more readable to pass
> in the wait_ms value and then have the decision made based on that in
> the called function.
>
Ok, I will keep the wait_ms ternary operation as it is and send a v2.
Thanks for the input.
Thanks,
Bhumika
> Cheers,
> Jes
>
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web