Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1479967 > unrolled thread

[PATCH 0/8] net: use IS_ENABLED() instead of checking for built-in or module

Started byJavier Martinez Canillas <javier@osg.samsung.com>
First post2016-09-09 14:50 +0200
Last post2016-09-11 06:20 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH 0/8] net: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-09-09 14:50 +0200
    Re: [PATCH 0/8] net: use IS_ENABLED() instead of checking for  built-in or module David Miller <davem@davemloft.net> - 2016-09-11 06:20 +0200

#1479967 — [PATCH 0/8] net: use IS_ENABLED() instead of checking for built-in or module

FromJavier Martinez Canillas <javier@osg.samsung.com>
Date2016-09-09 14:50 +0200
Subject[PATCH 0/8] net: use IS_ENABLED() instead of checking for built-in or module
Message-ID<sftpM-2S8-5@gated-at.bofh.it>
Hello David,

This trivial series replace the open coding to check for a Kconfig symbol
being built-in or module, with IS_ENABLED() macro that does exactly that.

Using the macro makes the code more readable by helping abstract away some
of the Kconfig built-in and module enable details.

Best regards,
Javier


Javier Martinez Canillas (8):
  appletalk: use IS_ENABLED() instead of checking for built-in or module
  lec: use IS_ENABLED() instead of checking for built-in or module
  net: use IS_ENABLED() instead of checking for built-in or module
  ipv4: use IS_ENABLED() instead of checking for built-in or module
  l2tp: use IS_ENABLED() instead of checking for built-in or module
  net: sched: use IS_ENABLED() instead of checking for built-in or
    module
  sctp: use IS_ENABLED() instead of checking for built-in or module
  xfrm: use IS_ENABLED() instead of checking for built-in or module

 net/appletalk/ddp.c  |  2 +-
 net/atm/lec.c        | 12 ++++++------
 net/core/dev.c       |  3 +--
 net/ipv4/ip_output.c |  2 +-
 net/l2tp/l2tp_core.h |  2 +-
 net/l2tp/l2tp_eth.c  |  4 ++--
 net/l2tp/l2tp_ppp.c  |  4 ++--
 net/sched/cls_flow.c |  6 +++---
 net/sctp/auth.c      |  2 +-
 net/xfrm/xfrm_algo.c |  2 +-
 10 files changed, 19 insertions(+), 20 deletions(-)

-- 
2.7.4

[toc] | [next] | [standalone]


#1480733 — Re: [PATCH 0/8] net: use IS_ENABLED() instead of checking for built-in or module

FromDavid Miller <davem@davemloft.net>
Date2016-09-11 06:20 +0200
SubjectRe: [PATCH 0/8] net: use IS_ENABLED() instead of checking for built-in or module
Message-ID<sg4pj-1hA-3@gated-at.bofh.it>
In reply to#1479967
From: Javier Martinez Canillas <javier@osg.samsung.com>
Date: Fri,  9 Sep 2016 08:43:12 -0400

> This trivial series replace the open coding to check for a Kconfig symbol
> being built-in or module, with IS_ENABLED() macro that does exactly that.
> 
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.

Series applied, thanks.

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web