Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1551732 > unrolled thread

Re: [PATCH] x86/apic: Fix two typos in comments

Started byIngo Molnar <mingo@kernel.org>
First post2017-01-05 09:20 +0100
Last post2017-01-05 11:00 +0100
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH] x86/apic: Fix two typos in comments Ingo Molnar <mingo@kernel.org> - 2017-01-05 09:20 +0100
    Re: [PATCH] x86/apic: Fix two typos in comments Dou Liyang <douly.fnst@cn.fujitsu.com> - 2017-01-05 11:00 +0100

#1551732 — Re: [PATCH] x86/apic: Fix two typos in comments

FromIngo Molnar <mingo@kernel.org>
Date2017-01-05 09:20 +0100
SubjectRe: [PATCH] x86/apic: Fix two typos in comments
Message-ID<sWbrb-bR-3@gated-at.bofh.it>
* Dou Liyang <douly.fnst@cn.fujitsu.com> wrote:

> s/inr_logical_cpuidi/nr_logical_cpuids/
> s/generic_processor_info()/__generic_processor_info()/
> 
> Signed-off-by: Dou Liyang <douly.fnst@cn.fujitsu.com>
> ---
>  arch/x86/kernel/apic/apic.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/x86/kernel/apic/apic.c b/arch/x86/kernel/apic/apic.c
> index 5b7e43e..c32a3ad 100644
> --- a/arch/x86/kernel/apic/apic.c
> +++ b/arch/x86/kernel/apic/apic.c
> @@ -2028,7 +2028,7 @@ void disconnect_bsp_APIC(int virt_wire_setup)
>  /*
>   * The number of allocated logical CPU IDs. Since logical CPU IDs are allocated
>   * contiguously, it equals to current allocated max logical CPU ID plus 1.
> - * All allocated CPU ID should be in [0, nr_logical_cpuidi), so the maximum of
> + * All allocated CPU ID should be in [0, nr_logical_cpuids), so the maximum of

There's another typo in that sentence as well, and the wording should be clarified 
as well while at it. Something like this would work for me:

> + * All allocated CPU IDs should be in the [0, nr_logical_cpuids) range,
> + * so the maximum of

Thanks,

	Ingo

[toc] | [next] | [standalone]


#1551835

FromDou Liyang <douly.fnst@cn.fujitsu.com>
Date2017-01-05 11:00 +0100
Message-ID<sWd03-1dl-5@gated-at.bofh.it>
In reply to#1551732
Hi, Ingo

At 01/05/2017 04:15 PM, Ingo Molnar wrote:
>
> * Dou Liyang <douly.fnst@cn.fujitsu.com> wrote:
>
>> s/inr_logical_cpuidi/nr_logical_cpuids/
>> s/generic_processor_info()/__generic_processor_info()/
>>
>> Signed-off-by: Dou Liyang <douly.fnst@cn.fujitsu.com>
>> ---
>>  arch/x86/kernel/apic/apic.c | 4 ++--
>>  1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/arch/x86/kernel/apic/apic.c b/arch/x86/kernel/apic/apic.c
>> index 5b7e43e..c32a3ad 100644
>> --- a/arch/x86/kernel/apic/apic.c
>> +++ b/arch/x86/kernel/apic/apic.c
>> @@ -2028,7 +2028,7 @@ void disconnect_bsp_APIC(int virt_wire_setup)
>>  /*
>>   * The number of allocated logical CPU IDs. Since logical CPU IDs are allocated
>>   * contiguously, it equals to current allocated max logical CPU ID plus 1.
>> - * All allocated CPU ID should be in [0, nr_logical_cpuidi), so the maximum of
>> + * All allocated CPU ID should be in [0, nr_logical_cpuids), so the maximum of
>
> There's another typo in that sentence as well, and the wording should be clarified
> as well while at it. Something like this would work for me:
>
>> + * All allocated CPU IDs should be in the [0, nr_logical_cpuids) range,
>> + * so the maximum of
>

Yes, It is. :)

Thanks,

	Dou

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web