Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1547424 > unrolled thread
| Started by | 岩松信洋 / IWAMATSU,NOBUHIRO <nobuhiro.iwamatsu.kw@hitachi.com> |
|---|---|
| First post | 2016-12-27 02:00 +0100 |
| Last post | 2017-01-04 07:30 +0100 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
RE: [PATCH v3 0/8] pstore: ramoops: support multiple pmsg instances 岩松信洋 / IWAMATSU,NOBUHIRO <nobuhiro.iwamatsu.kw@hitachi.com> - 2016-12-27 02:00 +0100
Re: [PATCH v3 0/8] pstore: ramoops: support multiple pmsg instances Kees Cook <keescook@chromium.org> - 2017-01-04 07:30 +0100
| From | 岩松信洋 / IWAMATSU,NOBUHIRO <nobuhiro.iwamatsu.kw@hitachi.com> |
|---|---|
| Date | 2016-12-27 02:00 +0100 |
| Subject | RE: [PATCH v3 0/8] pstore: ramoops: support multiple pmsg instances |
| Message-ID | <sSOhs-3wl-9@gated-at.bofh.it> |
Ping?_ > -----Original Message----- > From: linux-kernel-owner@vger.kernel.org > [mailto:linux-kernel-owner@vger.kernel.org] On Behalf Of 岩松信洋 / > IWAMATSU,NOBUHIRO > Sent: Monday, December 05, 2016 10:47 AM > To: Kees Cook > Cc: Anton Vorontsov; Colin Cross; Tony Luck; LKML; > cti.systems-productivity-manager.ts@hitachi.com > Subject: RE: [PATCH v3 0/8] pstore: ramoops: support multiple pmsg instances > > Hi, Kees. > > > -----Original Message----- > > From: keescook@google.com [mailto:keescook@google.com] On Behalf Of > > Kees Cook > > Sent: Saturday, November 12, 2016 7:24 AM > > To: 岩松信洋 / IWAMATSU,NOBUHIRO > > Cc: Anton Vorontsov; Colin Cross; Tony Luck; LKML; > > cti.systems-productivity-manager.ts@hitachi.com > > Subject: Re: [PATCH v3 0/8] pstore: ramoops: support multiple pmsg > > instances > > > > On Tue, Oct 18, 2016 at 12:13 AM, Nobuhiro Iwamatsu > > <nobuhiro.iwamatsu.kw@hitachi.com> wrote: > > > The following series implements multiple pmsg. This feature allows > > > userspace program to control individual content aging or priority. > > > > > > If a pstore backend module(e.g. ramoops) requires the multiple pmsg > > > instances when registering itself to pstore, multiple /dev/pmsg[ID] > > > are created. Writes to each /dev/pmsg[ID] are isolated each other. > > > After reboot, the contents are available in > > /sys/fs/pstore/pmsg-[backend]-[ID]. > > > > > > In addition, we add multiple pmsg support for ramoops. We can > > > specify multiple pmsg area size by its module parameter as follows. > > > > > > pmsg_size=0x1000,0x2000,... > > > > > > I did check the operation of this feature on CycloneV (socfpga) > > > Helio > > board. > > > > > > v3: > > > Rebase to v4.8. > > > Split patch. > > > merged device_create(). > > > Remove Blank lines. > > > Update documentiation of DT binding. > > > Update parsing function of ramoops_pmsg_size, add NULL termination. > > > Update module parameters for pmsg_size list. > > > > Thanks for this v3! Sorry for the delay, I should be able to review > > this shortly. > > Thank you. > I will wait for your review. > > > > > -Kees > > > > Best regards, > Nobuhiro > > > > > > > Hiraku Toyooka (2): > > > pstore: support multiple pmsg instances > > > selftests/pstore: add testcases for multiple pmsg instances > > > > > > Nobuhiro Iwamatsu (6): > > > pstore: Replace four kzalloc() calls by kcalloc() in > > ramoops_init_przs() > > > pstore: Change parameter of ramoops_free_przs() > > > ramoops: Add __ramoops_init_prz() as generic function > > > pstore: Rename 'przs' to 'dprzs' in struct ramoops_context > > > ramoops: Rename ramoops_init_prz() to ramoops_init_dprzs() > > > ramoops: support multiple pmsg instances > > > > > > .../bindings/reserved-memory/ramoops.txt | 6 +- > > > Documentation/ramoops.txt | 22 ++ > > > fs/pstore/pmsg.c | 23 +- > > > fs/pstore/ram.c | 344 > > ++++++++++++++++----- > > > include/linux/pstore.h | 1 + > > > include/linux/pstore_ram.h | 8 +- > > > tools/testing/selftests/pstore/common_tests | 21 +- > > > .../selftests/pstore/pstore_post_reboot_tests | 27 +- > > > tools/testing/selftests/pstore/pstore_tests | 14 +- > > > 9 files changed, 360 insertions(+), 106 deletions(-) > > > > > > -- > > > 2.9.3 > > > > > > > > > > > > > > -- > > Kees Cook > > Nexus Security
[toc] | [next] | [standalone]
| From | Kees Cook <keescook@chromium.org> |
|---|---|
| Date | 2017-01-04 07:30 +0100 |
| Message-ID | <sVNfb-OR-3@gated-at.bofh.it> |
| In reply to | #1547424 |
On Mon, Dec 26, 2016 at 4:48 PM, 岩松信洋 / IWAMATSU,NOBUHIRO <nobuhiro.iwamatsu.kw@hitachi.com> wrote: > Ping?_ > >> -----Original Message----- >> From: linux-kernel-owner@vger.kernel.org >> [mailto:linux-kernel-owner@vger.kernel.org] On Behalf Of 岩松信洋 / >> IWAMATSU,NOBUHIRO >> Sent: Monday, December 05, 2016 10:47 AM >> To: Kees Cook >> Cc: Anton Vorontsov; Colin Cross; Tony Luck; LKML; >> cti.systems-productivity-manager.ts@hitachi.com >> Subject: RE: [PATCH v3 0/8] pstore: ramoops: support multiple pmsg instances >> >> Hi, Kees. >> >> > -----Original Message----- >> > From: keescook@google.com [mailto:keescook@google.com] On Behalf Of >> > Kees Cook >> > Sent: Saturday, November 12, 2016 7:24 AM >> > To: 岩松信洋 / IWAMATSU,NOBUHIRO >> > Cc: Anton Vorontsov; Colin Cross; Tony Luck; LKML; >> > cti.systems-productivity-manager.ts@hitachi.com >> > Subject: Re: [PATCH v3 0/8] pstore: ramoops: support multiple pmsg >> > instances >> > >> > On Tue, Oct 18, 2016 at 12:13 AM, Nobuhiro Iwamatsu >> > <nobuhiro.iwamatsu.kw@hitachi.com> wrote: >> > > The following series implements multiple pmsg. This feature allows >> > > userspace program to control individual content aging or priority. >> > > >> > > If a pstore backend module(e.g. ramoops) requires the multiple pmsg >> > > instances when registering itself to pstore, multiple /dev/pmsg[ID] >> > > are created. Writes to each /dev/pmsg[ID] are isolated each other. >> > > After reboot, the contents are available in >> > /sys/fs/pstore/pmsg-[backend]-[ID]. >> > > >> > > In addition, we add multiple pmsg support for ramoops. We can >> > > specify multiple pmsg area size by its module parameter as follows. >> > > >> > > pmsg_size=0x1000,0x2000,... >> > > >> > > I did check the operation of this feature on CycloneV (socfpga) >> > > Helio >> > board. >> > > >> > > v3: >> > > Rebase to v4.8. >> > > Split patch. >> > > merged device_create(). >> > > Remove Blank lines. >> > > Update documentiation of DT binding. >> > > Update parsing function of ramoops_pmsg_size, add NULL termination. >> > > Update module parameters for pmsg_size list. >> > >> > Thanks for this v3! Sorry for the delay, I should be able to review >> > this shortly. >> >> Thank you. >> I will wait for your review. Now that the big changes have landed in Linus's tree, are you able to rebase your series on those? -Kees -- Kees Cook Nexus Security
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web