Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1521469 > unrolled thread

Re: [PATHCv10 1/2] usb: USB Type-C connector class

Started byGreg KH <gregkh@linuxfoundation.org>
First post2016-11-14 11:00 +0100
Last post2016-11-17 09:30 +0100
Articles 2 on this page of 22 — 5 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATHCv10 1/2] usb: USB Type-C connector class Greg KH <gregkh@linuxfoundation.org> - 2016-11-14 11:00 +0100
    Re: [PATHCv10 1/2] usb: USB Type-C connector class Heikki Krogerus <heikki.krogerus@linux.intel.com> - 2016-11-14 13:40 +0100
      Re: [PATHCv10 1/2] usb: USB Type-C connector class Greg KH <gregkh@linuxfoundation.org> - 2016-11-14 15:20 +0100
        Re: [PATHCv10 1/2] usb: USB Type-C connector class Heikki Krogerus <heikki.krogerus@linux.intel.com> - 2016-11-14 15:40 +0100
          Re: [PATHCv10 1/2] usb: USB Type-C connector class Greg KH <gregkh@linuxfoundation.org> - 2016-11-14 16:10 +0100
      Re: [PATHCv10 1/2] usb: USB Type-C connector class Guenter Roeck <linux@roeck-us.net> - 2016-11-14 15:40 +0100
        Re: [PATHCv10 1/2] usb: USB Type-C connector class Oliver Neukum <oneukum@suse.com> - 2016-11-16 10:00 +0100
      Re: [PATHCv10 1/2] usb: USB Type-C connector class Guenter Roeck <linux@roeck-us.net> - 2016-11-14 21:50 +0100
        Re: [PATHCv10 1/2] usb: USB Type-C connector class Greg KH <gregkh@linuxfoundation.org> - 2016-11-15 08:10 +0100
          Re: [PATHCv10 1/2] usb: USB Type-C connector class Guenter Roeck <linux@roeck-us.net> - 2016-11-15 10:30 +0100
            Re: [PATHCv10 1/2] usb: USB Type-C connector class Badhri Jagan Sridharan <badhri@google.com> - 2016-11-16 01:20 +0100
              Re: [PATHCv10 1/2] usb: USB Type-C connector class Heikki Krogerus <heikki.krogerus@linux.intel.com> - 2016-11-16 10:40 +0100
                Re: [PATHCv10 1/2] usb: USB Type-C connector class Greg KH <gregkh@linuxfoundation.org> - 2016-11-16 10:50 +0100
                  Re: [PATHCv10 1/2] usb: USB Type-C connector class Heikki Krogerus <heikki.krogerus@linux.intel.com> - 2016-11-16 12:20 +0100
                    Re: [PATHCv10 1/2] usb: USB Type-C connector class Oliver Neukum <oneukum@suse.com> - 2016-11-16 12:40 +0100
                      Re: [PATHCv10 1/2] usb: USB Type-C connector class Badhri Jagan Sridharan <badhri@google.com> - 2016-11-16 15:40 +0100
                        Re: [PATHCv10 1/2] usb: USB Type-C connector class Heikki Krogerus <heikki.krogerus@linux.intel.com> - 2016-11-16 15:50 +0100
                Re: [PATHCv10 1/2] usb: USB Type-C connector class Oliver Neukum <oneukum@suse.com> - 2016-11-16 10:50 +0100
    Re: [PATHCv10 1/2] usb: USB Type-C connector class Badhri Jagan Sridharan <badhri@google.com> - 2016-11-16 16:30 +0100
    Re: [PATHCv10 1/2] usb: USB Type-C connector class Heikki Krogerus <heikki.krogerus@linux.intel.com> - 2016-11-16 16:30 +0100
      Re: [PATHCv10 1/2] usb: USB Type-C connector class Greg KH <gregkh@linuxfoundation.org> - 2016-11-16 16:40 +0100
        Re: [PATHCv10 1/2] usb: USB Type-C connector class Heikki Krogerus <heikki.krogerus@linux.intel.com> - 2016-11-17 09:30 +0100

Page 2 of 2 — ← Prev page 1 [2]


#1523603

FromGreg KH <gregkh@linuxfoundation.org>
Date2016-11-16 16:40 +0100
Message-ID<sEatz-4HA-5@gated-at.bofh.it>
In reply to#1523597
On Wed, Nov 16, 2016 at 05:20:24PM +0200, Heikki Krogerus wrote:
> Hi Greg,
> 
> On Mon, Nov 14, 2016 at 10:51:48AM +0100, Greg KH wrote:
> > > +static int sysfs_strmatch(const char * const *array, size_t n, const char *str)
> > > +{
> > > +	const char *item;
> > > +	int index;
> > > +
> > > +	for (index = 0; index < n; index++) {
> > > +		item = array[index];
> > > +		if (!item)
> > > +			break;
> > > +		if (sysfs_streq(item, str))
> > > +			return index;
> > > +	}
> > > +
> > > +	return -EINVAL;
> > > +}
> > 
> > should we make this a core sysfs function?
> 
> Last question before I send v11. Is the following (the helper) OK?
> 
> 
> diff --git a/include/linux/string.h b/include/linux/string.h
> index 26b6f6a..5606810 100644
> --- a/include/linux/string.h
> +++ b/include/linux/string.h
> @@ -135,6 +135,16 @@ static inline int strtobool(const char *s, bool *res)
>  }
>  
>  int match_string(const char * const *array, size_t n, const char *string);
> +int __sysfs_strmatch(const char * const *array, size_t n, const char *string);
> +
> +/**
> + * sysfs_strmatch - matches given string in an array
> + * @a: array of strings
> + * @s: string to match with
> + *
> + * Helper for __sysfs_strmatch(). Calculates the size of @a automatically.
> + */
> +#define sysfs_strmatch(a, s) __sysfs_strmatch(a, ARRAY_SIZE(a), s)

People will bikeshed the name.  Why not just use sysfs_match_string() as
this does the same as match_string, but calls sysfs_string instead of
strcmp().

thanks,

greg k-h

[toc] | [prev] | [next] | [standalone]


#1524161

FromHeikki Krogerus <heikki.krogerus@linux.intel.com>
Date2016-11-17 09:30 +0100
Message-ID<sEqf0-6CB-11@gated-at.bofh.it>
In reply to#1523603
On Wed, Nov 16, 2016 at 04:31:07PM +0100, Greg KH wrote:
> On Wed, Nov 16, 2016 at 05:20:24PM +0200, Heikki Krogerus wrote:
> > Hi Greg,
> > 
> > On Mon, Nov 14, 2016 at 10:51:48AM +0100, Greg KH wrote:
> > > > +static int sysfs_strmatch(const char * const *array, size_t n, const char *str)
> > > > +{
> > > > +	const char *item;
> > > > +	int index;
> > > > +
> > > > +	for (index = 0; index < n; index++) {
> > > > +		item = array[index];
> > > > +		if (!item)
> > > > +			break;
> > > > +		if (sysfs_streq(item, str))
> > > > +			return index;
> > > > +	}
> > > > +
> > > > +	return -EINVAL;
> > > > +}
> > > 
> > > should we make this a core sysfs function?
> > 
> > Last question before I send v11. Is the following (the helper) OK?
> > 
> > 
> > diff --git a/include/linux/string.h b/include/linux/string.h
> > index 26b6f6a..5606810 100644
> > --- a/include/linux/string.h
> > +++ b/include/linux/string.h
> > @@ -135,6 +135,16 @@ static inline int strtobool(const char *s, bool *res)
> >  }
> >  
> >  int match_string(const char * const *array, size_t n, const char *string);
> > +int __sysfs_strmatch(const char * const *array, size_t n, const char *string);
> > +
> > +/**
> > + * sysfs_strmatch - matches given string in an array
> > + * @a: array of strings
> > + * @s: string to match with
> > + *
> > + * Helper for __sysfs_strmatch(). Calculates the size of @a automatically.
> > + */
> > +#define sysfs_strmatch(a, s) __sysfs_strmatch(a, ARRAY_SIZE(a), s)
> 
> People will bikeshed the name.  Why not just use sysfs_match_string() as
> this does the same as match_string, but calls sysfs_string instead of
> strcmp().

Makes sense. I'll change the name.

Thanks,

-- 
heikki

[toc] | [prev] | [standalone]


Page 2 of 2 — ← Prev page 1 [2]

Back to top | Article view | linux.kernel


csiph-web