Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1516076 > unrolled thread

[PATCHv7 09/11] mfd: 88pm860x: Move over to new I2C device .probe() call

Started byKieran Bingham <kieran@ksquared.org.uk>
First post2016-11-07 13:50 +0100
Last post2016-11-07 20:20 +0100
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCHv7 09/11] mfd: 88pm860x: Move over to new I2C device .probe() call Kieran Bingham <kieran@ksquared.org.uk> - 2016-11-07 13:50 +0100
    Re: [PATCHv7 09/11] mfd: 88pm860x: Move over to new I2C device  .probe() call Javier Martinez Canillas <javier@osg.samsung.com> - 2016-11-07 20:20 +0100

#1516076 — [PATCHv7 09/11] mfd: 88pm860x: Move over to new I2C device .probe() call

FromKieran Bingham <kieran@ksquared.org.uk>
Date2016-11-07 13:50 +0100
Subject[PATCHv7 09/11] mfd: 88pm860x: Move over to new I2C device .probe() call
Message-ID<sARx7-3aL-1@gated-at.bofh.it>
From: Lee Jones <lee.jones@linaro.org>

As part of an effort to rid the mostly unused second parameter for I2C
related .probe() functions and to conform to other existing frameworks
we're moving over to a temporary replacement .probe() call-back.

Acked-by: Grant Likely <grant.likely@linaro.org>
Signed-off-by: Lee Jones <lee.jones@linaro.org>
Signed-off-by: Kieran Bingham <kieran@bingham.xyz>

---
Changes since v4
 - Rename .probe2 to probe_new

 drivers/mfd/88pm860x-core.c | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/drivers/mfd/88pm860x-core.c b/drivers/mfd/88pm860x-core.c
index 25e1aafae60c..227b99018657 100644
--- a/drivers/mfd/88pm860x-core.c
+++ b/drivers/mfd/88pm860x-core.c
@@ -1132,8 +1132,7 @@ static int pm860x_dt_init(struct device_node *np,
 	return 0;
 }
 
-static int pm860x_probe(struct i2c_client *client,
-				  const struct i2c_device_id *id)
+static int pm860x_probe(struct i2c_client *client)
 {
 	struct pm860x_platform_data *pdata = dev_get_platdata(&client->dev);
 	struct device_node *node = client->dev.of_node;
@@ -1259,7 +1258,7 @@ static struct i2c_driver pm860x_driver = {
 		.pm     = &pm860x_pm_ops,
 		.of_match_table	= pm860x_dt_ids,
 	},
-	.probe		= pm860x_probe,
+	.probe_new	= pm860x_probe,
 	.remove		= pm860x_remove,
 	.id_table	= pm860x_id_table,
 };
-- 
2.7.4

[toc] | [next] | [standalone]


#1516522 — Re: [PATCHv7 09/11] mfd: 88pm860x: Move over to new I2C device .probe() call

FromJavier Martinez Canillas <javier@osg.samsung.com>
Date2016-11-07 20:20 +0100
SubjectRe: [PATCHv7 09/11] mfd: 88pm860x: Move over to new I2C device .probe() call
Message-ID<sAXCx-7rh-23@gated-at.bofh.it>
In reply to#1516076
Hello Kieran,

On 11/07/2016 09:47 AM, Kieran Bingham wrote:
> From: Lee Jones <lee.jones@linaro.org>
> 
> As part of an effort to rid the mostly unused second parameter for I2C
> related .probe() functions and to conform to other existing frameworks
> we're moving over to a temporary replacement .probe() call-back.
> 
> Acked-by: Grant Likely <grant.likely@linaro.org>
> Signed-off-by: Lee Jones <lee.jones@linaro.org>
> Signed-off-by: Kieran Bingham <kieran@bingham.xyz>
> 

Reviewed-by: Javier Martinez Canillas <javier@osg.samsung.com>

Best regards,
-- 
Javier Martinez Canillas
Open Source Group
Samsung Research America

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web