Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1516260 > unrolled thread
| Started by | Maxime Ripard <maxime.ripard@free-electrons.com> |
|---|---|
| First post | 2016-11-07 16:50 +0100 |
| Last post | 2016-11-11 17:50 +0100 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH v2 1/2] regulator: Add coupled regulator Maxime Ripard <maxime.ripard@free-electrons.com> - 2016-11-07 16:50 +0100
Re: [PATCH v2 1/2] regulator: Add coupled regulator Mark Brown <broonie@kernel.org> - 2016-11-11 17:50 +0100
| From | Maxime Ripard <maxime.ripard@free-electrons.com> |
|---|---|
| Date | 2016-11-07 16:50 +0100 |
| Subject | Re: [PATCH v2 1/2] regulator: Add coupled regulator |
| Message-ID | <sAUlk-4ZD-13@gated-at.bofh.it> |
[Multipart message — attachments visible in raw view] — view raw
Hi Mark, On Fri, Feb 05, 2016 at 03:32:58PM +0000, Mark Brown wrote: > On Fri, Feb 05, 2016 at 03:33:28PM +0100, Maxime Ripard wrote: > > On Thu, Jan 21, 2016 at 04:28:02PM +0000, Mark Brown wrote: > > > On Thu, Jan 21, 2016 at 04:46:49PM +0100, Maxime Ripard wrote: > > > > > Anyway, I'm fine with both approaches, just let me know what you > > > > prefer. > > > > Without seeing an implementation of the lists it's hard to say. > > > Just to make sure we're on the same page: you want to keep the > > regulator, but instead of giving the parent through vinX-supplies > > properties, you want to have a single *-supply property, with a list > > of regulators, right? > > Either that or an explicit regulator describing the merge. Rob wants > the list I think but I really don't care. So, I'm reviving this old thread after speaking to you about it at ELCE and trying to code something up, and getting lost.. To put a bit of context, I'm still trying to tackle the issue of devices that have two regulators powering them on the same pin for example when each regulator cannot provide enough current alone to power the device (all the setups like this one I've seen so far were for WiFi chips, but it might be different). I guess we already agreed on the fact that the DT binding should just be to allow a *-supply property to take multiple regulators, and mark them as "coupled" (or whatever name we see fit) in such a case. Since regulator_get returns a struct regulator pointer, it felt logical to try to add the list of parent regulators to it, especially as this structure is per-consumer, and different consumers might have different combinations of regulators. However, this structure embeds a pointer to a struct regulator_dev, which seems to model the regulator itself, but will also contain pointer to the struct regulator, probably to model its parent? I guess my first question would be do we care about nesting? or having a regulator with multiple parents? It also contains the constraints on each regulator, which might or might not be different for each of the coupled regulators, but I'm guessing the couple might have contraints of its own too I guess. Is it something that might happen? Should we care about it? And finally, my real question is, do we want to aggregate them in struct regulator, at the consumer level, which might make the more sense, or do we want to create an intermediate regulator internally? What is your take on this? Thanks! Maxime -- Maxime Ripard, Free Electrons Embedded Linux and Kernel engineering http://free-electrons.com
[toc] | [next] | [standalone]
| From | Mark Brown <broonie@kernel.org> |
|---|---|
| Date | 2016-11-11 17:50 +0100 |
| Message-ID | <sCnbz-6LA-17@gated-at.bofh.it> |
| In reply to | #1516260 |
[Multipart message — attachments visible in raw view] — view raw
On Mon, Nov 07, 2016 at 04:47:38PM +0100, Maxime Ripard wrote: > Since regulator_get returns a struct regulator pointer, it felt > logical to try to add the list of parent regulators to it, especially > as this structure is per-consumer, and different consumers might have > different combinations of regulators. > However, this structure embeds a pointer to a struct regulator_dev, > which seems to model the regulator itself, but will also contain > pointer to the struct regulator, probably to model its parent? I guess It'd be a lot easier to follow this if you named the fields... The rdev in the struct regulator is indeed the physical device. The struct regulator called supply in struct regulator_dev is indeed the parent regulator. > my first question would be do we care about nesting? or having a > regulator with multiple parents? Well, it seems that your use case here is multiple parents so I guess we do care about it. :) > It also contains the constraints on each regulator, which might or > might not be different for each of the coupled regulators, but I'm > guessing the couple might have contraints of its own too I guess. Is > it something that might happen? Should we care about it? I can't see how one could physically have constraints that didn't apply to both parents. > And finally, my real question is, do we want to aggregate them in > struct regulator, at the consumer level, which might make the more > sense, or do we want to create an intermediate regulator internally? > What is your take on this? My initial thought without having tried to implement this is that doing things in an intermediate regulator might do a better job of encapsulating things it if it works out but I've got a feeling that it's not going to work out well and that therefore doing it in the consumer with multiple rdevs will be better. But really either approach is fine if it doesn't look horrible.
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web