Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1468573 > unrolled thread

[PATCH 7/7] vfs: add note about i_op->rename changes to porting

Started byMiklos Szeredi <mszeredi@redhat.com>
First post2016-08-23 16:10 +0200
Last post2016-08-23 16:10 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH 7/7] vfs: add note about i_op->rename changes to porting Miklos Szeredi <mszeredi@redhat.com> - 2016-08-23 16:10 +0200

#1468573 — [PATCH 7/7] vfs: add note about i_op->rename changes to porting

FromMiklos Szeredi <mszeredi@redhat.com>
Date2016-08-23 16:10 +0200
Subject[PATCH 7/7] vfs: add note about i_op->rename changes to porting
Message-ID<s9kyS-52F-31@gated-at.bofh.it>
Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
---
 Documentation/filesystems/porting | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/Documentation/filesystems/porting b/Documentation/filesystems/porting
index b1bd05ea66b2..1ab28d9b612a 100644
--- a/Documentation/filesystems/porting
+++ b/Documentation/filesystems/porting
@@ -592,3 +592,7 @@ in your dentry operations instead.
 	work just as well; if it's something more complicated, use dentry->d_parent.
 	Just be careful not to assume that fetching it more than once will yield
 	the same value - in RCU mode it could change under you.
+--
+[mandatory]
+	->rename() has an added flags argument.  Any flags not handled by the
+        filesystem should result in EINVAL being returned.
-- 
2.5.5

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web