Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1458997 > unrolled thread
| Started by | Taeung Song <treeze.taeung@gmail.com> |
|---|---|
| First post | 2016-08-09 19:10 +0200 |
| Last post | 2016-08-09 19:10 +0200 |
| Articles | 2 — 1 participant |
Back to article view | Back to linux.kernel
[PATCH v7 0/7] perf config: Introduce default config key-value pairs arrays Taeung Song <treeze.taeung@gmail.com> - 2016-08-09 19:10 +0200
[PATCH v7 6/7] perf config: Add default section and item arrays for 'annotate' config Taeung Song <treeze.taeung@gmail.com> - 2016-08-09 19:10 +0200
| From | Taeung Song <treeze.taeung@gmail.com> |
|---|---|
| Date | 2016-08-09 19:10 +0200 |
| Subject | [PATCH v7 0/7] perf config: Introduce default config key-value pairs arrays |
| Message-ID | <s4iHn-20B-3@gated-at.bofh.it> |
Hello, :)
When initializing default perf config values,
we currently use values of actual type(int, bool, char *, etc.).
But I suggest using default config key-value pairs arrays.
For example,
If there isn't a user config value for 'annotate.use_offset'
config variable at ~/.perfconfig,
default value for it is 'true' bool type value in perf like below.
At ui/browsers/annoate.c
static struct annotate_browser_opt {
bool hide_src_code,
use_offset,
jump_arrows,
show_linenr,
show_nr_jumps,
show_total_period;
} annotate_browser__opts = {
.use_offset = true,
.jump_arrows = true,
};
But if we use new config arrays that have all default config key-value pairs,
we could initialize default config values with them.
If we do, we can manage default perf config values at one spot (like util/config.c)
and It can be easy and simple to modify existing default config values or
add default values for new config item.
For example,
If we use new default config arrays and there isn't user config value for 'annoate.use_offset'
default value for it will be set as annotate_config_items[CONFIG_ANNOATE_USE_OFFSET].value.b
instead of actual boolean type value 'true'.
IMHO, I think it would needed to use new default config arrays
to manage default perf config values more effectively.
And this pathset contains patchs for only 'colors' and 'annoate' section
because waiting for other opinions.
If you review this patchset, I'd appreciate it :-)
Thanks,
Taeung
v7:
- fix wrong handling a exception from strdup (Arnaldo)
- rebased on current acme/perf/core
v6:
- rename 'fore_back_colors' to simple 'colors' of ui_browser_colorset (Namhyung)
- remove unnecssary whitespace changes of PATCH 4/7, 5/7 (Namhyung)
- make more general macro instead of making accessor macro for each config section (Namhyung)
- rebased on current acme/perf/core
v5:
- rebased on current acme/perf/core
v4:
- rename 'fb_ground' to 'fore_back_colors' (Namhyung)
- add struct default_config_section
- split first patch[PATCH 1/7] as two
- remove perf_default_config_init() at perf.c
- rebased on current acme/perf/core
v3:
- remove default config arrays for the rest sections except 'colors' and 'annotate'
- use combined {fore, back}ground colors instead of each two color
- introduce perf_default_config_init() that call all default_*_config_init()
for each config section
v2:
- rename 'ui_browser__config_gcolors' to 'ui_browser__config_colors' (Arnaldo)
- change 'ground colors' to '{back, fore}ground colors' (Arnaldo)
- use strtok + ltrim instead of strchr and while (isspace(*++bg)); (Arnaldo)
Taeung Song (7):
perf config: Introduce default_config_section and default_config_item
for default config key-value pairs
perf config: Add macros assigning key-value pairs to
default_config_item
perf config: Add default section and item arrays for 'colors' config
perf config: Use combined {fore,back}ground colors value instead of
each two color
perf config: Initialize ui_browser__colorsets with default config
items
perf config: Add default section and item arrays for 'annotate' config
perf config: Initialize annotate_browser__opts with default config
items
tools/perf/ui/browser.c | 64 +++++++++++++++++--------------
tools/perf/ui/browsers/annotate.c | 16 ++++++--
tools/perf/util/config.c | 26 +++++++++++++
tools/perf/util/config.h | 80 +++++++++++++++++++++++++++++++++++++++
4 files changed, 154 insertions(+), 32 deletions(-)
--
2.5.0
[toc] | [next] | [standalone]
| From | Taeung Song <treeze.taeung@gmail.com> |
|---|---|
| Date | 2016-08-09 19:10 +0200 |
| Subject | [PATCH v7 6/7] perf config: Add default section and item arrays for 'annotate' config |
| Message-ID | <s4iHo-20B-35@gated-at.bofh.it> |
| In reply to | #1458997 |
Actual values for default configs of 'annotate' section is like below.
(at ui/browsers/annoate.c)
static struct annotate_browser_opt {
bool hide_src_code,
use_offset,
jump_arrows,
show_linenr,
show_nr_jumps,
show_total_period;
} annotate_browser__opts = {
.use_offset = true,
.jump_arrows = true,
};
But I suggest using default config arrays for 'annotate' section that
contain all default config key-value pairs for it.
In near future, this arrays will be used on ui/browsers/annoate.c
because of setting default values of actual variables for 'annotate' config.
Cc: Namhyung Kim <namhyung@kernel.org>
Cc: Jiri Olsa <jolsa@redhat.com>
Cc: Masami Hiramatsu <mhiramat@kernel.org>
Cc: Wang Nan <wangnan0@huawei.com>
Signed-off-by: Taeung Song <treeze.taeung@gmail.com>
---
tools/perf/util/config.c | 11 +++++++++++
tools/perf/util/config.h | 11 +++++++++++
2 files changed, 22 insertions(+)
diff --git a/tools/perf/util/config.c b/tools/perf/util/config.c
index a0c0170..d8d5415 100644
--- a/tools/perf/util/config.c
+++ b/tools/perf/util/config.c
@@ -41,8 +41,19 @@ const struct default_config_item colors_config_items[] = {
CONF_END()
};
+const struct default_config_item annotate_config_items[] = {
+ CONF_BOOL_VAR("hide_src_code", false),
+ CONF_BOOL_VAR("use_offset", true),
+ CONF_BOOL_VAR("jump_arrows", true),
+ CONF_BOOL_VAR("show_nr_jumps", false),
+ CONF_BOOL_VAR("show_linenr", false),
+ CONF_BOOL_VAR("show_total_period", false),
+ CONF_END()
+};
+
const struct default_config_section default_sections[] = {
{ .name = "colors", .items = colors_config_items },
+ { .name = "annotate", .items = annotate_config_items },
};
static int get_next_char(void)
diff --git a/tools/perf/util/config.h b/tools/perf/util/config.h
index b9190fe..2fcfd51 100644
--- a/tools/perf/util/config.h
+++ b/tools/perf/util/config.h
@@ -75,6 +75,7 @@ enum perf_config_type {
enum config_section_idx {
CONFIG_COLORS,
+ CONFIG_ANNOTATE,
};
enum colors_config_items_idx {
@@ -87,6 +88,15 @@ enum colors_config_items_idx {
CONFIG_COLORS_ROOT,
};
+enum annotate_config_items_idx {
+ CONFIG_ANNOTATE_HIDE_SRC_CODE,
+ CONFIG_ANNOTATE_USE_OFFSET,
+ CONFIG_ANNOTATE_JUMP_ARROWS,
+ CONFIG_ANNOTATE_SHOW_NR_JUMPS,
+ CONFIG_ANNOTATE_SHOW_LINENR,
+ CONFIG_ANNOTATE_SHOW_TOTAL_PERIOD,
+};
+
struct default_config_item {
const char *name;
union {
@@ -128,5 +138,6 @@ struct default_config_section {
extern const struct default_config_section default_sections[];
extern const struct default_config_item colors_config_items[];
+extern const struct default_config_item annotate_config_items[];
#endif /* __PERF_CONFIG_H */
--
2.5.0
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web