Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1454552 > unrolled thread
| Started by | Baole Ni <baolex.ni@intel.com> |
|---|---|
| First post | 2016-08-02 16:30 +0200 |
| Last post | 2016-08-02 16:30 +0200 |
| Articles | 1 — 1 participant |
Back to article view | Back to linux.kernel
[PATCH 1085/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 16:30 +0200
| From | Baole Ni <baolex.ni@intel.com> |
|---|---|
| Date | 2016-08-02 16:30 +0200 |
| Subject | [PATCH 1085/1285] Replace numeric parameter like 0444 with macro |
| Message-ID | <s1IRJ-5C1-35@gated-at.bofh.it> |
I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com> Signed-off-by: Baole Ni <baolex.ni@intel.com> --- net/9p/trans_virtio.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/net/9p/trans_virtio.c b/net/9p/trans_virtio.c index 4acb1d5..f5ae921 100644 --- a/net/9p/trans_virtio.c +++ b/net/9p/trans_virtio.c @@ -527,7 +527,7 @@ static ssize_t p9_mount_tag_show(struct device *dev, return chan->tag_len + 1; } -static DEVICE_ATTR(mount_tag, 0444, p9_mount_tag_show, NULL); +static DEVICE_ATTR(mount_tag, S_IRUSR | S_IRGRP | S_IROTH, p9_mount_tag_show, NULL); /** * p9_virtio_probe - probe for existence of 9P virtio channels -- 2.9.2
Back to top | Article view | linux.kernel
csiph-web