Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1454510 > unrolled thread

[PATCH 1105/1285] Replace numeric parameter like 0444 with macro

Started byBaole Ni <baolex.ni@intel.com>
First post2016-08-02 16:20 +0200
Last post2016-08-02 16:20 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel


Contents

  [PATCH 1105/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 16:20 +0200

#1454510 — [PATCH 1105/1285] Replace numeric parameter like 0444 with macro

FromBaole Ni <baolex.ni@intel.com>
Date2016-08-02 16:20 +0200
Subject[PATCH 1105/1285] Replace numeric parameter like 0444 with macro
Message-ID<s1II2-5y4-13@gated-at.bofh.it>
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 net/ipv4/tcp_htcp.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/net/ipv4/tcp_htcp.c b/net/ipv4/tcp_htcp.c
index 4a4d8e7..2596861 100644
--- a/net/ipv4/tcp_htcp.c
+++ b/net/ipv4/tcp_htcp.c
@@ -15,11 +15,11 @@
 #define BETA_MAX	102	/* 0.8 with shift << 7 */
 
 static int use_rtt_scaling __read_mostly = 1;
-module_param(use_rtt_scaling, int, 0644);
+module_param(use_rtt_scaling, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(use_rtt_scaling, "turn on/off RTT scaling");
 
 static int use_bandwidth_switch __read_mostly = 1;
-module_param(use_bandwidth_switch, int, 0644);
+module_param(use_bandwidth_switch, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(use_bandwidth_switch, "turn on/off bandwidth switcher");
 
 struct htcp {
-- 
2.9.2

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web