Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1454570 > unrolled thread
| Started by | Baole Ni <baolex.ni@intel.com> |
|---|---|
| First post | 2016-08-02 16:40 +0200 |
| Last post | 2016-08-02 16:40 +0200 |
| Articles | 1 — 1 participant |
Back to article view | Back to linux.kernel
[PATCH 1076/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 16:40 +0200
| From | Baole Ni <baolex.ni@intel.com> |
|---|---|
| Date | 2016-08-02 16:40 +0200 |
| Subject | [PATCH 1076/1285] Replace numeric parameter like 0444 with macro |
| Message-ID | <s1HVF-50V-75@gated-at.bofh.it> |
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
kernel/time/sched_clock.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/kernel/time/sched_clock.c b/kernel/time/sched_clock.c
index a26036d..9d072c3 100644
--- a/kernel/time/sched_clock.c
+++ b/kernel/time/sched_clock.c
@@ -71,7 +71,7 @@ struct clock_data {
static struct hrtimer sched_clock_timer;
static int irqtime = -1;
-core_param(irqtime, irqtime, int, 0400);
+core_param(irqtime, irqtime, int, S_IRUSR);
static u64 notrace jiffy_sched_clock_read(void)
{
--
2.9.2
Back to top | Article view | linux.kernel
csiph-web