Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1453849 > unrolled thread
| Started by | Baole Ni <baolex.ni@intel.com> |
|---|---|
| First post | 2016-08-02 13:40 +0200 |
| Last post | 2016-08-02 13:40 +0200 |
| Articles | 1 — 1 participant |
Back to article view | Back to linux.kernel
[PATCH 0164/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 13:40 +0200
| From | Baole Ni <baolex.ni@intel.com> |
|---|---|
| Date | 2016-08-02 13:40 +0200 |
| Subject | [PATCH 0164/1285] Replace numeric parameter like 0444 with macro |
| Message-ID | <s1Gdd-3Oh-49@gated-at.bofh.it> |
I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com> Signed-off-by: Baole Ni <baolex.ni@intel.com> --- drivers/eisa/virtual_root.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/eisa/virtual_root.c b/drivers/eisa/virtual_root.c index 535e4f9..2242564 100644 --- a/drivers/eisa/virtual_root.c +++ b/drivers/eisa/virtual_root.c @@ -69,6 +69,6 @@ static int __init virtual_eisa_root_init (void) return 0; } -module_param (force_probe, int, 0444); +module_param (force_probe, int, S_IRUSR | S_IRGRP | S_IROTH); device_initcall (virtual_eisa_root_init); -- 2.9.2
Back to top | Article view | linux.kernel
csiph-web