Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1453816 > unrolled thread
| Started by | Baole Ni <baolex.ni@intel.com> |
|---|---|
| First post | 2016-08-02 13:30 +0200 |
| Last post | 2016-08-03 04:40 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH 0133/1285] Replace numeric parameter like 0444 with macro Baole Ni <baolex.ni@intel.com> - 2016-08-02 13:30 +0200
Re: [PATCH 0133/1285] Replace numeric parameter like 0444 with macro Vinod Koul <vinod.koul@intel.com> - 2016-08-03 04:40 +0200
| From | Baole Ni <baolex.ni@intel.com> |
|---|---|
| Date | 2016-08-02 13:30 +0200 |
| Subject | [PATCH 0133/1285] Replace numeric parameter like 0444 with macro |
| Message-ID | <s1G3x-3Jf-69@gated-at.bofh.it> |
I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com> Signed-off-by: Baole Ni <baolex.ni@intel.com> --- drivers/dma/at_xdmac.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/dma/at_xdmac.c b/drivers/dma/at_xdmac.c index 75bd662..3c26e23 100644 --- a/drivers/dma/at_xdmac.c +++ b/drivers/dma/at_xdmac.c @@ -314,7 +314,7 @@ static inline u8 at_xdmac_get_dwidth(u32 cfg) }; static unsigned int init_nr_desc_per_channel = 64; -module_param(init_nr_desc_per_channel, uint, 0644); +module_param(init_nr_desc_per_channel, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(init_nr_desc_per_channel, "initial descriptors per channel (default: 64)"); -- 2.9.2
[toc] | [next] | [standalone]
| From | Vinod Koul <vinod.koul@intel.com> |
|---|---|
| Date | 2016-08-03 04:40 +0200 |
| Message-ID | <s1Ug9-4Hs-9@gated-at.bofh.it> |
| In reply to | #1453816 |
On Tue, Aug 02, 2016 at 06:43:10PM +0800, Baole Ni wrote: > I find that the developers often just specified the numeric value > when calling a macro which is defined with a parameter for access permission. > As we know, these numeric value for access permission have had the corresponding macro, > and that using macro can improve the robustness and readability of the code, > thus, I suggest replacing the numeric parameter with the macro. and all the patches I recived have same title. Please, use subsystem specfic tags and driver names. Also patch title is not telling me much. Perhpas mentioning that you are fixing module params hardcoding would be better! > > Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com> > Signed-off-by: Baole Ni <baolex.ni@intel.com> > --- > drivers/dma/at_xdmac.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/dma/at_xdmac.c b/drivers/dma/at_xdmac.c > index 75bd662..3c26e23 100644 > --- a/drivers/dma/at_xdmac.c > +++ b/drivers/dma/at_xdmac.c > @@ -314,7 +314,7 @@ static inline u8 at_xdmac_get_dwidth(u32 cfg) > }; > > static unsigned int init_nr_desc_per_channel = 64; > -module_param(init_nr_desc_per_channel, uint, 0644); > +module_param(init_nr_desc_per_channel, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); > MODULE_PARM_DESC(init_nr_desc_per_channel, > "initial descriptors per channel (default: 64)"); > > -- > 2.9.2 > -- ~Vinod
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web