Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1394433 > unrolled thread
| Started by | Kieran Bingham <kieran@ksquared.org.uk> |
|---|---|
| First post | 2016-05-04 17:20 +0200 |
| Last post | 2016-05-10 07:00 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
[PATCHv5 2/8] i2c: Add the ability to match device to compatible string without an of_node Kieran Bingham <kieran@ksquared.org.uk> - 2016-05-04 17:20 +0200
Re: [PATCHv5 2/8] i2c: Add the ability to match device to compatible string without an of_node Javier Martinez Canillas <javier@osg.samsung.com> - 2016-05-10 07:00 +0200
| From | Kieran Bingham <kieran@ksquared.org.uk> |
|---|---|
| Date | 2016-05-04 17:20 +0200 |
| Subject | [PATCHv5 2/8] i2c: Add the ability to match device to compatible string without an of_node |
| Message-ID | <rv6KJ-6s5-9@gated-at.bofh.it> |
From: Lee Jones <lee.jones@linaro.org>
A great deal of I2C devices are currently matched via DT node name, and
as such the compatible naming convention of '<vendor>,<device>' has gone
somewhat awry - some nodes don't supply one, some supply an arbitrary
string and others the correct device name with an arbitrary vendor prefix.
In an effort to correct this problem we have to supply a mechanism to
match a device by compatible string AND by simple device name. This
function strips off the '<vendor>,' part of a supplied compatible string
and attempts to match without it.
The plan is to remove this function once all of the compatible strings
for each device have been brought into line.
Acked-by: Grant Likely <grant.likely@linaro.org>
Signed-off-by: Lee Jones <lee.jones@linaro.org>
[Kieran: strnicmp to strncasecmp]
Signed-off-by: Kieran Bingham <kieran@bingham.xyz>
Tested-by: Kieran Bingham <kieran@bingham.xyz>
---
drivers/i2c/i2c-core.c | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
diff --git a/drivers/i2c/i2c-core.c b/drivers/i2c/i2c-core.c
index e980c8257676..f75e78f6f9c1 100644
--- a/drivers/i2c/i2c-core.c
+++ b/drivers/i2c/i2c-core.c
@@ -1494,6 +1494,27 @@ struct i2c_adapter *of_get_i2c_adapter_by_node(struct device_node *node)
return adapter;
}
EXPORT_SYMBOL(of_get_i2c_adapter_by_node);
+
+static const struct of_device_id*
+i2c_of_match_device_strip_vendor(const struct of_device_id *matches,
+ struct i2c_client *client)
+{
+ const char *name;
+
+ for (; matches->compatible[0]; matches++) {
+ name = strchr(matches->compatible, ',');
+ if (!name)
+ name = matches->compatible;
+ else
+ name++;
+
+ if (!strncasecmp(client->name, name, strlen(client->name)))
+ return matches;
+ }
+
+ return NULL;
+}
+
#else
static void of_i2c_register_devices(struct i2c_adapter *adap) { }
#endif /* CONFIG_OF */
--
2.5.0
[toc] | [next] | [standalone]
| From | Javier Martinez Canillas <javier@osg.samsung.com> |
|---|---|
| Date | 2016-05-10 07:00 +0200 |
| Subject | Re: [PATCHv5 2/8] i2c: Add the ability to match device to compatible string without an of_node |
| Message-ID | <rx7W1-3u2-1@gated-at.bofh.it> |
| In reply to | #1394433 |
On 05/04/2016 11:14 AM, Kieran Bingham wrote: > From: Lee Jones <lee.jones@linaro.org> > > A great deal of I2C devices are currently matched via DT node name, and > as such the compatible naming convention of '<vendor>,<device>' has gone > somewhat awry - some nodes don't supply one, some supply an arbitrary > string and others the correct device name with an arbitrary vendor prefix. > > In an effort to correct this problem we have to supply a mechanism to > match a device by compatible string AND by simple device name. This > function strips off the '<vendor>,' part of a supplied compatible string > and attempts to match without it. > > The plan is to remove this function once all of the compatible strings > for each device have been brought into line. > > Acked-by: Grant Likely <grant.likely@linaro.org> > Signed-off-by: Lee Jones <lee.jones@linaro.org> > [Kieran: strnicmp to strncasecmp] > Signed-off-by: Kieran Bingham <kieran@bingham.xyz> > Tested-by: Kieran Bingham <kieran@bingham.xyz> > --- Reviewed-by: Javier Martinez Canillas <javier@osg.samsung.com> Tested-by: Javier Martinez Canillas <javier@osg.samsung.com> Best regards, -- Javier Martinez Canillas Open Source Group Samsung Research America
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web