Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1394745 > unrolled thread
| Started by | Konstantin Shkolnyy <konstantin.shkolnyy@gmail.com> |
|---|---|
| First post | 2016-05-05 00:00 +0200 |
| Last post | 2016-05-05 12:10 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
[PATCH v5 0/3] USB: serial: cp210x: Bugfixes and cleanup in CRTSCTS flag code Konstantin Shkolnyy <konstantin.shkolnyy@gmail.com> - 2016-05-05 00:00 +0200
Re: [PATCH v5 0/3] USB: serial: cp210x: Bugfixes and cleanup in CRTSCTS flag code Johan Hovold <johan@kernel.org> - 2016-05-05 12:10 +0200
| From | Konstantin Shkolnyy <konstantin.shkolnyy@gmail.com> |
|---|---|
| Date | 2016-05-05 00:00 +0200 |
| Subject | [PATCH v5 0/3] USB: serial: cp210x: Bugfixes and cleanup in CRTSCTS flag code |
| Message-ID | <rvcZQ-3pD-25@gated-at.bofh.it> |
This patch series fixes bugs and replaces magic numbers with symbolic names in CRTSCTS flag code. v5: Fixed 2 compile errors in PATCH 2/3, otherwise no change. v4: Same series of patches, fixed names and defines by feedback. v3: Regenerated the patches correctly against the latest usb-next branch. v2 Improved CRTSCTS fix by feedback. Dropped get_termios error handling fix. Konstantin Shkolnyy (3): USB: serial: cp210x: Fixed RTS mode setting by the CRTSCTS flag. USB: serial: cp210x: Got rid of magic numbers in CRTSCTS flag code. USB: serial: cp210x: Cleaned up CRTSCTS flag code. drivers/usb/serial/cp210x.c | 102 ++++++++++++++++++++++++++++++++------------ 1 file changed, 74 insertions(+), 28 deletions(-) -- 1.8.4.5
[toc] | [next] | [standalone]
| From | Johan Hovold <johan@kernel.org> |
|---|---|
| Date | 2016-05-05 12:10 +0200 |
| Subject | Re: [PATCH v5 0/3] USB: serial: cp210x: Bugfixes and cleanup in CRTSCTS flag code |
| Message-ID | <rvooi-6rF-11@gated-at.bofh.it> |
| In reply to | #1394745 |
On Wed, May 04, 2016 at 04:56:38PM -0500, Konstantin Shkolnyy wrote: > This patch series fixes bugs and replaces magic numbers with symbolic > names in CRTSCTS flag code. > > v5: > Fixed 2 compile errors in PATCH 2/3, otherwise no change. > v4: > Same series of patches, fixed names and defines by feedback. > v3: > Regenerated the patches correctly against the latest usb-next branch. > v2 > Improved CRTSCTS fix by feedback. Dropped get_termios error handling fix. > > Konstantin Shkolnyy (3): > USB: serial: cp210x: Fixed RTS mode setting by the CRTSCTS flag. > USB: serial: cp210x: Got rid of magic numbers in CRTSCTS flag code. > USB: serial: cp210x: Cleaned up CRTSCTS flag code. > > drivers/usb/serial/cp210x.c | 102 ++++++++++++++++++++++++++++++++------------ > 1 file changed, 74 insertions(+), 28 deletions(-) Thanks for the v5. All now applied for -next. I reworded the first commit message slightly and added a stable tag since it clearly fixes a bug even if it happens to have been around since 2005 without anyone noticing. And thanks again for doing this work. The code is indeed much easier to read now, and provides a good foundation for further improvements. Johan
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web