Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1395951 > unrolled thread
| Started by | "Maarten Brock" <m.brock@vanmierlo.com> |
|---|---|
| First post | 2016-05-06 17:50 +0200 |
| Last post | 2016-05-06 20:10 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
Re: [PATCH v3 03/11] dmaengine: dw: set polarity of handshake interface "Maarten Brock" <m.brock@vanmierlo.com> - 2016-05-06 17:50 +0200
Re: [PATCH v3 03/11] dmaengine: dw: set polarity of handshake interface Andy Shevchenko <andriy.shevchenko@linux.intel.com> - 2016-05-06 20:10 +0200
| From | "Maarten Brock" <m.brock@vanmierlo.com> |
|---|---|
| Date | 2016-05-06 17:50 +0200 |
| Subject | Re: [PATCH v3 03/11] dmaengine: dw: set polarity of handshake interface |
| Message-ID | <rvQaT-7UW-11@gated-at.bofh.it> |
----- Original Message ----- From: Andy Shevchenko [mailto:andy.shevchenko@gmail.com] To: Maarten Brock [mailto:m.brock@vanmierlo.com] Cc: Andy Shevchenko [mailto:andriy.shevchenko@linux.intel.com], Bryan O'Donoghue [mailto:pure.logic@nexus-software.ie], Peter Hurley [mailto:peter@hurleysoftware.com], linux-serial@vger.kernel.org [mailto:linux-serial@vger.kernel.org], Vinod Koul [mailto:vinod.koul@intel.com], linux-kernel@vger.kernel.org [mailto:linux-kernel@vger.kernel.org], dmaengine [mailto:dmaengine@vger.kernel.org], Greg Kroah-Hartman [mailto:gregkh@linuxfoundation.org], Puustinen, Ismo [mailto:ismo.puustinen@intel.com], Heikki Krogerus [mailto:heikki.krogerus@linux.intel.com] Sent: Fri, 06 May 2016 13:38:44 +0200 Subject: Re: [PATCH v3 03/11] dmaengine: dw: set polarity of handshake interface > On Fri, May 6, 2016 at 2:20 PM, Maarten Brock <m.brock@vanmierlo.com> wrote: > >> > > > >> > > + bool polarity; > >> > So this variable is not very intuitively named. > >> > >> There is a help above. This is a property of the Synopsys DesignWare DMA > >> engine. Anyone familiar with datasheet easily understands this. > >> > >> > > >> > You end up setting somepointer->polarity = true; in a later patch. > >> > > >> > Since you're respining a V4 I'd suggest a name that describes a little > >> > bit better than polarity. Setting polarity = true is a little bit > >> > liked being asked "you you like ice-cream or apple pie" and then > >> > saying "yes please". > >> > >> It's about handshake interface polarity, so, what about hs_polarity? > > > > So it means: handshake has polarity (true) or handshake has no polarity > > (omnidirectional?) (false), right? > > It means that handshake polarity _signal_ is inverted (true) or > default (false) in terms of hardware gates. Would it not be better then to name it handshake_inverted ? That is something you can ask and answer with true or false. Maarten > -- > With Best Regards, > Andy Shevchenko >
[toc] | [next] | [standalone]
| From | Andy Shevchenko <andriy.shevchenko@linux.intel.com> |
|---|---|
| Date | 2016-05-06 20:10 +0200 |
| Message-ID | <rvSmm-1A4-5@gated-at.bofh.it> |
| In reply to | #1395951 |
On Fri, 2016-05-06 at 17:48 +0200, Maarten Brock wrote: > + bool polarity; > > > > > So this variable is not very intuitively named. > > > > There is a help above. This is a property of the Synopsys > > > > DesignWare DMA > > > > engine. Anyone familiar with datasheet easily understands this. > > > > > > > > > > > > > > > > > > > You end up setting somepointer->polarity = true; in a later > > > > > patch. > > > > > > > > > > Since you're respining a V4 I'd suggest a name that describes > > > > > a little > > > > > bit better than polarity. Setting polarity = true is a little > > > > > bit > > > > > liked being asked "you you like ice-cream or apple pie" and > > > > > then > > > > > saying "yes please". > > > > It's about handshake interface polarity, so, what about > > > > hs_polarity? > > > So it means: handshake has polarity (true) or handshake has no > > > polarity > > > (omnidirectional?) (false), right? > > It means that handshake polarity _signal_ is inverted (true) or > > default (false) in terms of hardware gates. > Would it not be better then to name it handshake_inverted ? That is > something you can ask and answer with true or false. > I would stick for now with hs_polarity as agreed with Bryan. Without specification any (more or less short) name will suck anyway. -- Andy Shevchenko <andriy.shevchenko@linux.intel.com> Intel Finland Oy
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web