Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1390782 > unrolled thread
| Started by | Stephen Rothwell <sfr@canb.auug.org.au> |
|---|---|
| First post | 2016-04-29 08:20 +0200 |
| Last post | 2016-04-29 08:30 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
linux-next: manual merge of the akpm-current tree with the tip tree Stephen Rothwell <sfr@canb.auug.org.au> - 2016-04-29 08:20 +0200
Re: linux-next: manual merge of the akpm-current tree with the tip tree Ingo Molnar <mingo@kernel.org> - 2016-04-29 08:30 +0200
| From | Stephen Rothwell <sfr@canb.auug.org.au> |
|---|---|
| Date | 2016-04-29 08:20 +0200 |
| Subject | linux-next: manual merge of the akpm-current tree with the tip tree |
| Message-ID | <rt9Wp-1dU-7@gated-at.bofh.it> |
Hi Andrew,
Today's linux-next merge of the akpm-current tree got a conflict in:
include/linux/efi.h
between commit:
2c23b73c2d02 ("Ard Biesheuvel <ard.biesheuvel@linaro.org>")
from the tip tree and commit:
9f2c36a7b097 ("include/linux/efi.h: redefine type, constant, macro from generic code")
from the akpm-current tree.
I fixed it up (see below) and can carry the fix as necessary. This
is now fixed as far as linux-next is concerned, but any non trivial
conflicts should be mentioned to your upstream maintainer when your tree
is submitted for merging. You may also want to consider cooperating
with the maintainer of the conflicting tree to minimise any particularly
complex conflicts.
--
Cheers,
Stephen Rothwell
diff --cc include/linux/efi.h
index aa36fb8bea4b,5b1d5c5b4080..000000000000
--- a/include/linux/efi.h
+++ b/include/linux/efi.h
@@@ -21,7 -21,7 +21,8 @@@
#include <linux/pfn.h>
#include <linux/pstore.h>
#include <linux/reboot.h>
+#include <linux/screen_info.h>
+ #include <linux/uuid.h>
#include <asm/page.h>
[toc] | [next] | [standalone]
| From | Ingo Molnar <mingo@kernel.org> |
|---|---|
| Date | 2016-04-29 08:30 +0200 |
| Subject | Re: linux-next: manual merge of the akpm-current tree with the tip tree |
| Message-ID | <rta67-1ix-33@gated-at.bofh.it> |
| In reply to | #1390782 |
* Stephen Rothwell <sfr@canb.auug.org.au> wrote:
> Hi Andrew,
>
> Today's linux-next merge of the akpm-current tree got a conflict in:
>
> include/linux/efi.h
>
> between commit:
>
> 2c23b73c2d02 ("Ard Biesheuvel <ard.biesheuvel@linaro.org>")
>
> from the tip tree and commit:
>
> 9f2c36a7b097 ("include/linux/efi.h: redefine type, constant, macro from generic code")
>
> from the akpm-current tree.
>
> I fixed it up (see below) and can carry the fix as necessary. This
> is now fixed as far as linux-next is concerned, but any non trivial
> conflicts should be mentioned to your upstream maintainer when your tree
> is submitted for merging. You may also want to consider cooperating
> with the maintainer of the conflicting tree to minimise any particularly
> complex conflicts.
Btw., while looking at this, I noticed that akpm-current introduced this namespace
collision:
include/acpi/acconfig.h:#define UUID_STRING_LENGTH 36 /* Total length of a UUID string */
include/linux/uuid.h:#define UUID_STRING_LEN 36
I suspect the include/acpi/acconfig.h define should be renamed:
UUID_STRING_LENGTH -> ACPI_UUID_STRING_LENGTH
UUID_BUFFER_LENGTH -> ACPI_UUID_BUFFER_LENGTH
... before the collision causes any trouble.
Thanks,
Ingo
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web