Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1389917 > unrolled thread

[RFC v4 2/8] gpio: rename gpio-generic.c into gpio-mmio.c

Started byChristian Lamparter <chunkeey@googlemail.com>
First post2016-04-28 11:10 +0200
Last post2016-04-29 16:20 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [RFC v4 2/8] gpio: rename gpio-generic.c into gpio-mmio.c Christian Lamparter <chunkeey@googlemail.com> - 2016-04-28 11:10 +0200
    Re: [RFC v4 2/8] gpio: rename gpio-generic.c into gpio-mmio.c Linus Walleij <linus.walleij@linaro.org> - 2016-04-29 16:20 +0200

#1389917 — [RFC v4 2/8] gpio: rename gpio-generic.c into gpio-mmio.c

FromChristian Lamparter <chunkeey@googlemail.com>
Date2016-04-28 11:10 +0200
Subject[RFC v4 2/8] gpio: rename gpio-generic.c into gpio-mmio.c
Message-ID<rsQ7p-Ft-39@gated-at.bofh.it>
This patch renames the gpio-generic.c into gpio-mmio.c.
This is because currently the file only contains code
for a memory-mapped GPIO driver. There isn't any support
for ioports or other resource type.

Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
---
 drivers/gpio/Makefile                        | 3 +++
 drivers/gpio/{gpio-generic.c => gpio-mmio.c} | 0
 2 files changed, 3 insertions(+)
 rename drivers/gpio/{gpio-generic.c => gpio-mmio.c} (100%)

diff --git a/drivers/gpio/Makefile b/drivers/gpio/Makefile
index 74eb1a7..991598e 100644
--- a/drivers/gpio/Makefile
+++ b/drivers/gpio/Makefile
@@ -12,6 +12,9 @@ obj-$(CONFIG_GPIO_ACPI)		+= gpiolib-acpi.o
 # Device drivers. Generally keep list sorted alphabetically
 obj-$(CONFIG_GPIO_GENERIC)	+= gpio-generic.o
 
+# directly supported by gpio-generic
+gpio-generic-$(CONFIG_GPIO_GENERIC)	+= gpio-mmio.o
+
 obj-$(CONFIG_GPIO_104_DIO_48E)	+= gpio-104-dio-48e.o
 obj-$(CONFIG_GPIO_104_IDIO_16)	+= gpio-104-idio-16.o
 obj-$(CONFIG_GPIO_104_IDI_48)	+= gpio-104-idi-48.o
diff --git a/drivers/gpio/gpio-generic.c b/drivers/gpio/gpio-mmio.c
similarity index 100%
rename from drivers/gpio/gpio-generic.c
rename to drivers/gpio/gpio-mmio.c
-- 
2.8.1

[toc] | [next] | [standalone]


#1391186

FromLinus Walleij <linus.walleij@linaro.org>
Date2016-04-29 16:20 +0200
Message-ID<rthqW-7qz-13@gated-at.bofh.it>
In reply to#1389917
On Thu, Apr 28, 2016 at 11:05 AM, Christian Lamparter
<chunkeey@googlemail.com> wrote:

> This patch renames the gpio-generic.c into gpio-mmio.c.
> This is because currently the file only contains code
> for a memory-mapped GPIO driver. There isn't any support
> for ioports or other resource type.
>
> Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>

Makes perfect sense.

Patch applied.

Yours,
Linus Walleij

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web