Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1384111 > unrolled thread
| Started by | Mark Rutland <mark.rutland@arm.com> |
|---|---|
| First post | 2016-04-21 13:40 +0200 |
| Last post | 2016-04-21 19:00 +0200 |
| Articles | 3 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
[PATCHv2 2/5] arm64/efi: move to generic {__,}efi_call_virt Mark Rutland <mark.rutland@arm.com> - 2016-04-21 13:40 +0200
Re: [PATCHv2 2/5] arm64/efi: move to generic {__,}efi_call_virt Will Deacon <will.deacon@arm.com> - 2016-04-21 18:50 +0200
Re: [PATCHv2 2/5] arm64/efi: move to generic {__,}efi_call_virt Mark Rutland <mark.rutland@arm.com> - 2016-04-21 19:00 +0200
| From | Mark Rutland <mark.rutland@arm.com> |
|---|---|
| Date | 2016-04-21 13:40 +0200 |
| Subject | [PATCHv2 2/5] arm64/efi: move to generic {__,}efi_call_virt |
| Message-ID | <rql7J-8rt-43@gated-at.bofh.it> |
Now there's a common template for {__,}efi_call_virt, remove the
duplicate logic from the arm64 efi code.
Signed-off-by: Mark Rutland <mark.rutland@arm.com>
Cc: Ard Biesheuvel <ard.biesheuvel@linaro.org>
Cc: Catalin Marinas <catalin.marinas@arm.com>
Cc: Leif Lindholm <leif.lindholm@linaro.org>
Cc: Matt Fleming <matt@codeblueprint.co.uk>
Cc: Will Deacon <will.deacon@arm.com>
Cc: linux-arm-kernel@lists.infradead.org
Cc: linux-efi@vger.kernel.org
Cc: linux-kernel@vger.kernel.org
---
arch/arm64/include/asm/efi.h | 21 +++++++--------------
1 file changed, 7 insertions(+), 14 deletions(-)
diff --git a/arch/arm64/include/asm/efi.h b/arch/arm64/include/asm/efi.h
index 8e88a69..f4f71224 100644
--- a/arch/arm64/include/asm/efi.h
+++ b/arch/arm64/include/asm/efi.h
@@ -14,28 +14,21 @@ extern void efi_init(void);
int efi_create_mapping(struct mm_struct *mm, efi_memory_desc_t *md);
-#define efi_call_virt(f, ...) \
+#define arch_efi_call_virt_setup() \
({ \
- efi_##f##_t *__f; \
- efi_status_t __s; \
- \
kernel_neon_begin(); \
efi_virtmap_load(); \
- __f = efi.systab->runtime->f; \
- __s = __f(__VA_ARGS__); \
- efi_virtmap_unload(); \
- kernel_neon_end(); \
- __s; \
})
-#define __efi_call_virt(f, ...) \
+#define arch_efi_call_virt(f, args...) \
({ \
efi_##f##_t *__f; \
- \
- kernel_neon_begin(); \
- efi_virtmap_load(); \
__f = efi.systab->runtime->f; \
- __f(__VA_ARGS__); \
+ __f(args); \
+})
+
+#define arch_efi_call_virt_teardown() \
+({ \
efi_virtmap_unload(); \
kernel_neon_end(); \
})
--
1.9.1
[toc] | [next] | [standalone]
| From | Will Deacon <will.deacon@arm.com> |
|---|---|
| Date | 2016-04-21 18:50 +0200 |
| Message-ID | <rqpXI-3HX-11@gated-at.bofh.it> |
| In reply to | #1384111 |
On Thu, Apr 21, 2016 at 12:35:26PM +0100, Mark Rutland wrote:
> Now there's a common template for {__,}efi_call_virt, remove the
> duplicate logic from the arm64 efi code.
>
> Signed-off-by: Mark Rutland <mark.rutland@arm.com>
> Cc: Ard Biesheuvel <ard.biesheuvel@linaro.org>
> Cc: Catalin Marinas <catalin.marinas@arm.com>
> Cc: Leif Lindholm <leif.lindholm@linaro.org>
> Cc: Matt Fleming <matt@codeblueprint.co.uk>
> Cc: Will Deacon <will.deacon@arm.com>
> Cc: linux-arm-kernel@lists.infradead.org
> Cc: linux-efi@vger.kernel.org
> Cc: linux-kernel@vger.kernel.org
> ---
> arch/arm64/include/asm/efi.h | 21 +++++++--------------
> 1 file changed, 7 insertions(+), 14 deletions(-)
>
> diff --git a/arch/arm64/include/asm/efi.h b/arch/arm64/include/asm/efi.h
> index 8e88a69..f4f71224 100644
> --- a/arch/arm64/include/asm/efi.h
> +++ b/arch/arm64/include/asm/efi.h
> @@ -14,28 +14,21 @@ extern void efi_init(void);
>
> int efi_create_mapping(struct mm_struct *mm, efi_memory_desc_t *md);
>
> -#define efi_call_virt(f, ...) \
> +#define arch_efi_call_virt_setup() \
> ({ \
> - efi_##f##_t *__f; \
> - efi_status_t __s; \
> - \
> kernel_neon_begin(); \
> efi_virtmap_load(); \
> - __f = efi.systab->runtime->f; \
> - __s = __f(__VA_ARGS__); \
> - efi_virtmap_unload(); \
> - kernel_neon_end(); \
> - __s; \
> })
>
> -#define __efi_call_virt(f, ...) \
> +#define arch_efi_call_virt(f, args...) \
> ({ \
> efi_##f##_t *__f; \
> - \
> - kernel_neon_begin(); \
> - efi_virtmap_load(); \
> __f = efi.systab->runtime->f; \
> - __f(__VA_ARGS__); \
> + __f(args); \
Any reason to change this to a named argument? This patch is hard enough
to review as it is, given the way the diff has been generated!
Either way:
Acked-by: Will Deacon <will.deacon@arm.com>
Will
[toc] | [prev] | [next] | [standalone]
| From | Mark Rutland <mark.rutland@arm.com> |
|---|---|
| Date | 2016-04-21 19:00 +0200 |
| Message-ID | <rqq7p-3Lk-27@gated-at.bofh.it> |
| In reply to | #1384423 |
On Thu, Apr 21, 2016 at 05:48:40PM +0100, Will Deacon wrote:
> On Thu, Apr 21, 2016 at 12:35:26PM +0100, Mark Rutland wrote:
> > Now there's a common template for {__,}efi_call_virt, remove the
> > duplicate logic from the arm64 efi code.
> >
> > Signed-off-by: Mark Rutland <mark.rutland@arm.com>
> > Cc: Ard Biesheuvel <ard.biesheuvel@linaro.org>
> > Cc: Catalin Marinas <catalin.marinas@arm.com>
> > Cc: Leif Lindholm <leif.lindholm@linaro.org>
> > Cc: Matt Fleming <matt@codeblueprint.co.uk>
> > Cc: Will Deacon <will.deacon@arm.com>
> > Cc: linux-arm-kernel@lists.infradead.org
> > Cc: linux-efi@vger.kernel.org
> > Cc: linux-kernel@vger.kernel.org
> > ---
> > arch/arm64/include/asm/efi.h | 21 +++++++--------------
> > 1 file changed, 7 insertions(+), 14 deletions(-)
> >
> > diff --git a/arch/arm64/include/asm/efi.h b/arch/arm64/include/asm/efi.h
> > index 8e88a69..f4f71224 100644
> > --- a/arch/arm64/include/asm/efi.h
> > +++ b/arch/arm64/include/asm/efi.h
> > @@ -14,28 +14,21 @@ extern void efi_init(void);
> >
> > int efi_create_mapping(struct mm_struct *mm, efi_memory_desc_t *md);
> >
> > -#define efi_call_virt(f, ...) \
> > +#define arch_efi_call_virt_setup() \
> > ({ \
> > - efi_##f##_t *__f; \
> > - efi_status_t __s; \
> > - \
> > kernel_neon_begin(); \
> > efi_virtmap_load(); \
> > - __f = efi.systab->runtime->f; \
> > - __s = __f(__VA_ARGS__); \
> > - efi_virtmap_unload(); \
> > - kernel_neon_end(); \
> > - __s; \
> > })
> >
> > -#define __efi_call_virt(f, ...) \
> > +#define arch_efi_call_virt(f, args...) \
> > ({ \
> > efi_##f##_t *__f; \
> > - \
> > - kernel_neon_begin(); \
> > - efi_virtmap_load(); \
> > __f = efi.systab->runtime->f; \
> > - __f(__VA_ARGS__); \
> > + __f(args); \
>
> Any reason to change this to a named argument? This patch is hard enough
> to review as it is, given the way the diff has been generated!
That was to enforce consistency across arm/arm64/x86 for this.
It seemed nicer to make them all use a named argument than it did to
make them all use __VA_ARGS__, either of which was nice than each of
them doing something slightly different.
Sorry for the pain that evidently caused!
> Either way:
>
> Acked-by: Will Deacon <will.deacon@arm.com>
Cheers!
Mark.
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web