Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1356897 > unrolled thread

[PATCH 00/22] ncr5380: Eliminate macros, reduce code duplication, fix bugs etc

Started byFinn Thain <fthain@telegraphics.com.au>
First post2016-03-14 05:50 +0100
Last post2016-03-18 08:10 +0100
Articles 3 on this page of 43 — 5 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH 00/22] ncr5380: Eliminate macros, reduce code duplication, fix bugs etc Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 09/22] ncr5380: Adopt uniform DMA setup convention Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
      Re: [PATCH 09/22] ncr5380: Adopt uniform DMA setup convention Hannes Reinecke <hare@suse.de> - 2016-03-14 08:40 +0100
        Re: [PATCH 09/22] ncr5380: Adopt uniform DMA setup convention Finn Thain <fthain@telegraphics.com.au> - 2016-03-15 04:30 +0100
          Re: [PATCH 09/22] ncr5380: Adopt uniform DMA setup convention Hannes Reinecke <hare@suse.de> - 2016-03-15 08:00 +0100
    [PATCH 05/22] ncr5380: Disable the DMA errata workaround flag by default Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 12/22] sun3_scsi: Adopt NCR5380.c core driver Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 06/22] ncr5380: Remove PSEUDO_DMA macro Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 17/22] ncr5380: Remove remaining register storage qualifiers Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 11/22] atari_scsi: Adopt NCR5380.c core driver Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
      Re: [PATCH 11/22] atari_scsi: Adopt NCR5380.c core driver Hannes Reinecke <hare@suse.de> - 2016-03-14 08:40 +0100
    [PATCH 15/22] dmx3191d: Drop max_sectors limit Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 14/22] ncr5380: Add MAX_LUN limit Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
      Re: [PATCH 14/22] ncr5380: Add MAX_LUN limit Hannes Reinecke <hare@suse.de> - 2016-03-14 08:50 +0100
      Re: [PATCH 14/22] ncr5380: Add MAX_LUN limit Christoph Hellwig <hch@infradead.org> - 2016-03-14 09:00 +0100
        Re: [PATCH 14/22] ncr5380: Add MAX_LUN limit Finn Thain <fthain@telegraphics.com.au> - 2016-03-15 04:30 +0100
          Re: [PATCH 14/22] ncr5380: Add MAX_LUN limit Christoph Hellwig <hch@infradead.org> - 2016-03-15 09:30 +0100
    [PATCH 07/22] ncr5380: Remove BOARD_REQUIRES_NO_DELAY macro Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 20/22] atari_scsi: Set a reasonable default for cmd_per_lun Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
      Re: [PATCH 20/22] atari_scsi: Set a reasonable default for  cmd_per_lun Hannes Reinecke <hare@suse.de> - 2016-03-14 08:50 +0100
        Re: [PATCH 20/22] atari_scsi: Set a reasonable default for  cmd_per_lun Finn Thain <fthain@telegraphics.com.au> - 2016-03-15 04:30 +0100
          Re: [PATCH 20/22] atari_scsi: Set a reasonable default for  cmd_per_lun Hannes Reinecke <hare@suse.de> - 2016-03-15 08:00 +0100
            Re: [PATCH 20/22] atari_scsi: Set a reasonable default for  cmd_per_lun Finn Thain <fthain@telegraphics.com.au> - 2016-03-15 09:30 +0100
          Re: [PATCH 20/22] atari_scsi: Set a reasonable default for  cmd_per_lun James Bottomley <James.Bottomley@HansenPartnership.com> - 2016-03-15 15:40 +0100
    [PATCH 08/22] ncr5380: Use DMA hooks for PDMA Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 18/22] ncr5380: Remove DONT_USE_INTR and AUTOPROBE_IRQ macros Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 22/22] mac_scsi: Fix pseudo DMA implementation Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 02/22] ncr5380: Remove FLAG_NO_PSEUDO_DMA where possible Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 16/22] ncr5380: Fix register decoding for debugging Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
      Re: [PATCH 16/22] ncr5380: Fix register decoding for debugging Hannes Reinecke <hare@suse.de> - 2016-03-14 08:50 +0100
        Re: [PATCH 16/22] ncr5380: Fix register decoding for debugging Finn Thain <fthain@telegraphics.com.au> - 2016-03-15 04:30 +0100
    [PATCH 19/22] ncr5380: Update usage documentation Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 21/22] atari_scsi: Allow can_queue to be increased for Falcon Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
      Re: [PATCH 21/22] atari_scsi: Allow can_queue to be increased for  Falcon Hannes Reinecke <hare@suse.de> - 2016-03-14 09:00 +0100
    [PATCH 10/22] ncr5380: Merge DMA implementation from atari_NCR5380 core driver Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 05:50 +0100
    [PATCH 01/22] g_ncr5380: Remove CONFIG_SCSI_GENERIC_NCR53C400 Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 06:00 +0100
      Re: [PATCH 01/22] g_ncr5380: Remove CONFIG_SCSI_GENERIC_NCR53C400 Hannes Reinecke <hare@suse.de> - 2016-03-14 08:30 +0100
    [PATCH 03/22] ncr5380: Remove REAL_DMA and REAL_DMA_POLL macros Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 06:00 +0100
      Re: [PATCH 03/22] ncr5380: Remove REAL_DMA and REAL_DMA_POLL macros Hannes Reinecke <hare@suse.de> - 2016-03-14 08:30 +0100
    [PATCH 04/22] atari_NCR5380: Remove DMA_MIN_SIZE macro Finn Thain <fthain@telegraphics.com.au> - 2016-03-14 06:00 +0100
      Re: [PATCH 04/22] atari_NCR5380: Remove DMA_MIN_SIZE macro Hannes Reinecke <hare@suse.de> - 2016-03-14 08:30 +0100
        Re: [PATCH 04/22] atari_NCR5380: Remove DMA_MIN_SIZE macro Finn Thain <fthain@telegraphics.com.au> - 2016-03-15 04:20 +0100
    Re: [PATCH 00/22] ncr5380: Eliminate macros, reduce code duplication,  fix bugs etc Michael Schmitz <schmitzmic@gmail.com> - 2016-03-18 08:10 +0100

Page 3 of 3 — ← Prev page 1 2 [3]


#1356990 — Re: [PATCH 04/22] atari_NCR5380: Remove DMA_MIN_SIZE macro

FromHannes Reinecke <hare@suse.de>
Date2016-03-14 08:30 +0100
SubjectRe: [PATCH 04/22] atari_NCR5380: Remove DMA_MIN_SIZE macro
Message-ID<rcv6V-DY-7@gated-at.bofh.it>
In reply to#1356932
On 03/14/2016 05:27 AM, Finn Thain wrote:
> Only the atari_scsi and sun3_scsi drivers define DMA_MIN_SIZE.
> Both drivers also define NCR5380_dma_xfer_len, which means
> DMA_MIN_SIZE is redundant.
> 
> This removes another discrepancy between the two core drivers.
> 
> Signed-off-by: Finn Thain <fthain@telegraphics.com.au>
> 
> ---
>  drivers/scsi/atari_NCR5380.c |   16 ++++++++--------
>  drivers/scsi/atari_scsi.c    |    4 +++-
>  drivers/scsi/sun3_scsi.c     |   16 ++++++----------
>  3 files changed, 17 insertions(+), 19 deletions(-)
> 
> Index: linux/drivers/scsi/atari_NCR5380.c
> ===================================================================
> --- linux.orig/drivers/scsi/atari_NCR5380.c	2016-03-14 15:26:23.000000000 +1100
> +++ linux/drivers/scsi/atari_NCR5380.c	2016-03-14 15:26:26.000000000 +1100
> @@ -1857,12 +1857,11 @@ static void NCR5380_information_transfer
>  					d = cmd->SCp.ptr;
>  				}
>  				/* this command setup for dma yet? */
> -				if ((count >= DMA_MIN_SIZE) && (sun3_dma_setup_done != cmd)) {
> -					if (cmd->request->cmd_type == REQ_TYPE_FS) {
> -						sun3scsi_dma_setup(instance, d, count,
> -						                   rq_data_dir(cmd->request));
> -						sun3_dma_setup_done = cmd;
> -					}
> +				if (sun3_dma_setup_done != cmd &&
> +				    sun3scsi_dma_xfer_len(count, cmd) > 0) {
> +					sun3scsi_dma_setup(instance, d, count,
> +					                   rq_data_dir(cmd->request));
> +					sun3_dma_setup_done = cmd;
>  				}
>  #ifdef SUN3_SCSI_VME
>  				dregs->csr |= CSR_INTR;
> @@ -1927,7 +1926,7 @@ static void NCR5380_information_transfer
>  #endif
>  					transfersize = NCR5380_dma_xfer_len(instance, cmd, phase);
>  
> -				if (transfersize >= DMA_MIN_SIZE) {
> +				if (transfersize > 0) {
>  					len = transfersize;
>  					cmd->SCp.phase = phase;
>  					if (NCR5380_transfer_dma(instance, &phase,
> @@ -2366,7 +2365,8 @@ static void NCR5380_reselect(struct Scsi
>  			d = tmp->SCp.ptr;
>  		}
>  		/* setup this command for dma if not already */
> -		if ((count >= DMA_MIN_SIZE) && (sun3_dma_setup_done != tmp)) {
> +		if (sun3_dma_setup_done != tmp &&
> +		    sun3scsi_dma_xfer_len(count, tmp) > 0) {
>  			sun3scsi_dma_setup(instance, d, count,
>  			                   rq_data_dir(tmp->request));
>  			sun3_dma_setup_done = tmp;
> Index: linux/drivers/scsi/atari_scsi.c
> ===================================================================
> --- linux.orig/drivers/scsi/atari_scsi.c	2016-03-14 15:26:23.000000000 +1100
> +++ linux/drivers/scsi/atari_scsi.c	2016-03-14 15:26:26.000000000 +1100
> @@ -87,7 +87,6 @@
>  
>  #define SUPPORT_TAGS
>  #define MAX_TAGS                        32
> -#define DMA_MIN_SIZE                    32
>  
>  #define NCR5380_implementation_fields   /* none */
>  
> @@ -605,6 +604,9 @@ static unsigned long atari_dma_xfer_len(
>  {
>  	unsigned long	possible_len, limit;
>  
> +	if (wanted_len < 32)
> +		return 0;
> +
>  	if (IS_A_TT())
>  		/* TT SCSI DMA can transfer arbitrary #bytes */
>  		return wanted_len;
> Index: linux/drivers/scsi/sun3_scsi.c
> ===================================================================
> --- linux.orig/drivers/scsi/sun3_scsi.c	2016-03-14 15:26:23.000000000 +1100
> +++ linux/drivers/scsi/sun3_scsi.c	2016-03-14 15:26:26.000000000 +1100
> @@ -39,9 +39,6 @@
>  /* Definitions for the core NCR5380 driver. */
>  
>  /* #define SUPPORT_TAGS */
> -/* minimum number of bytes to do dma on */
> -#define DMA_MIN_SIZE                    129
> -
>  /* #define MAX_TAGS                     32 */
>  
>  #define NCR5380_implementation_fields   /* none */
> @@ -61,7 +58,7 @@
>  #define NCR5380_dma_residual(instance) \
>          sun3scsi_dma_residual(instance)
>  #define NCR5380_dma_xfer_len(instance, cmd, phase) \
> -        sun3scsi_dma_xfer_len(cmd->SCp.this_residual, cmd, !((phase) & SR_IO))
> +        sun3scsi_dma_xfer_len(cmd->SCp.this_residual, cmd)
>  
>  #define NCR5380_acquire_dma_irq(instance)    (1)
>  #define NCR5380_release_dma_irq(instance)
> @@ -262,14 +259,13 @@ static inline unsigned long sun3scsi_dma
>  	return last_residual;
>  }
>  
> -static inline unsigned long sun3scsi_dma_xfer_len(unsigned long wanted,
> -						  struct scsi_cmnd *cmd,
> -						  int write_flag)
> +static inline unsigned long sun3scsi_dma_xfer_len(unsigned long wanted_len,
> +                                                  struct scsi_cmnd *cmd)
>  {
> -	if (cmd->request->cmd_type == REQ_TYPE_FS)
> - 		return wanted;
> -	else
> +	if (wanted_len < 129 || cmd->request->cmd_type != REQ_TYPE_FS)
>  		return 0;
> +
> +	return wanted_len;
>  }
>  
>  static inline int sun3scsi_dma_start(unsigned long count, unsigned char *data)
> 
> 
I still would keep the 'DMA_MIN_LEN' definition around for
sun3_scsi.c; makes it a bit more obvious what the magic number '129'
is supposed to mean.

Cheers,

Hannes
-- 
Dr. Hannes Reinecke		   Teamlead Storage & Networking
hare@suse.de			               +49 911 74053 688
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: F. Imendörffer, J. Smithard, J. Guild, D. Upmanyu, G. Norton
HRB 21284 (AG Nürnberg)

[toc] | [prev] | [next] | [standalone]


#1357785 — Re: [PATCH 04/22] atari_NCR5380: Remove DMA_MIN_SIZE macro

FromFinn Thain <fthain@telegraphics.com.au>
Date2016-03-15 04:20 +0100
SubjectRe: [PATCH 04/22] atari_NCR5380: Remove DMA_MIN_SIZE macro
Message-ID<rcNGx-4H3-1@gated-at.bofh.it>
In reply to#1356990
On Mon, 14 Mar 2016, Hannes Reinecke wrote:

> I still would keep the 'DMA_MIN_LEN' definition around for sun3_scsi.c; 
> makes it a bit more obvious what the magic number '129' is supposed to 
> mean.

OK.

-- 

[toc] | [prev] | [next] | [standalone]


#1360382 — Re: [PATCH 00/22] ncr5380: Eliminate macros, reduce code duplication, fix bugs etc

FromMichael Schmitz <schmitzmic@gmail.com>
Date2016-03-18 08:10 +0100
SubjectRe: [PATCH 00/22] ncr5380: Eliminate macros, reduce code duplication, fix bugs etc
Message-ID<rdWHM-2jO-9@gated-at.bofh.it>
In reply to#1356897
Finn,

tested successfully on Atari Falcon, so:

Tested-by: Michael Schmitz <schmitzmic@gmail.com>

Am 14.03.2016 um 17:27 schrieb Finn Thain:
> This patch series has more macro elimination and some tweaks to the
> DMA hooks so that all the wrapper drivers can share the same core
> DMA algorithm. This resolves the major discrepancies between the two
> core drivers, which relate to code conditional on the REAL_DMA and
> PSEUDO_DMA macros.
> 
> After all the wrapper drivers agree on the DMA hook api, the core driver
> fork gets resolved. NCR5380.c is adopted by atari_scsi and sun3_scsi and
> atari_NCR5380.c is then deleted.
> 
> Historically, the 5380 drivers suffered from over-use of conditional
> compilation, which caused the compile-time configuration space to explode,
> leading to core driver code that was practically untestable, unmaintainable
> and difficult to reason about. It also prevented driver modules from
> sharing object code.
> 
> Along with REAL_DMA, REAL_DMA_POLL and PSEUDO_DMA, most of the remaining
> macros are also eradicated, such as CONFIG_SCSI_GENERIC_NCR53C400,
> SUPPORT_TAGS, DONT_USE_INTR, AUTOPROBE_IRQ and BIOSPARAM.
> 
> Also in this patch series, some duplicated documentation is removed and
> the PDMA implementation in mac_scsi finally gets fixed.
> 
> This patch series was tested by exercising the dmx3191d and mac_scsi modules
> on suitable hardware. Help with driver testing on ISA and Atari hardware
> is sought as I don't have any (likewise RiscPC ecards and Sun 3 hardware).
> 
> ---
>  Documentation/scsi/g_NCR5380.txt       |   17 
>  Documentation/scsi/scsi-parameters.txt |   11 
>  drivers/scsi/Kconfig                   |   11 
>  drivers/scsi/NCR5380.c                 |  661 ++++----
>  drivers/scsi/NCR5380.h                 |  145 -
>  drivers/scsi/arm/cumana_1.c            |   25 
>  drivers/scsi/arm/oak.c                 |   22 
>  drivers/scsi/atari_NCR5380.c           | 2676 ---------------------------------
>  drivers/scsi/atari_scsi.c              |  142 -
>  drivers/scsi/dmx3191d.c                |   10 
>  drivers/scsi/dtc.c                     |   27 
>  drivers/scsi/dtc.h                     |    7 
>  drivers/scsi/g_NCR5380.c               |  143 -
>  drivers/scsi/g_NCR5380.h               |   26 
>  drivers/scsi/mac_scsi.c                |  239 +-
>  drivers/scsi/pas16.c                   |   27 
>  drivers/scsi/pas16.h                   |    5 
>  drivers/scsi/sun3_scsi.c               |   48 
>  drivers/scsi/t128.c                    |   19 
>  drivers/scsi/t128.h                    |    7 
>  20 files changed, 636 insertions(+), 3632 deletions(-)
> 
> 
> 
> 

[toc] | [prev] | [standalone]


Page 3 of 3 — ← Prev page 1 2 [3]

Back to top | Article view | linux.kernel


csiph-web