Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1355922 > unrolled thread

[PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios

Started byLaxman Dewangan <ldewangan@nvidia.com>
First post2016-03-11 15:00 +0100
Last post2016-03-15 15:20 +0100
Articles 5 — 3 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios Laxman Dewangan <ldewangan@nvidia.com> - 2016-03-11 15:00 +0100
    Re: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support  multiple gpios Stephen Warren <swarren@wwwdotorg.org> - 2016-03-14 17:40 +0100
      Re: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support  multiple gpios Laxman Dewangan <ldewangan@nvidia.com> - 2016-03-15 08:00 +0100
        Re: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support  multiple gpios Stephen Warren <swarren@wwwdotorg.org> - 2016-03-15 16:50 +0100
    Re: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support  multiple gpios Linus Walleij <linus.walleij@linaro.org> - 2016-03-15 15:20 +0100

#1355922 — [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios

FromLaxman Dewangan <ldewangan@nvidia.com>
Date2016-03-11 15:00 +0100
Subject[PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios
Message-ID<rbvLI-73L-13@gated-at.bofh.it>
The property "gpios" of GPIO hog node support the multiple GPIO entries.
Rephrase the details of this property for this new support.

Add details of new property "label" for GPIO label name.

Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>

---
Changes from V1:
- Add details for the new property "label".
- Resequence series to make this as 4/5 which was 5/5.
---
 Documentation/devicetree/bindings/gpio/gpio.txt | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

diff --git a/Documentation/devicetree/bindings/gpio/gpio.txt b/Documentation/devicetree/bindings/gpio/gpio.txt
index 069cdf6..6270e2d 100644
--- a/Documentation/devicetree/bindings/gpio/gpio.txt
+++ b/Documentation/devicetree/bindings/gpio/gpio.txt
@@ -162,9 +162,9 @@ gpio-controller's driver probe function.
 Each GPIO hog definition is represented as a child node of the GPIO controller.
 Required properties:
 - gpio-hog:   A property specifying that this child node represent a GPIO hog.
-- gpios:      Store the GPIO information (id, flags, ...). Shall contain the
-	      number of cells specified in its parent node (GPIO controller
-	      node).
+- gpios:      Store the GPIO information (id, flags, ...). Multiple GPIOs are
+	      possible to list here. Shall contain the number of cells
+	      specified in its parent node (GPIO controller node) per GPIOs.
 Only one of the following properties scanned in the order shown below.
 This means that when multiple properties are present they will be searched
 in the order presented below and the first match is taken as the intended
@@ -177,6 +177,11 @@ configuration.
 
 Optional properties:
 - line-name:  The GPIO label name. If not present the node name is used.
+- label:      The GPIO lable name. This can have multiple string for GPIO
+	      label names to match with the GPIOs in "gpios" properties.
+	      If line-name is prosent than name is taken from line-name. If
+	      it is not then the name will be taken from label. If both are
+	      not available then node name is used for GPIO label name.
 
 Example of two SOC GPIO banks defined as gpio-controller nodes:
 
-- 
2.1.4

[toc] | [next] | [standalone]


#1357400 — Re: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios

FromStephen Warren <swarren@wwwdotorg.org>
Date2016-03-14 17:40 +0100
SubjectRe: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios
Message-ID<rcDHc-6ja-3@gated-at.bofh.it>
In reply to#1355922
On 03/11/2016 06:43 AM, Laxman Dewangan wrote:
> The property "gpios" of GPIO hog node support the multiple GPIO entries.
> Rephrase the details of this property for this new support.
>
> Add details of new property "label" for GPIO label name.

> diff --git a/Documentation/devicetree/bindings/gpio/gpio.txt b/Documentation/devicetree/bindings/gpio/gpio.txt

>   Optional properties:
>   - line-name:  The GPIO label name. If not present the node name is used.
> +- label:      The GPIO lable name. This can have multiple string for GPIO
> +	      label names to match with the GPIOs in "gpios" properties.
> +	      If line-name is prosent than name is taken from line-name. If
> +	      it is not then the name will be taken from label. If both are
> +	      not available then node name is used for GPIO label name.

Why are there two properties for the same thing? Why not just allow 
line-name to have multiple entries instead of introducing a new property?

[toc] | [prev] | [next] | [standalone]


#1357832 — Re: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios

FromLaxman Dewangan <ldewangan@nvidia.com>
Date2016-03-15 08:00 +0100
SubjectRe: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios
Message-ID<rcR7r-6VA-5@gated-at.bofh.it>
In reply to#1357400
On Monday 14 March 2016 10:01 PM, Stephen Warren wrote:
> On 03/11/2016 06:43 AM, Laxman Dewangan wrote:
>> The property "gpios" of GPIO hog node support the multiple GPIO entries.
>> Rephrase the details of this property for this new support.
>>
>> Add details of new property "label" for GPIO label name.
>
>> diff --git a/Documentation/devicetree/bindings/gpio/gpio.txt 
>> b/Documentation/devicetree/bindings/gpio/gpio.txt
>
>>   Optional properties:
>>   - line-name:  The GPIO label name. If not present the node name is 
>> used.
>> +- label:      The GPIO lable name. This can have multiple string for 
>> GPIO
>> +          label names to match with the GPIOs in "gpios" properties.
>> +          If line-name is prosent than name is taken from line-name. If
>> +          it is not then the name will be taken from label. If both are
>> +          not available then node name is used for GPIO label name.
>
> Why are there two properties for the same thing? Why not just allow 
> line-name to have multiple entries instead of introducing a new property?
>

We can use the lin-names also but per disucssion on the patch V1 of
     gpio: of: Add support to have multiple gpios in gpio-hog

Markus suggested the discussion about the discussion 
(https://lkml.org/lkml/2016/3/10/194):
     "Device tree binding documentation for gpio-switch"


and on that, label is used.  Also for names, "label" is going to very 
common.

So I added new property "label" to support multiple names.

[toc] | [prev] | [next] | [standalone]


#1358114 — Re: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios

FromStephen Warren <swarren@wwwdotorg.org>
Date2016-03-15 16:50 +0100
SubjectRe: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios
Message-ID<rcZom-3Yy-9@gated-at.bofh.it>
In reply to#1357832
On 03/15/2016 12:37 AM, Laxman Dewangan wrote:
>
> On Monday 14 March 2016 10:01 PM, Stephen Warren wrote:
>> On 03/11/2016 06:43 AM, Laxman Dewangan wrote:
>>> The property "gpios" of GPIO hog node support the multiple GPIO entries.
>>> Rephrase the details of this property for this new support.
>>>
>>> Add details of new property "label" for GPIO label name.
>>
>>> diff --git a/Documentation/devicetree/bindings/gpio/gpio.txt
>>> b/Documentation/devicetree/bindings/gpio/gpio.txt
>>
>>>   Optional properties:
>>>   - line-name:  The GPIO label name. If not present the node name is
>>> used.
>>> +- label:      The GPIO lable name. This can have multiple string for
>>> GPIO
>>> +          label names to match with the GPIOs in "gpios" properties.
>>> +          If line-name is prosent than name is taken from line-name. If
>>> +          it is not then the name will be taken from label. If both are
>>> +          not available then node name is used for GPIO label name.
>>
>> Why are there two properties for the same thing? Why not just allow
>> line-name to have multiple entries instead of introducing a new property?
>>
>
> We can use the lin-names also but per disucssion on the patch V1 of
>      gpio: of: Add support to have multiple gpios in gpio-hog
>
> Markus suggested the discussion about the discussion
> (https://lkml.org/lkml/2016/3/10/194):
>      "Device tree binding documentation for gpio-switch"
>
>
> and on that, label is used.  Also for names, "label" is going to very
> common.
>
> So I added new property "label" to support multiple names.

It makes sense to standardize on a common name for new bindings, but 
this binding has already picked a name. It'd be much simpler for anyone 
looking at the binding (and backwards-compatibility) to just stick with 
it. We have to support the old name forever no matter what. Supporting 
two different names will just be confusing.

[toc] | [prev] | [next] | [standalone]


#1358059 — Re: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios

FromLinus Walleij <linus.walleij@linaro.org>
Date2016-03-15 15:20 +0100
SubjectRe: [PATCH V2 4/5] gpio: DT: Rephrase "gpios" of hog node to support multiple gpios
Message-ID<rcXZg-3bg-7@gated-at.bofh.it>
In reply to#1355922
On Fri, Mar 11, 2016 at 2:43 PM, Laxman Dewangan <ldewangan@nvidia.com> wrote:

> The property "gpios" of GPIO hog node support the multiple GPIO entries.
> Rephrase the details of this property for this new support.
>
> Add details of new property "label" for GPIO label name.
>
> Signed-off-by: Laxman Dewangan <ldewangan@nvidia.com>

Also Rob H has expressed that he prefers "label" for this kind of
stuff.

So instead of adding it as another optional property, add it above
label-name, declare line-name as deprecated (and also mention
that it does not support an array). Maybe move under a separate
heading "Deprecated optional properties" or something.

Yours,
Linus Walleij

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web