Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1445068 > unrolled thread

Re: [RESEND PATCH 00/14] eeprom: at24: driver rework and at24cs/at24mac support

Started byWolfram Sang <wsa@the-dreams.de>
First post2016-07-17 20:10 +0200
Last post2016-07-17 20:10 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [RESEND PATCH 00/14] eeprom: at24: driver rework and  at24cs/at24mac support Wolfram Sang <wsa@the-dreams.de> - 2016-07-17 20:10 +0200

#1445068 — Re: [RESEND PATCH 00/14] eeprom: at24: driver rework and at24cs/at24mac support

FromWolfram Sang <wsa@the-dreams.de>
Date2016-07-17 20:10 +0200
SubjectRe: [RESEND PATCH 00/14] eeprom: at24: driver rework and at24cs/at24mac support
Message-ID<rVYFQ-430-17@gated-at.bofh.it>

[Multipart message — attachments visible in raw view] — view raw

On Mon, Jun 06, 2016 at 10:48:42AM +0200, Bartosz Golaszewski wrote:
> Chips from the at24cs EEPROM series have an additional read-only
> memory area containing a factory pre-programmed serial number. In
> order to access it, a dummy write must be executed before reading
> the serial number bytes.
> 
> Chips from the at24mac familiy, apart from the serial number, have
> a second special memory area containing a factory programmed
> EUI-48/EUI64 mac address.
> 
> The read-only serial/mac memory area is accessible on a different i2c
> slave address (addr + 0x08). This patchset makes it possible to
> instantiate a separate at24 device on this second address and access
> the read-only area through the regular eeprom sysfs attribute or the
> new nvmem subsystem.
> 
> This series also contains several patches refactoring the driver code.
> Most notably: the low-level read/write routines are split into more
> specialized, smaller functions that no longer perform functionality
> checks at runtime.
> 
> Minor readability tweaks are also included.
> 
> Tested with at24cs32 and at24cs02 chips (for both 16 and 8 bit address
> pointers). I have no means of testing the support for at24mac chips, I
> relied solely on the datasheet.
> 
> Bartosz Golaszewski (14):
>   eeprom: at24: improve the device_id table readability
>   eeprom: at24: move at24_read() below at24_eeprom_write()
>   eeprom: at24: coding style fixes
>   eeprom: at24: call read/write functions via function pointers
>   eeprom: at24: hide the read/write loop behind a macro
>   eeprom: at24: split at24_eeprom_read() into specialized functions
>   eeprom: at24: split at24_eeprom_write() into specialized functions
>   eeprom: at24: platform_data: use BIT() macro
>   eeprom: at24: platform_data: add serial number flag
>   eeprom: at24: support reading the serial number
>   eeprom: at24: add the at24cs series to the list of supported devices

I changed the 128 / 8 to 16 as discussed and squashed the last 3 patches
into 1 here...

>   eeprom: at24: platform_data: add at24mac series flag
>   eeprom: at24: add support for at24mac series
>   eeprom: at24: add at24mac chips to the list of supported devices

... and here.

After that, applied to for-next , thanks!

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web