Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1441655 > unrolled thread

Re: [PULL] lkdtm update (next)

Started byKees Cook <keescook@chromium.org>
First post2016-07-12 20:50 +0200
Last post2016-07-13 05:10 +0200
Articles 3 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PULL] lkdtm update (next) Kees Cook <keescook@chromium.org> - 2016-07-12 20:50 +0200
    Re: [PULL] lkdtm update (next) Greg KH <gregkh@linuxfoundation.org> - 2016-07-13 03:10 +0200
      Re: [PULL] lkdtm update (next) Kees Cook <keescook@chromium.org> - 2016-07-13 05:10 +0200

#1441655 — Re: [PULL] lkdtm update (next)

FromKees Cook <keescook@chromium.org>
Date2016-07-12 20:50 +0200
SubjectRe: [PULL] lkdtm update (next)
Message-ID<rUaUO-iN-15@gated-at.bofh.it>
On Thu, Jul 7, 2016 at 2:14 PM, Kees Cook <keescook@chromium.org> wrote:
> Hi,
>
> Please pull these lkdtm changes for next.

Friendly ping... I'd like this refactor to make it in time for the 4.8
merge window. :)

-Kees

>
> Thanks!
>
> -Kees
>
> The following changes since commit e2402b1d214e5d50e807773563d590115a161f45:
>
>   nvmem: imx-ocotp: Fix assignment warning. (2016-06-25 07:42:55 -0700)
>
> are available in the git repository at:
>
>   git://git.kernel.org/pub/scm/linux/kernel/git/kees/linux.git tags/lkdtm-next
>
> for you to fetch changes up to c479e3fd88703c4b1049d7102a3fa8c6b3affef5:
>
>   lkdtm: use struct arrays instead of enums (2016-07-07 11:09:27 -0700)
>
> ----------------------------------------------------------------
> refactoring for multiple source files and better layout
>
> ----------------------------------------------------------------
> Kees Cook (12):
>       lkdtm: add usercopy test for blocking kernel text
>       lkdtm: drop "alloc_size" parameter
>       lkdtm: split usercopy tests to separate file
>       lkdtm: split memory permissions tests to separate file
>       lkdtm: split heap corruption tests to separate file
>       lkdtm: split remaining logic bug tests to separate file
>       lkdtm: remove intentional off-by-one array access
>       lkdtm: rename "count" to "crash_count"
>       lkdtm: rename globals for clarity
>       lkdtm: reorganize module paramaters
>       lkdtm: move jprobe entry points to start of source
>       lkdtm: use struct arrays instead of enums
>
>  drivers/misc/Makefile         |    4 +
>  drivers/misc/lkdtm.h          |   51 ++
>  drivers/misc/lkdtm_bugs.c     |  152 +++++
>  drivers/misc/lkdtm_core.c     | 1246 ++++++++---------------------------------
>  drivers/misc/lkdtm_heap.c     |  146 +++++
>  drivers/misc/lkdtm_perms.c    |  203 +++++++
>  drivers/misc/lkdtm_usercopy.c |  315 +++++++++++
>  7 files changed, 1106 insertions(+), 1011 deletions(-)
>  create mode 100644 drivers/misc/lkdtm_bugs.c
>  create mode 100644 drivers/misc/lkdtm_heap.c
>  create mode 100644 drivers/misc/lkdtm_perms.c
>  create mode 100644 drivers/misc/lkdtm_usercopy.c
>
> --
> Kees Cook
> Chrome OS & Brillo Security



-- 
Kees Cook
Chrome OS & Brillo Security

[toc] | [next] | [standalone]


#1441940

FromGreg KH <gregkh@linuxfoundation.org>
Date2016-07-13 03:10 +0200
Message-ID<rUgQx-4nw-13@gated-at.bofh.it>
In reply to#1441655
On Tue, Jul 12, 2016 at 02:42:22PM -0400, Kees Cook wrote:
> On Thu, Jul 7, 2016 at 2:14 PM, Kees Cook <keescook@chromium.org> wrote:
> > Hi,
> >
> > Please pull these lkdtm changes for next.
> 
> Friendly ping... I'd like this refactor to make it in time for the 4.8
> merge window. :)

Sorry, was on vacation last week, and am at LinuxCon Japan this week,
will get to it in a day or so.  Don't worry, it will make 4.8 :)

greg k-h

[toc] | [prev] | [next] | [standalone]


#1441979

FromKees Cook <keescook@chromium.org>
Date2016-07-13 05:10 +0200
Message-ID<rUiIF-5G6-7@gated-at.bofh.it>
In reply to#1441940
On Tue, Jul 12, 2016 at 9:00 PM, Greg KH <gregkh@linuxfoundation.org> wrote:
> On Tue, Jul 12, 2016 at 02:42:22PM -0400, Kees Cook wrote:
>> On Thu, Jul 7, 2016 at 2:14 PM, Kees Cook <keescook@chromium.org> wrote:
>> > Hi,
>> >
>> > Please pull these lkdtm changes for next.
>>
>> Friendly ping... I'd like this refactor to make it in time for the 4.8
>> merge window. :)
>
> Sorry, was on vacation last week, and am at LinuxCon Japan this week,
> will get to it in a day or so.  Don't worry, it will make 4.8 :)

Awesome, thanks!

-Kees

-- 
Kees Cook
Chrome OS & Brillo Security

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web