Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1436856 > unrolled thread
| Started by | Joseph Lo <josephl@nvidia.com> |
|---|---|
| First post | 2016-07-05 11:10 +0200 |
| Last post | 2016-07-07 20:50 +0200 |
| Articles | 6 — 3 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
[PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox Joseph Lo <josephl@nvidia.com> - 2016-07-05 11:10 +0200
Re: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox Stephen Warren <swarren@wwwdotorg.org> - 2016-07-06 19:10 +0200
Re: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox Joseph Lo <josephl@nvidia.com> - 2016-07-07 08:30 +0200
Re: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox Sivaram Nair <sivaramn@nvidia.com> - 2016-07-07 20:20 +0200
Re: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox Stephen Warren <swarren@wwwdotorg.org> - 2016-07-07 20:40 +0200
Re: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox Sivaram Nair <sivaramn@nvidia.com> - 2016-07-07 20:50 +0200
| From | Joseph Lo <josephl@nvidia.com> |
|---|---|
| Date | 2016-07-05 11:10 +0200 |
| Subject | [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox |
| Message-ID | <rRuwF-MJ-13@gated-at.bofh.it> |
Add DT binding for the Hardware Synchronization Primitives (HSP). The
HSP is designed for the processors to share resources and communicate
together. It provides a set of hardware synchronization primitives for
interprocessor communication. So the interprocessor communication (IPC)
protocols can use hardware synchronization primitive, when operating
between two processors not in an SMP relationship.
Signed-off-by: Joseph Lo <josephl@nvidia.com>
---
Changes in V2:
- revise the compatible string, interrupt-names, interrupts, and #mbox-cells
properties
- remove "nvidia,hsp-function" property
- fix the header file name
- the binding supports the concept of multiple HSP sub-modules on one HSP HW
block now.
---
.../bindings/mailbox/nvidia,tegra186-hsp.txt | 51 ++++++++++++++++++++++
include/dt-bindings/mailbox/tegra186-hsp.h | 23 ++++++++++
2 files changed, 74 insertions(+)
create mode 100644 Documentation/devicetree/bindings/mailbox/nvidia,tegra186-hsp.txt
create mode 100644 include/dt-bindings/mailbox/tegra186-hsp.h
diff --git a/Documentation/devicetree/bindings/mailbox/nvidia,tegra186-hsp.txt b/Documentation/devicetree/bindings/mailbox/nvidia,tegra186-hsp.txt
new file mode 100644
index 000000000000..10e53edbe1c7
--- /dev/null
+++ b/Documentation/devicetree/bindings/mailbox/nvidia,tegra186-hsp.txt
@@ -0,0 +1,51 @@
+NVIDIA Tegra Hardware Synchronization Primitives (HSP)
+
+The HSP modules are used for the processors to share resources and communicate
+together. It provides a set of hardware synchronization primitives for
+interprocessor communication. So the interprocessor communication (IPC)
+protocols can use hardware synchronization primitives, when operating between
+two processors not in an SMP relationship.
+
+The features that HSP supported are shared mailboxes, shared semaphores,
+arbitrated semaphores and doorbells.
+
+Required properties:
+- name : Should be hsp
+- compatible
+ Array of strings.
+ one of:
+ - "nvidia,tegra186-hsp"
+- reg : Offset and length of the register set for the device.
+- interrupt-names
+ Array of strings.
+ Contains a list of names for the interrupts described by the interrupt
+ property. May contain the following entries, in any order:
+ - "doorbell"
+ Users of this binding MUST look up entries in the interrupt property
+ by name, using this interrupt-names property to do so.
+- interrupts
+ Array of interrupt specifiers.
+ Must contain one entry per entry in the interrupt-names property,
+ in a matching order.
+- #mbox-cells : Should be 1.
+
+The mbox specifier of the "mboxes" property in the client node should use
+the "HSP_MBOX_ID" macro which integrates the HSP type and master ID data.
+Those information can be found in the following file.
+
+- <dt-bindings/mailbox/tegra186-hsp.h>.
+
+Example:
+
+hsp_top0: hsp@3c00000 {
+ compatible = "nvidia,tegra186-hsp";
+ reg = <0x0 0x03c00000 0x0 0xa0000>;
+ interrupts = <GIC_SPI 176 IRQ_TYPE_LEVEL_HIGH>;
+ interrupt-names = "doorbell";
+ #mbox-cells = <1>;
+};
+
+client {
+ ...
+ mboxes = <&hsp_top0 HSP_MBOX_ID(DB, HSP_DB_MASTER_XXX)>;
+};
diff --git a/include/dt-bindings/mailbox/tegra186-hsp.h b/include/dt-bindings/mailbox/tegra186-hsp.h
new file mode 100644
index 000000000000..365dbeb5d894
--- /dev/null
+++ b/include/dt-bindings/mailbox/tegra186-hsp.h
@@ -0,0 +1,23 @@
+/*
+ * This header provides constants for binding nvidia,tegra186-hsp.
+ *
+ * The number with HSP_DB_MASTER prefix indicates the bit that is
+ * associated with a master ID in the doorbell registers.
+ */
+
+
+#ifndef _DT_BINDINGS_MAILBOX_TEGRA186_HSP_H
+#define _DT_BINDINGS_MAILBOX_TEGRA186_HSP_H
+
+#define HSP_MBOX_TYPE_DB 0x0
+#define HSP_MBOX_TYPE_SM 0x1
+#define HSP_MBOX_TYPE_SS 0x2
+#define HSP_MBOX_TYPE_AS 0x3
+
+#define HSP_DB_MASTER_CCPLEX 17
+#define HSP_DB_MASTER_BPMP 19
+
+#define HSP_MBOX_ID(type, ID) \
+ (HSP_MBOX_TYPE_##type << 16 | ID)
+
+#endif /* _DT_BINDINGS_MAILBOX_TEGRA186_HSP_H */
--
2.9.0
[toc] | [next] | [standalone]
| From | Stephen Warren <swarren@wwwdotorg.org> |
|---|---|
| Date | 2016-07-06 19:10 +0200 |
| Subject | Re: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox |
| Message-ID | <rRYuK-3wy-35@gated-at.bofh.it> |
| In reply to | #1436856 |
On 07/05/2016 03:04 AM, Joseph Lo wrote: > Add DT binding for the Hardware Synchronization Primitives (HSP). The > HSP is designed for the processors to share resources and communicate > together. It provides a set of hardware synchronization primitives for > interprocessor communication. So the interprocessor communication (IPC) > protocols can use hardware synchronization primitive, when operating > between two processors not in an SMP relationship. Acked-by: Stephen Warren <swarren@nvidia.com>
[toc] | [prev] | [next] | [standalone]
| From | Joseph Lo <josephl@nvidia.com> |
|---|---|
| Date | 2016-07-07 08:30 +0200 |
| Subject | Re: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox |
| Message-ID | <rSaYV-3ar-5@gated-at.bofh.it> |
| In reply to | #1437855 |
On 07/07/2016 01:02 AM, Stephen Warren wrote: > On 07/05/2016 03:04 AM, Joseph Lo wrote: >> Add DT binding for the Hardware Synchronization Primitives (HSP). The >> HSP is designed for the processors to share resources and communicate >> together. It provides a set of hardware synchronization primitives for >> interprocessor communication. So the interprocessor communication (IPC) >> protocols can use hardware synchronization primitive, when operating >> between two processors not in an SMP relationship. > > Acked-by: Stephen Warren <swarren@nvidia.com> Thanks, -Joseph > -- > To unsubscribe from this list: send the line "unsubscribe linux-tegra" in > the body of a message to majordomo@vger.kernel.org > More majordomo info at http://vger.kernel.org/majordomo-info.html
[toc] | [prev] | [next] | [standalone]
| From | Sivaram Nair <sivaramn@nvidia.com> |
|---|---|
| Date | 2016-07-07 20:20 +0200 |
| Subject | Re: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox |
| Message-ID | <rSm42-23N-3@gated-at.bofh.it> |
| In reply to | #1436856 |
On Tue, Jul 05, 2016 at 05:04:22PM +0800, Joseph Lo wrote:
> Add DT binding for the Hardware Synchronization Primitives (HSP). The
> HSP is designed for the processors to share resources and communicate
> together. It provides a set of hardware synchronization primitives for
> interprocessor communication. So the interprocessor communication (IPC)
> protocols can use hardware synchronization primitive, when operating
> between two processors not in an SMP relationship.
>
> Signed-off-by: Joseph Lo <josephl@nvidia.com>
> ---
> Changes in V2:
> - revise the compatible string, interrupt-names, interrupts, and #mbox-cells
> properties
> - remove "nvidia,hsp-function" property
> - fix the header file name
> - the binding supports the concept of multiple HSP sub-modules on one HSP HW
> block now.
> ---
> .../bindings/mailbox/nvidia,tegra186-hsp.txt | 51 ++++++++++++++++++++++
> include/dt-bindings/mailbox/tegra186-hsp.h | 23 ++++++++++
> 2 files changed, 74 insertions(+)
> create mode 100644 Documentation/devicetree/bindings/mailbox/nvidia,tegra186-hsp.txt
> create mode 100644 include/dt-bindings/mailbox/tegra186-hsp.h
>
> diff --git a/Documentation/devicetree/bindings/mailbox/nvidia,tegra186-hsp.txt b/Documentation/devicetree/bindings/mailbox/nvidia,tegra186-hsp.txt
> new file mode 100644
> index 000000000000..10e53edbe1c7
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/mailbox/nvidia,tegra186-hsp.txt
> @@ -0,0 +1,51 @@
> +NVIDIA Tegra Hardware Synchronization Primitives (HSP)
> +
> +The HSP modules are used for the processors to share resources and communicate
> +together. It provides a set of hardware synchronization primitives for
> +interprocessor communication. So the interprocessor communication (IPC)
> +protocols can use hardware synchronization primitives, when operating between
> +two processors not in an SMP relationship.
> +
> +The features that HSP supported are shared mailboxes, shared semaphores,
> +arbitrated semaphores and doorbells.
> +
> +Required properties:
> +- name : Should be hsp
> +- compatible
> + Array of strings.
> + one of:
> + - "nvidia,tegra186-hsp"
> +- reg : Offset and length of the register set for the device.
> +- interrupt-names
> + Array of strings.
> + Contains a list of names for the interrupts described by the interrupt
> + property. May contain the following entries, in any order:
> + - "doorbell"
> + Users of this binding MUST look up entries in the interrupt property
> + by name, using this interrupt-names property to do so.
> +- interrupts
> + Array of interrupt specifiers.
> + Must contain one entry per entry in the interrupt-names property,
> + in a matching order.
> +- #mbox-cells : Should be 1.
> +
> +The mbox specifier of the "mboxes" property in the client node should use
> +the "HSP_MBOX_ID" macro which integrates the HSP type and master ID data.
> +Those information can be found in the following file.
> +
> +- <dt-bindings/mailbox/tegra186-hsp.h>.
> +
> +Example:
> +
> +hsp_top0: hsp@3c00000 {
> + compatible = "nvidia,tegra186-hsp";
> + reg = <0x0 0x03c00000 0x0 0xa0000>;
> + interrupts = <GIC_SPI 176 IRQ_TYPE_LEVEL_HIGH>;
> + interrupt-names = "doorbell";
> + #mbox-cells = <1>;
> +};
> +
> +client {
> + ...
> + mboxes = <&hsp_top0 HSP_MBOX_ID(DB, HSP_DB_MASTER_XXX)>;
> +};
> diff --git a/include/dt-bindings/mailbox/tegra186-hsp.h b/include/dt-bindings/mailbox/tegra186-hsp.h
> new file mode 100644
> index 000000000000..365dbeb5d894
> --- /dev/null
> +++ b/include/dt-bindings/mailbox/tegra186-hsp.h
> @@ -0,0 +1,23 @@
> +/*
> + * This header provides constants for binding nvidia,tegra186-hsp.
> + *
> + * The number with HSP_DB_MASTER prefix indicates the bit that is
> + * associated with a master ID in the doorbell registers.
> + */
> +
> +
> +#ifndef _DT_BINDINGS_MAILBOX_TEGRA186_HSP_H
> +#define _DT_BINDINGS_MAILBOX_TEGRA186_HSP_H
> +
> +#define HSP_MBOX_TYPE_DB 0x0
> +#define HSP_MBOX_TYPE_SM 0x1
> +#define HSP_MBOX_TYPE_SS 0x2
> +#define HSP_MBOX_TYPE_AS 0x3
> +
> +#define HSP_DB_MASTER_CCPLEX 17
> +#define HSP_DB_MASTER_BPMP 19
> +
> +#define HSP_MBOX_ID(type, ID) \
> + (HSP_MBOX_TYPE_##type << 16 | ID)
It will be nicer if you avoid the macro glue magic '##' for 'type'. I
would also suggest to use braces around 'type' and 'ID'.
> +
> +#endif /* _DT_BINDINGS_MAILBOX_TEGRA186_HSP_H */
> --
> 2.9.0
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-tegra" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
[toc] | [prev] | [next] | [standalone]
| From | Stephen Warren <swarren@wwwdotorg.org> |
|---|---|
| Date | 2016-07-07 20:40 +0200 |
| Subject | Re: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox |
| Message-ID | <rSmnn-2ax-11@gated-at.bofh.it> |
| In reply to | #1438786 |
On 07/07/2016 12:13 PM, Sivaram Nair wrote: > On Tue, Jul 05, 2016 at 05:04:22PM +0800, Joseph Lo wrote: >> Add DT binding for the Hardware Synchronization Primitives (HSP). The >> HSP is designed for the processors to share resources and communicate >> together. It provides a set of hardware synchronization primitives for >> interprocessor communication. So the interprocessor communication (IPC) >> protocols can use hardware synchronization primitive, when operating >> between two processors not in an SMP relationship. >> diff --git a/include/dt-bindings/mailbox/tegra186-hsp.h b/include/dt-bindings/mailbox/tegra186-hsp.h >> +#define HSP_MBOX_TYPE_DB 0x0 >> +#define HSP_MBOX_TYPE_SM 0x1 >> +#define HSP_MBOX_TYPE_SS 0x2 >> +#define HSP_MBOX_TYPE_AS 0x3 >> + >> +#define HSP_DB_MASTER_CCPLEX 17 >> +#define HSP_DB_MASTER_BPMP 19 >> + >> +#define HSP_MBOX_ID(type, ID) \ >> + (HSP_MBOX_TYPE_##type << 16 | ID) > > It will be nicer if you avoid the macro glue magic '##' for 'type'. I > would also suggest to use braces around 'type' and 'ID'. This technique been used without issue in quite a few other places without issue, and has the benefit of simplifying the text wherever the macro is used. What issue do you foresee? BTW, if this patch does need reposting, I'd suggest s/ID/id/ since macro parameters are usually lower-case.
[toc] | [prev] | [next] | [standalone]
| From | Sivaram Nair <sivaramn@nvidia.com> |
|---|---|
| Date | 2016-07-07 20:50 +0200 |
| Subject | Re: [PATCH V2 01/10] Documentation: dt-bindings: mailbox: tegra: Add binding for HSP mailbox |
| Message-ID | <rSmx4-2ew-17@gated-at.bofh.it> |
| In reply to | #1438796 |
On Thu, Jul 07, 2016 at 12:35:02PM -0600, Stephen Warren wrote: > On 07/07/2016 12:13 PM, Sivaram Nair wrote: > >On Tue, Jul 05, 2016 at 05:04:22PM +0800, Joseph Lo wrote: > >>Add DT binding for the Hardware Synchronization Primitives (HSP). The > >>HSP is designed for the processors to share resources and communicate > >>together. It provides a set of hardware synchronization primitives for > >>interprocessor communication. So the interprocessor communication (IPC) > >>protocols can use hardware synchronization primitive, when operating > >>between two processors not in an SMP relationship. > > >>diff --git a/include/dt-bindings/mailbox/tegra186-hsp.h b/include/dt-bindings/mailbox/tegra186-hsp.h > > >>+#define HSP_MBOX_TYPE_DB 0x0 > >>+#define HSP_MBOX_TYPE_SM 0x1 > >>+#define HSP_MBOX_TYPE_SS 0x2 > >>+#define HSP_MBOX_TYPE_AS 0x3 > >>+ > >>+#define HSP_DB_MASTER_CCPLEX 17 > >>+#define HSP_DB_MASTER_BPMP 19 > >>+ > >>+#define HSP_MBOX_ID(type, ID) \ > >>+ (HSP_MBOX_TYPE_##type << 16 | ID) > > > >It will be nicer if you avoid the macro glue magic '##' for 'type'. I > >would also suggest to use braces around 'type' and 'ID'. > > This technique been used without issue in quite a few other places > without issue, and has the benefit of simplifying the text wherever > the macro is used. What issue do you foresee? It improves readability where HSP_MBOX_ID is used (in tegra186.dtsi file in this case) - but consider this as a cosmetic comment. > > BTW, if this patch does need reposting, I'd suggest s/ID/id/ since > macro parameters are usually lower-case.
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web