Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1434567 > unrolled thread

[PATCH v23 04/22] vfs: Make the inode passed to inode_change_ok non-const

Started byAndreas Gruenbacher <agruenba@redhat.com>
First post2016-06-30 16:00 +0200
Last post2016-07-05 13:20 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  [PATCH v23 04/22] vfs: Make the inode passed to inode_change_ok non-const Andreas Gruenbacher <agruenba@redhat.com> - 2016-06-30 16:00 +0200
    Re: [PATCH v23 04/22] vfs: Make the inode passed to inode_change_ok  non-const Jeff Layton <jlayton@redhat.com> - 2016-07-05 13:20 +0200

#1434567 — [PATCH v23 04/22] vfs: Make the inode passed to inode_change_ok non-const

FromAndreas Gruenbacher <agruenba@redhat.com>
Date2016-06-30 16:00 +0200
Subject[PATCH v23 04/22] vfs: Make the inode passed to inode_change_ok non-const
Message-ID<rPKFz-1Pr-9@gated-at.bofh.it>
We will need to call iop->permission and iop->get_acl from
inode_change_ok() for additional permission checks, and both take a
non-const inode.

Signed-off-by: Andreas Gruenbacher <agruenba@redhat.com>
Reviewed-by: J. Bruce Fields <bfields@redhat.com>
Reviewed-by: Andreas Dilger <adilger@dilger.ca>
Reviewed-by: Steve French <steve.french@primarydata.com>
---
 fs/attr.c          | 2 +-
 include/linux/fs.h | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/fs/attr.c b/fs/attr.c
index 25b24d0..7ca7fa0 100644
--- a/fs/attr.c
+++ b/fs/attr.c
@@ -28,7 +28,7 @@
  * Should be called as the first thing in ->setattr implementations,
  * possibly after taking additional locks.
  */
-int inode_change_ok(const struct inode *inode, struct iattr *attr)
+int inode_change_ok(struct inode *inode, struct iattr *attr)
 {
 	unsigned int ia_valid = attr->ia_valid;
 
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 86bfa10..208f73b 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -2993,7 +2993,7 @@ extern int buffer_migrate_page(struct address_space *,
 #define buffer_migrate_page NULL
 #endif
 
-extern int inode_change_ok(const struct inode *, struct iattr *);
+extern int inode_change_ok(struct inode *, struct iattr *);
 extern int inode_newsize_ok(const struct inode *, loff_t offset);
 extern void setattr_copy(struct inode *inode, const struct iattr *attr);
 
-- 
2.5.5

[toc] | [next] | [standalone]


#1436930 — Re: [PATCH v23 04/22] vfs: Make the inode passed to inode_change_ok non-const

FromJeff Layton <jlayton@redhat.com>
Date2016-07-05 13:20 +0200
SubjectRe: [PATCH v23 04/22] vfs: Make the inode passed to inode_change_ok non-const
Message-ID<rRwyt-24B-9@gated-at.bofh.it>
In reply to#1434567
On Thu, 2016-06-30 at 15:46 +0200, Andreas Gruenbacher wrote:
> We will need to call iop->permission and iop->get_acl from
> inode_change_ok() for additional permission checks, and both take a
> non-const inode.
> 
> Signed-off-by: Andreas Gruenbacher <agruenba@redhat.com>
> Reviewed-by: J. Bruce Fields <bfields@redhat.com>
> Reviewed-by: Andreas Dilger <adilger@dilger.ca>
> Reviewed-by: Steve French <steve.french@primarydata.com>
> ---
>  fs/attr.c          | 2 +-
>  include/linux/fs.h | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/fs/attr.c b/fs/attr.c
> index 25b24d0..7ca7fa0 100644
> --- a/fs/attr.c
> +++ b/fs/attr.c
> @@ -28,7 +28,7 @@
>   * Should be called as the first thing in ->setattr implementations,
>   * possibly after taking additional locks.
>   */
> -int inode_change_ok(const struct inode *inode, struct iattr *attr)
> +int inode_change_ok(struct inode *inode, struct iattr *attr)
>  {
>  	unsigned int ia_valid = attr->ia_valid;
>  
> diff --git a/include/linux/fs.h b/include/linux/fs.h
> index 86bfa10..208f73b 100644
> --- a/include/linux/fs.h
> +++ b/include/linux/fs.h
> @@ -2993,7 +2993,7 @@ extern int buffer_migrate_page(struct address_space *,
>  #define buffer_migrate_page NULL
>  #endif
>  
> -extern int inode_change_ok(const struct inode *, struct iattr *);
> +extern int inode_change_ok(struct inode *, struct iattr *);
>  extern int inode_newsize_ok(const struct inode *, loff_t offset);
>  extern void setattr_copy(struct inode *inode, const struct iattr *attr);
>  

Yuck. Bummer to lose the "const" there, but it doesn't look like it's
possible to make those ops take a const arg.

Reviewed-by: Jeff Layton <jlayton@redhat.com>

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web