Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1422012 > unrolled thread
| Started by | Mark Brown <broonie@kernel.org> |
|---|---|
| First post | 2016-06-14 17:30 +0200 |
| Last post | 2016-06-15 11:20 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH v3 1/2] ASoC: msm8916: Add codec Device Tree bindings. Mark Brown <broonie@kernel.org> - 2016-06-14 17:30 +0200
Re: [PATCH v3 1/2] ASoC: msm8916: Add codec Device Tree bindings. Srinivas Kandagatla <srinivas.kandagatla@linaro.org> - 2016-06-15 11:20 +0200
| From | Mark Brown <broonie@kernel.org> |
|---|---|
| Date | 2016-06-14 17:30 +0200 |
| Subject | Re: [PATCH v3 1/2] ASoC: msm8916: Add codec Device Tree bindings. |
| Message-ID | <rJYrT-6Cf-17@gated-at.bofh.it> |
[Multipart message — attachments visible in raw view] — view raw
On Fri, Jun 10, 2016 at 07:18:44PM +0100, Srinivas Kandagatla wrote: > +Codec IP is divided into two parts, first analog which is integrated in pmic pm8916 > +and secondly digital part which is integrated into application processor. Codec register > +controls are also split across pmic an lpass. Analog part is controlled via spmi bus to pmic. Please keep things wrapped at less than 80 columns. > + - interrupt-parent : The parent interrupt controller. > + - interrupts: List of interrupts in given SPMI peripheral. > + - interrupt-names: Names specified to above list of interrupts in same > + order. List of supported interrupt names are: > + "spk_cnp_int" - Speaker click and pop interrupt Please format this more clearly so these don't look like properties, more indentation would be good. > + - vddio-supply: phandle to VDD_CDC_IO regulator device tree node. > + - vdd-tx-rx-supply: phandle to VDD_CDC_TX/RX/CX regulator device tree node. You should name the supplies with the same name as the datasheet uses.
[toc] | [next] | [standalone]
| From | Srinivas Kandagatla <srinivas.kandagatla@linaro.org> |
|---|---|
| Date | 2016-06-15 11:20 +0200 |
| Message-ID | <rKf9n-F4-1@gated-at.bofh.it> |
| In reply to | #1422012 |
Thanks for review comments, On 14/06/16 16:23, Mark Brown wrote: > On Fri, Jun 10, 2016 at 07:18:44PM +0100, Srinivas Kandagatla wrote: > >> +Codec IP is divided into two parts, first analog which is integrated in pmic pm8916 >> +and secondly digital part which is integrated into application processor. Codec register >> +controls are also split across pmic an lpass. Analog part is controlled via spmi bus to pmic. > > Please keep things wrapped at less than 80 columns. Yep, will fix it in next version. > >> + - interrupt-parent : The parent interrupt controller. >> + - interrupts: List of interrupts in given SPMI peripheral. >> + - interrupt-names: Names specified to above list of interrupts in same >> + order. List of supported interrupt names are: >> + "spk_cnp_int" - Speaker click and pop interrupt > > Please format this more clearly so these don't look like properties, > more indentation would be good. Ok, will do it in next version. > >> + - vddio-supply: phandle to VDD_CDC_IO regulator device tree node. >> + - vdd-tx-rx-supply: phandle to VDD_CDC_TX/RX/CX regulator device tree node. > > You should name the supplies with the same name as the datasheet uses. > Yep, I will rename them to match the hw specs. thanks, srini
[toc] | [prev] | [standalone]
Back to top | Article view | linux.kernel
csiph-web