Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1420547 > unrolled thread

Re: [PATCH v4 7/7] unicore32: use the new LED disk activity trigger

Started byJacek Anaszewski <j.anaszewski@samsung.com>
First post2016-06-13 10:00 +0200
Last post2016-06-14 04:20 +0200
Articles 2 — 2 participants

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [PATCH v4 7/7] unicore32: use the new LED disk activity trigger Jacek Anaszewski <j.anaszewski@samsung.com> - 2016-06-13 10:00 +0200
    Re: [PATCH v4 7/7] unicore32: use the new LED disk activity trigger "Xuetao Guan" <gxt@mprc.pku.edu.cn> - 2016-06-14 04:20 +0200

#1420547 — Re: [PATCH v4 7/7] unicore32: use the new LED disk activity trigger

FromJacek Anaszewski <j.anaszewski@samsung.com>
Date2016-06-13 10:00 +0200
SubjectRe: [PATCH v4 7/7] unicore32: use the new LED disk activity trigger
Message-ID<rJuWR-3i5-11@gated-at.bofh.it>
Hi Guan,

For consistency reasons this patch should be merged through LED tree,
but I need an ack for this.

Thanks,
Jacek Anaszewski

On 06/10/2016 08:00 AM, Stephan Linz wrote:
> - platform: rename 'ide-disk' to 'disk-activity'
> - defconfig: rename 'LEDS_TRIGGER_IDE_DISK' to 'LEDS_TRIGGER_DISK'
>
> Signed-off-by: Stephan Linz <linz@li-pro.net>
> ---
>   arch/unicore32/configs/unicore32_defconfig | 2 +-
>   arch/unicore32/kernel/gpio.c               | 2 +-
>   2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/arch/unicore32/configs/unicore32_defconfig b/arch/unicore32/configs/unicore32_defconfig
> index 45f47f8..aebd01f 100644
> --- a/arch/unicore32/configs/unicore32_defconfig
> +++ b/arch/unicore32/configs/unicore32_defconfig
> @@ -161,7 +161,7 @@ CONFIG_LEDS_GPIO=y
>   #	LED Triggers
>   CONFIG_LEDS_TRIGGERS=y
>   CONFIG_LEDS_TRIGGER_TIMER=y
> -CONFIG_LEDS_TRIGGER_IDE_DISK=y
> +CONFIG_LEDS_TRIGGER_DISK=y
>   CONFIG_LEDS_TRIGGER_HEARTBEAT=y
>
>   #	Real Time Clock
> diff --git a/arch/unicore32/kernel/gpio.c b/arch/unicore32/kernel/gpio.c
> index 49347a0..bf164bb 100644
> --- a/arch/unicore32/kernel/gpio.c
> +++ b/arch/unicore32/kernel/gpio.c
> @@ -27,7 +27,7 @@ static const struct gpio_led puv3_gpio_leds[] = {
>   	{ .name = "cpuhealth", .gpio = GPO_CPU_HEALTH, .active_low = 0,
>   		.default_trigger = "heartbeat",	},
>   	{ .name = "hdd_led", .gpio = GPO_HDD_LED, .active_low = 1,
> -		.default_trigger = "ide-disk", },
> +		.default_trigger = "disk-activity", },
>   };
>
>   static const struct gpio_led_platform_data puv3_gpio_led_data = {
>


-- 
Best regards,
Jacek Anaszewski

[toc] | [next] | [standalone]


#1421522

From"Xuetao Guan" <gxt@mprc.pku.edu.cn>
Date2016-06-14 04:20 +0200
Message-ID<rJM7o-6NR-23@gated-at.bofh.it>
In reply to#1420547
> Hi Guan,
>
> For consistency reasons this patch should be merged through LED tree,
> but I need an ack for this.
>
> Thanks,
> Jacek Anaszewski

For uc32 code,
Acked-by: GUAN Xuetao <gxt@mprc.pku.edu.cn>

Thanks Jacek

>
> On 06/10/2016 08:00 AM, Stephan Linz wrote:
>> - platform: rename 'ide-disk' to 'disk-activity'
>> - defconfig: rename 'LEDS_TRIGGER_IDE_DISK' to 'LEDS_TRIGGER_DISK'
>>
>> Signed-off-by: Stephan Linz <linz@li-pro.net>
>> ---
>>   arch/unicore32/configs/unicore32_defconfig | 2 +-
>>   arch/unicore32/kernel/gpio.c               | 2 +-
>>   2 files changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/arch/unicore32/configs/unicore32_defconfig
>> b/arch/unicore32/configs/unicore32_defconfig
>> index 45f47f8..aebd01f 100644
>> --- a/arch/unicore32/configs/unicore32_defconfig
>> +++ b/arch/unicore32/configs/unicore32_defconfig
>> @@ -161,7 +161,7 @@ CONFIG_LEDS_GPIO=y
>>   #	LED Triggers
>>   CONFIG_LEDS_TRIGGERS=y
>>   CONFIG_LEDS_TRIGGER_TIMER=y
>> -CONFIG_LEDS_TRIGGER_IDE_DISK=y
>> +CONFIG_LEDS_TRIGGER_DISK=y
>>   CONFIG_LEDS_TRIGGER_HEARTBEAT=y
>>
>>   #	Real Time Clock
>> diff --git a/arch/unicore32/kernel/gpio.c b/arch/unicore32/kernel/gpio.c
>> index 49347a0..bf164bb 100644
>> --- a/arch/unicore32/kernel/gpio.c
>> +++ b/arch/unicore32/kernel/gpio.c
>> @@ -27,7 +27,7 @@ static const struct gpio_led puv3_gpio_leds[] = {
>>   	{ .name = "cpuhealth", .gpio = GPO_CPU_HEALTH, .active_low = 0,
>>   		.default_trigger = "heartbeat",	},
>>   	{ .name = "hdd_led", .gpio = GPO_HDD_LED, .active_low = 1,
>> -		.default_trigger = "ide-disk", },
>> +		.default_trigger = "disk-activity", },
>>   };
>>
>>   static const struct gpio_led_platform_data puv3_gpio_led_data = {
>>
>
>
> --
> Best regards,
> Jacek Anaszewski
>

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web