Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1421601 > unrolled thread
| Started by | Masahiro Yamada <yamada.masahiro@socionext.com> |
|---|---|
| First post | 2016-06-14 08:10 +0200 |
| Last post | 2016-06-14 08:10 +0200 |
| Articles | 1 — 1 participant |
Back to article view | Back to linux.kernel
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: [PATCH] kconfig.h: use already defined macros for IS_REACHABLE() define Masahiro Yamada <yamada.masahiro@socionext.com> - 2016-06-14 08:10 +0200
| From | Masahiro Yamada <yamada.masahiro@socionext.com> |
|---|---|
| Date | 2016-06-14 08:10 +0200 |
| Subject | Re: [PATCH] kconfig.h: use already defined macros for IS_REACHABLE() define |
| Message-ID | <rJPHX-P7-9@gated-at.bofh.it> |
Hi Nicolas, 2016-06-07 7:03 GMT+09:00 Nicolas Pitre <nicolas.pitre@linaro.org>: > On Tue, 7 Jun 2016, Masahiro Yamada wrote: > >> Because config_enabled() is so useful, >> maybe people tend to abuse it. >> >> I see one case where config_enabled() is used >> for a non-config macro. >> >> #define __EXPORT_SYMBOL(sym, sec) \ >> __cond_export_sym(sym, sec, config_enabled(__KSYM_##sym)) > > Here the need is for a macro that returns 1 or 0 whether given > symbol is defined or not, exactly as explained in the comment above the > definition for config_enabled() which in itself has nothing to do with > config. > > So maybe config_enabled() should be renamed to __is_defined() or > similar, and then config_enabled() or its replacement defined in termps > of it. __is_defined() seems reasonable to me, so I've sent an updated series. -- Best Regards Masahiro Yamada
Back to top | Article view | linux.kernel
csiph-web