Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1417234 > unrolled thread

Re: [RFC PATCH v1 10/18] x86/efi: Access EFI related tables in the clear

Started byMatt Fleming <matt@codeblueprint.co.uk>
First post2016-06-08 12:10 +0200
Last post2016-06-08 12:10 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.kernel

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: [RFC PATCH v1 10/18] x86/efi: Access EFI related tables in the  clear Matt Fleming <matt@codeblueprint.co.uk> - 2016-06-08 12:10 +0200

#1417234 — Re: [RFC PATCH v1 10/18] x86/efi: Access EFI related tables in the clear

FromMatt Fleming <matt@codeblueprint.co.uk>
Date2016-06-08 12:10 +0200
SubjectRe: [RFC PATCH v1 10/18] x86/efi: Access EFI related tables in the clear
Message-ID<rHIAV-7fu-9@gated-at.bofh.it>
(Sorry for the delay)

On Thu, 26 May, at 08:45:58AM, Tom Lendacky wrote:
> 
> The patch in question is patch 6/18 where PAGE_KERNEL is changed to
> include the _PAGE_ENC attribute (the encryption mask). This now
> makes FIXMAP_PAGE_NORMAL contain the encryption mask while
> FIXMAP_PAGE_IO does not. In this way, anything mapped using the
> early_ioremap call won't be mapped encrypted.

There are semantics attached to early_ioremap() that do not apply in
this case; that you're mapping an MMIO region but for EFI we just care
about noting where the firmware (not the kernel) populated the region
with data. Similar problems exist for other early boot code such as
the devicetree stuff.

early_ioremap() is not the answer.

What you really want is just some way to distinguish kernel-owned
regions from those owned by "somebody else".

I have no problem updating early_memremap() to take a @flags argument
to make that distinction, provided that the naming is generic and not
tied to AMD's SME technology via an "sme" prefix/suffix.

And making it generic should allow it to be easily sprinkled into the
shared architecture code in drivers/firmware/efi/ without issue.

I'm going to follow up with some additional comments/questions on
PATCH 10.

[toc] | [standalone]


Back to top | Article view | linux.kernel


csiph-web